-   Slackware (
-   -   [small tip] in case of Firefox' freeze (

Didier Spaier 07-03-2013 08:08 AM

[small tip] in case of Firefox' freeze
I just noticed that Firefox froze. 'top' told me that process plugin-container ate all the CPU. 'ps -Ao args|grep "plugin-container"' returned:

/usr/lib/firefox-21.0/plugin-container /usr/lib/mozilla/plugins/ -greomni /usr/lib/firefox-21.0/omni.ja -appomni
So in Firefox' menu I found Tools => Add-ons => Plugins and disabled Shockwave Flash.

PS of course other plugins could be involved, so you'll have to check which one is in each case.

EDIT. And yes, I know that "flash is bad", but that's not the point here.

Firerat 07-03-2013 08:25 AM

Install the NoScript Firefox extension and configure it to prevent flash even on trusted sites.
This way you can Click to enable only the flash frames you want to use.

David the H. 07-03-2013 04:49 PM

+1 noscript. You should have it installed anyway, since it also provides many other protections than just controlling plugins.

Also, if you start having problems with a plugin, open up a terminal and run 'pkill plugin-cont' (you only need a partial string match). This will terminate the container process without affecting the rest of Firefox. Reloading the page with the plugin object will re-launch the container.

tuxbg 07-04-2013 12:10 AM

I have the same problem.When i launch a site with lots of flash video's and firefox freeze.But when i disable shockwave how to watch flash videos ?Now i use google-chrome

Nh3xus 07-04-2013 04:48 AM

I also use NoScript in Firefox with many other security/privacy related plugins.

But if you want some basic and on-the-fly Flash activation, you can toggle the boolean "plugins.click_to_play" in about:config. :)

All times are GMT -5. The time now is 12:53 PM.