-   Slackware (
-   -   [slackware-current] Phonon applications silent/muted (

bonaire 01-02-2010 11:45 AM

[slackware-current] Phonon applications silent/muted

i have a very strange problem with Phonon. I am running slackware-current with KDE-4.3.4 on an old PC with CS46xx sound chip. The Phonon backend is Xine. The system is newly installed.

Applications which use the Phonon layer are silent or muted. I am not able to hear anything. Affected is for example Amarok, Dragon Player, Minitube or the Kde Notification system (when playing sounds). What makes the situation strange is the fact, that everything looks pretty fine:

Alsa works excellent and is configured correctly.
KMixer affects the alsa system settings as expected.
Mplayer works, Xine works, mpg321 works.
Inside Kde's system settings -> Multimedia, the Test button works and i can hear the Kde start up melody.
Inside Kde's system settings -> Notifications, the play button for sound events works and plays the given sounds.

The problem appears with a newly created user account, too.

What i also tried was to compile The output looks ok to me, too. No errors and ogg and mp3 support is available.

Last but not least i tried the Python coding tutorial at The fact, that this works, unsettles me totally.

Any ideas what causes this?


bonaire 01-02-2010 05:00 PM

From my point of view, this is a bug in phonon/xine/cs46xx driver. I now use the ugly GStreamer backend and video applications still do not work, but Amarok does. \o/

All times are GMT -5. The time now is 06:41 AM.