-   Slackware (
-   -   [Slackware 10] Cannot reduce sound volume. (

asklepios 10-10-2004 06:34 AM

[Slackware 10] Cannot reduce sound volume.
Greetings everyone,
I have a very weird problem. Somehow I just can't adjust the sound volume of my system.
Here are the relevant system specs

Distro: Slackware 10
Sound hardware: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)

I have compiled the alsa modules and they load fine (snd_intel8x0). The sound runs fine but I can't reduce or increase the volume of the sound using any of the utilities. I have tried alsamixer, rexima and Kmix but none of them work. Sound just runs at the maximum level at which it can.
The only thing I can do using these software utilities is either mute the PCM or unmute it. Nothing else. Is there anyway to reduce the sound using Kmix or any such thing?
Any help is highly appreciated.

Thanx for reading.

trickykid 10-10-2004 10:16 AM

Moved: More suitable in our Slackware forum.

typho 10-10-2004 10:44 AM

I have the same sound card and alsa has been working fine. Does it work when you are logged on as root?

asklepios 10-10-2004 12:46 PM

trickykid: thanx for moving the thread to appropriate forum.

typho: the problem persists even when i m logged in as root. i have even tried logging in to the default 2.4 series kernel to see if the problem was kernel specific but it was not. thanx for the reply. hoping to see a solution :(

predator.hawk 10-10-2004 12:57 PM

Tryed using ALSA Mixer? if not try that and tell us the resaults.

asklepios 10-10-2004 02:39 PM

predator.hawk: as i mentioned in my post i have already tried alsamixer, rexima and kmix. nothing helped

...but there has been a bit of developement.
not in the form of sound being working fine but i have found that the on-board sound card i m using is actually C-Media 9739A which has the ICH5 chipset.
this card is known to have such problems and i found a reference here
the page there ^ talks about a dmix plugin but i don't know what that is and how to configure it. can someone please help me to find more info on it or tell me how i can configure it properly?
thanx for sticking with me till now.

All times are GMT -5. The time now is 05:23 PM.