LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   [recompiled kernel] framebuffer problem and some more (https://www.linuxquestions.org/questions/slackware-14/%5Brecompiled-kernel%5D-framebuffer-problem-and-some-more-133149/)

jacktheripper 01-09-2004 01:59 PM

[recompiled kernel] framebuffer problem and some more
 
Well, i have compiled 2.6.0 kernel (WITH enabled framebuffer), rebooted (vga=773 in lilo ... 1024x768) . When lilo booted new kernel screen blinks abou 2 times and than boot without framebuffer -> without this beutiful, amazing, blabla linux logo and in standart resoltuion.... Tried few tricks with lilo, but they didnt work.
Another problem: what does it mean that when type startx and start gnome session it just shows the background (this startup background) and nothing else happens? well gnome is not very functional in this mode however i can move mouse....... i upgraded 2.2.0 to gnome 2.4.0 using swaret and this s*** happend after.

bb_matt 01-09-2004 02:11 PM

Is your /home directory an "old" one from another linux distribution or an older Slackware one ?

I had the same problem and had to clean out all my Gnome 2.2 preferences from my home folder.

I basically just did a

rm -R .g*

after checking to make sure there wasn't anything I needed there.

This will clean your old config out though !

Anyway, after cleaning that out and a whole bunch of other hidden crud from other distributions/apps, I had no problems.

About the framebuffer thing, check out page 2 of the kernel 2.6 sticky thread -
http://www.linuxquestions.org/questi...hreadid=127095

It may help you, I'm still trying to get it working too.

jacktheripper 01-10-2004 12:42 PM

yes! framebuffer worked, but gnome still doesnt... still just stays in the "loading" mode, as i call it -> just the backgrund and a mouse...
well, i also applied the nvidia patch one the kernel, and nvidia module loads, but the system shows "cannot execute /sbin/agetty" and i cant ofcourse even log in, when i press CtrlAltDel it says "reboot - unknow command" - or smth like that.... Daaaaamn i was trying to upgrade my system and ended up with it not working... help me, hilfe mich ...


All times are GMT -5. The time now is 03:44 AM.