-   Slackware (
-   -   [POLL] UEFI: can you boot DVD and/or USB installation media for Slackware64-14.1? (

Didier Spaier 11-30-2013 03:19 AM

[POLL] UEFI: can you boot DVD and/or USB installation media for Slackware64-14.1?
3 Attachment(s)
Which boot loader works best to for Slackware64-14.1 on boxes with an UEFI firmware: grub, used in the Slackware DVD or elilo, used on a Slackware USB stick?

If you can't boot a Slackware64-14.1 USB stick and/or a Slackware64-14.1 DVD under UEFI, please state the symptoms and what are your hardware and firmware.

As a reminder, instructions to put an installer on an USB stick are in /usb-and-pxe-installers/README_USB.TXT.

PS Please answer only if you have an UEFI firmware.

PPS I have uploaded three screenshots:
  1. elilo1 is what you should see when using an USB stick
  2. elilo2 is what you should see some time after having booted from an USB stick
  3. grub1 is what you should see when using a DVD

PPPS To make an USB installer, use the dd command, but not the script as because of a known issue the USB stick couldn't boot on UEFI

Phorize 11-30-2013 06:56 AM

My hardware is:

Z77 Asrock Extreme 4 board with the latest uefi firmware (2.90).

When booting into uefi mode from the official Slackware64 dvd it takes around 2 minutes for the grub boot menu to appear. This can give the appearance of a freeze to those expecting grub to respond quickly.

EYo 11-30-2013 01:25 PM

Hewlett Packard UEFI

HP Envy H8-1445 (AMD FX-8120) August 2012
BIOS: An2_8.1- v8.10

Sorry for the noise, still using MBR on this drive. UEFI is enabled but Win8 (and the GPT) are long gone.
After reading Didier's update, looks like I have Grub (-efi fall back to MBR) success on the DVD boot, and then elilo1 failure on the USB boot.

Buumi 11-30-2013 01:53 PM

Well USB boots ok but I haven't simply tested DVD so can't really say it doesn't work.

fieldaj 11-30-2013 02:33 PM

Motherboard: Asus Sabertooth 990FX R2.0
BIOS: American Megatrends Version 0906. Release date: 09/17/2012
CPU: AMD8320 8 Core

Can boot the Official Slackware 64 bit DVD in UEFI mode fine. Have not tried USB boot.

Second machine: motherboard Asus M5A99FX PRO R2.0
BIOS: American Megatrends Ver 1503 Date 01/11/2013

Same result, Slackware Official DVD boots fine in UEFI mode. Didn't try USB.

trainee 12-05-2013 08:06 PM

My laptop is a SONY VAIO T . I could not boot from a USB stick (I tested the USB stick on another desktop and it booted OK). Yet, if I boot using an external DVD drive connecting through the same USB port, it boot OK. I suspect it might have something to do with ELILO.

arubin 12-06-2013 08:14 AM

My system is UEFI but it was a Windows machine purchased before secure boot and I was able to boot from the Slack 14.0 DVD let alone 14.1

Currently using rEFINd. All I had to do on installing 14.1 was copy the kernel to the EFI partition and adjust some lines in refind.conf

The USB stick created by the 14.1 installation boots fine.

All times are GMT -5. The time now is 03:00 PM.