LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-31-2004, 12:15 AM   #1
simonchen
LQ Newbie
 
Registered: Dec 2004
Location: Vancouver
Posts: 2

Rep: Reputation: 0
[Help] Cannot connect to Internet


Recently, I installed the Slackware 10. And I followed the NETCONFIG installation to setup my network.


I'm using ADSL to hook up the net. The ISP provide 2 dynamic IPs for me. They only check Network Card Address(MAC address) to allowed my PC to access the Internet.

Some info. as follow, hope it will help.

Code:
ifconfig
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:82 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:4532 (4.4 Kb)  TX bytes:4532 (4.4 Kb)[quote]

ifconfig eth0
eth0      Link encap:Ethernet  HWaddr 00:00:E8:E7:AC:D0
          BROADCAST NOTRAILERS MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Base address:0x9400
Code:
/etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"
anyone have any idea how can I slove this problem??

Thank in advance~~

BTW, as you can see,I'm a newbie in Linux. Please reply the answer fully and simply.
 
Old 12-31-2004, 12:20 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
I've never used ASDL so the following might be completely wrong.....

what does the output of lsmod say? Do you have the correct drivers installed? If I remember correctly, pppoe (the kernel driver) was required for DSL connections.
 
Old 12-31-2004, 02:34 AM   #3
beanerjo
Member
 
Registered: Aug 2004
Location: New Zealand
Distribution: Slackware
Posts: 40

Rep: Reputation: 15
1. Just in case you don't get enough feedback, I think /usr/doc/Linux-HOWTOs/DSL-HOWTO might be useful.

2. It is strange that your ifconfig reports no IP address for your eth0. In my case I have
Code:
       inet addr:10.1.1.5  Bcast:10.255.255.255  Mask:255.0.0.0
on the second line.

I've got an ADSL router so the situation may be different from yours. In my case, my linux machine has the IP address 10.1.1.5, and the ADSL router is 10.1.1.1, and that router takes care of everything. Sorry for not being so helpful.

Last edited by beanerjo; 12-31-2004 at 02:41 AM.
 
Old 12-31-2004, 09:20 AM   #4
simonchen
LQ Newbie
 
Registered: Dec 2004
Location: Vancouver
Posts: 2

Original Poster
Rep: Reputation: 0
Thank for reply,_J, beanerjo
I will try those info you guys provieded.

Could that be the Slack didn't recognize my NIC card at all??

Thanks again.
 
Old 12-31-2004, 09:49 AM   #5
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
try
Code:
dhcpcd eth0
 
Old 12-31-2004, 10:17 AM   #6
CartersAdvocate
Member
 
Registered: Sep 2003
Location: Columbus, OH
Distribution: Slackware 12.2
Posts: 166

Rep: Reputation: 30
Try:

Code:
ifconfig eth0 up
It doesn't look like your ethernet card is up with an IP address, etc. That command will attempt to bring up your NIC and get an IP address through DHCP.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When i connect on the internet I want root not to access the internet !! skouket Linux - Security 12 07-10-2005 12:17 PM
Messed up my Internet Settings (can't connect to the internet) Almazick Linux - Wireless Networking 0 09-07-2004 06:23 PM
can't connect to the internet:linux dont read my internet address droplsh Linux - General 1 02-29-2004 07:32 PM
Can connect broadband but can't connect Internet satimis Linux - Networking 4 01-31-2004 07:58 PM
Can't connect to Internet Galphar Linux - Newbie 13 08-24-2003 03:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration