LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-15-2010, 05:38 AM   #1
zine92Linux
LQ Newbie
 
Registered: Apr 2010
Posts: 5

Rep: Reputation: 0
[Bootloader]Adding Linux Mint Entry to Lilo on slackware


Help appreciated. Firstly i have a triple boot on my system currently being Win7, Slackware and Linux Mint. The problem i faced was adding an custom entry to my Slackware's Lilo(I used the liloconfig in slackware) can say i like what slackware have to offer but the thing is i tried editing and adding all sorts of things but still when i boot mint, it was started properly. Normally, mint would start with verbose but then startx automatically, however this wasn't achieved and mint stops at a tty login. Any ideas on how to edit the lilo entry. Here is a sample of my lilo.conf . I really like the slackware lilo boot screen though, else i would have used grub and then chainload slack instead. Thanks appreciated.

My lilo.conf (Current)

Code:
#LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
boot = /dev/sda
# Declare LBA32
LBA32
#compact        # faster, but won't work on all systems.
# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255
# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Append any additional kernel parameters:
append=" vt.default_utf8=1"
prompt
timeout = 300
# Normal VGA console
vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# ramdisk = 0     # paranoia setting
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda5
  label = Mint
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda6
  label = Slackware
  read-only  # Partitions should be mounted read-only for checking
# Linux bootable partition config ends
# Windows bootable partition config begins
other = /dev/sda2
  label = Windows
  table = /dev/sda
# Windows bootable partition config ends
 
Old 04-15-2010, 05:57 AM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,832

Rep: Reputation: Disabled
This has nothing to do with Lilo.

You have to set up the runlevel in Mint.
 
Old 04-15-2010, 06:05 AM   #3
XGizzmo
Member
 
Registered: Mar 2007
Distribution: Slackware
Posts: 264

Rep: Reputation: 68
It looks like you are trying to load mint with the Slackware kernel. If it were me I would boot into mint and install it's
bootloader to /dev/sda5 and then boot into Slackware and setup Slackware's lilo to chain load mint just like you did windows.
 
Old 04-15-2010, 06:09 AM   #4
uppman
Member
 
Registered: Jul 2008
Location: Stockholm, Sweden
Distribution: Slackware 13.1 32-bit
Posts: 145

Rep: Reputation: 24
I don't know about the runlevels in Mint, but you can set the runlevel to X in Slackware with lilo and append="4".

Something like this *might* work:

image = /boot/vmlinuz
root = /dev/sda5
label = Mint
append="4"
read-only # Partitions should be mounted read-only for checking


/Magnus
 
Old 04-15-2010, 06:27 AM   #5
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.2
Posts: 7,809
Blog Entries: 58

Rep: Reputation: Disabled
XGizzmo's right. Edit the Mint entry in lilo.conf to read:
Code:
other = /dev/sda5
  label = Mint
 
Old 04-15-2010, 07:47 AM   #6
uppman
Member
 
Registered: Jul 2008
Location: Stockholm, Sweden
Distribution: Slackware 13.1 32-bit
Posts: 145

Rep: Reputation: 24
Oops, I didn't see that he was using the slack kernel..

Here is an updated *might* work:

mount /dev/sda5 /mnt/hd

Code:
image = /mnt/hd/boot/vmlinuz
root = /dev/sda5
label = Mint
append="4"
read-only # Partitions should be mounted read-only for checking
lilo -v
umount /mnt/hd
 
Old 04-16-2010, 08:28 AM   #7
zine92Linux
LQ Newbie
 
Registered: Apr 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks alot.
 
Old 04-16-2010, 10:25 PM   #8
zine92Linux
LQ Newbie
 
Registered: Apr 2010
Posts: 5

Original Poster
Rep: Reputation: 0
Okay. the method that uppman suggested works the best for my case but i really appreciate the help. Thanks. And for the chainloading mint as an other os method, i had to install grub or whatever bootloader in /dev/sda5 which is mint itself and i don't wanna mess around with so many bootloaders and chainloadings. So thanks people. Now i can keep my Slack. ;P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adding linux option to lilo bootloader sumeet inani Linux - Newbie 1 01-19-2009 06:29 AM
Linux mint bootloader? jmite Linux - Distributions 8 12-07-2008 10:03 AM
Adding FreeBSD on Slackware's LILO bootloader austinramsay Slackware 4 06-15-2008 01:21 PM
slackware entry in lilo decimal3 Linux - Newbie 2 09-26-2004 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration