-   Slackware (
-   -   [ANN] sbopkg 0.33.2 is released (

slakmagik 07-19-2010 10:21 PM

[ANN] sbopkg 0.33.2 is released
This release contains one security fix. If you need this, for now please get it directly from

Link to full announcement.

ponce 07-20-2010 02:00 AM

thanks slakmagik, gonna try it soon (already built a package with sspm).

piratesmack 07-20-2010 03:09 AM


brianL 07-20-2010 04:09 AM

Spent 5 minutes wondering who ANN is, and why she needs to know about a sbopkg update. ;) :)

patostevens 07-20-2010 11:22 AM

Have used sbopkg many times with no issues. Now I'm getting the following message after syncing with the repository:

unsafe ownership on configuration file '/home/pat/.g
external program calls are disabled due to unsafe options fil
keyserver communications error: general error
WARNING: unable to fetch URL
Import done

All files in /home/pat are owned by pat:pat. Where do I look to fix this?
Even better - what am I trying to fix?

slakmagik 07-20-2010 02:02 PM

patostevens: never seen that but it's probably a gpg/gnupg error. Try 'chmod 600 ~/.gnupg/gpg.conf' if it's not already. -- Actually, wait a minute. You're getting a message about /home/pat/? You should be running sbopkg as root (at this point) and it should be looking at /root/.gnupg/gpg.conf, and that should be root:root/600.

brianL: sorry about that. :)

piratesmack: welcome

ponce: great, thanks!

brianL 07-21-2010 06:26 AM


Originally Posted by slakmagik (Post 4039730)
brianL: sorry about that. :)

At first I thought she might be su and PAM's sister.

Lufbery 07-21-2010 09:10 AM


Originally Posted by brianL (Post 4040497)
At first I thought she might be su and PAM's sister.

Is she also HAL's sister?

brianL 07-21-2010 09:15 AM

I think HAL's their big brother. Creator of the famous computer which he named after himself, but which obviously wasn't running Slackware (might have been Windows 2001?).

patostevens 07-21-2010 11:18 AM

I am running sbopkg as root. I have tried playing with ownership of /home/pat/.gnupg and it's files to no avail. It doesn't who owns what, the same error comes up. Also, ownerships in the ~/.gnupg are all root:root.

Also I have removed and re-installed sbopkg - same issue.

Any other ideas?

slakmagik 07-21-2010 01:52 PM

Like I say, /home/pat/* shouldn't have anything to do with this and it's not just the ownership, but the perms - root:root with the .gnupg dir as 700 and files as 600. Re-installing sbopkg won't have any effect because it's not an sbopkg problem. Somehow gpg seems to be running as the wrong user. What may be the problem may also be a solution: do you have GNUPGHOME set anywhere or have 'gpg' aliased/functioned/scripted to anything else? If so, unset it or clear the other stuff out so it runs the correct command. If not, try making sure the perms and ownership on /root/.gnupg and its files are correct and then run 'GNUPGHOME=/root/.gnupg sbopkg'. That command just makes explicit what ought to be the default.

ponce 07-21-2010 02:09 PM

pat, try becoming root with

su -
instead of the bare

this way you should get the right environment variables.

patostevens 07-21-2010 11:40 PM

Thanks slakmagic - your suggestion to run the GNUPGHOME command seems to have fixed it. I have no idea what caused the issue as I try never to mess with the settings like that. Oh well, probably demons from the 7th circle of M$ hell attacked my system. Thanks for the help everyone.

slakmagik 07-22-2010 01:47 PM

I don't know what caused it, either, but I'm glad it's working for you now. :)

All times are GMT -5. The time now is 05:21 PM.