LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-23-2019, 07:04 AM   #1
Pipeline79
LQ Newbie
 
Registered: Sep 2018
Location: Kent, United Kingdom
Distribution: Slackware 14.2
Posts: 24

Rep: Reputation: Disabled
'System Sounds' in pavucontrol, XFCE, Slackware 14.2


OK, I just set up fetchmail to automatically pull messages from my gmail account and put them in my user mail spool. I thought it'd be nice to have xbiff running and notify me when new mail comes in. It's supposed to play a beep/bell sound as well as put the flag up.

Whilst searching through loads of suggestions to make sure the 'xkbbell' utility work, etc. and finding none of them have actually produced any sound through my monitor speaker, I've begun to think the problem might be related to pulseaudio instead.

I don't actually get any of the sounds associated with the xfce 'settings editor' > 'xsettings' > 'event sounds/input sounds/sound themename' options - even though they are now all enabled.

Sound played by applications I open, like music, all works fine. However, I have 3 output devices and every time a new stream starts, I can select which device to send it to - but, with the 'system sounds' (which are always present) in pavucontrol, it has no device option.

Is this how it's supposed to be? If not, what can I change so I can get this option? Or, if I'm supposed to find out where these sounds are already going and remap them, how do I do that?

I'm running Slackware, and in their info on pulseaudio, they mention that pulseaudio is implemented on an app request basis, I think, which tallies with what I'm seeing. There's a 'rc.pulseaudio' daemon in /etc/rc.d/. But, if I try:

Code:
$: pulseaudio -k
I get 'no such process'. So there's no daemon running from startup, I think. Maybe that's why some pactl commands like 'pactl load-module [MODULE]' don't work either.

The only thing I CAN get to make a sound like this is if I do:

Code:
$: canberra-gtk-play -i bell
 
Old 01-24-2019, 02:48 AM   #2
Brains
Member
 
Registered: Apr 2009
Distribution: Debian testing
Posts: 972

Rep: Reputation: 259Reputation: 259Reputation: 259
This is a good article to refer too. Although, by what you imply, menu item #4 in the article may not be your issue, but worth looking into, it's in regards to what happens when apps that don't use pulseaudio and go through alsa instead, which in turn screws up pulseaudio. But there is mention of a fix also.
 
Old 01-24-2019, 07:42 AM   #3
Pipeline79
LQ Newbie
 
Registered: Sep 2018
Location: Kent, United Kingdom
Distribution: Slackware 14.2
Posts: 24

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Brains View Post
This is a good article to refer too. Although, by what you imply, menu item #4 in the article may not be your issue, but worth looking into, it's in regards to what happens when apps that don't use pulseaudio and go through alsa instead, which in turn screws up pulseaudio. But there is mention of a fix also.
Thanks, yeah I'm still scouring google for what this could be. There's so many permutations my head's spinning a little.

I've tried installing a different sound theme 'Borealis' according to an XFCE moderators instructions to others. But no luck, even though it seems it should just work out the box. Similarly, it seems even though pulseaudio does not run as a daemon from login, I can just start it up as a daemon with [$: pulseaudio --start]. Then I can load a module, or anything, with pactl commands. I altered the default.pa file in /etc to cache a sample for the x11-bell module, and if I use the pactl command to play that sample by the x11-bell name, I hear it.

It seems more like something to do with 'event sounds'. Because it's when something happens I want a sound, like a message.
https://unix.stackexchange.com/quest...m-command-line But I look at that solution - editing a database file - and I think, how can it be that complicated?

I'm going to try removing pavucontrol, another suggestion, even though I would rather have it on there.
 
Old 01-24-2019, 07:59 AM   #4
rtmistler
Moderator
 
Registered: Mar 2011
Location: MA, USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 7,724
Blog Entries: 13

Rep: Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214Reputation: 3214
Moved: This thread is more suitable in Linux-Slackware and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 01-24-2019, 08:13 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,858
Blog Entries: 1

Rep: Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819
pulseaudio does NOT share audio between different users. Well it does if you enable network audio and have a $HOME/.config/pulse/client.conf with a line "default-server = 127.0.0.1" that points at the pulseaudio server for all the users who did NOT start pulseaudio. Although not sure how that works for system users that lack a $HOME/ like nobody. And enable that feature in /etc/pulse/default.pa with the line "load-module module-native-protocol-tcp auth-ip-acl=127.0.0.1". Just saying your beeps and bops might be running as a different user.

The default soundcard without pulseaudio is hw:0,0 in alsa terminology. What shows up with an index of 0 (listed first) in /proc/asound/cards. Which might not be an audio source with output (webcam), or with anything sound generating attached. For motherboards that actually have that beep speaker, the pcspkr driver uses it. Which is generally not loaded at boot and blacklisted in /etc/modprobe.d/. Various other tricks to make snd-aloop the default soundcard. And route it's output pulseaudio, which is what I do. With caveats, like my pulseaudio server is a different machine (RPi 3B+), and alsaloop needs to start "after" the soundcard is in use. And different reasons in my case, like restarting alsaloop being easier than restarting jackdbus and pulse on a remote machine.
 
Old 01-24-2019, 08:35 AM   #6
Pipeline79
LQ Newbie
 
Registered: Sep 2018
Location: Kent, United Kingdom
Distribution: Slackware 14.2
Posts: 24

Original Poster
Rep: Reputation: Disabled
OK. I've had some success. I removed pavucontrol; set the default sink to the one I want by name with pactl, set its volume and now I get the 'bell' sound when I try xkbbell and if I run xbiff with the volume set. Don't think pavucontrol was at fault because I've reinstalled it and just got a bell from xbiff for new mail.

I'm still not getting any of the other sounds from the xfce sound theme though, such as opening and closing windows, etc.
 
Old 01-25-2019, 05:17 AM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,858
Blog Entries: 1

Rep: Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819Reputation: 819
pulseaudio can be quirky. I've had to disable and enable devices to get things that were already working working again.

You might try removing the $HOME/.pulse* and $HOME/.config/pulse/* things and starting over. Or create a new user and run under it to see if it has the same issue. If you've accidentally done pulse things as root, you might have created /.pulse* things which get in the way. And otherwise changed user:group permissions of stuff under /run/user/* to root, thus deny-ing the user access. Although you wouldn't get any sound if that were the case.

# ls -l /run/user/*
 
Old 01-29-2019, 01:43 PM   #8
Pipeline79
LQ Newbie
 
Registered: Sep 2018
Location: Kent, United Kingdom
Distribution: Slackware 14.2
Posts: 24

Original Poster
Rep: Reputation: Disabled
OK, to close this - post #4 here: https://www.linuxquestions.org/quest...st-4-a-858574/

Solves the problem for me. That was from 2011.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Error starting pavucontrol on Slackware-current (32bit only) allend Slackware 2 01-18-2016 07:42 PM
[SOLVED] Can't open pavucontrol in xfce - sound not configured Higgsboson Linux - Newbie 6 01-17-2015 11:04 AM
[SOLVED] unable to install pavucontrol on slackware 14.1 64 bits allenlinux Slackware 12 12-30-2014 01:39 PM
System sounds don't work as well as sounds through a browser Bagmeijer Linux - Newbie 1 03-03-2008 11:53 AM
system sounds, yes - media sounds, no bean target Linux - Newbie 3 02-14-2006 07:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration