LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-30-2003, 10:12 PM   #1
corkyloftin
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Rep: Reputation: 0
Cant boot into Xp after installing Red Hat 9


i have had red hat 9 on my computer for about 6 months and i just had to reinstall it on my computer recently. I have Windows Xp installed on my first hard drive, and Red Hat is installed on my second hard drive in a small partition. the rest of the drive is ntfs. when i boot my computer i get the GRUB boot loader with the red hat and windows options. Red hat boots just fine. when i choose windows i get the "windows was not shut down properly screen" with the options to boot normaly, safe mode etc... When i choose ANY option it begins to load, the the computer reboots. i can just make out the Windows Xp loading screen, then it just goes black and reboots.

i know that all of my windows files are there, because i have installed ntfs support in red hat and i can mount my windows drives, and all of my files are OK.

i have also checked the grub.conf file and everything appears to be fine.

I would prefer to no delete any os from my computer. if anything red hat can be sacrificed.
 
Old 09-30-2003, 10:17 PM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
i guess you could make a linux boot disk, reboot, put in your windows setup cds, try and fix the mbr in the recovery console, boot up into linux and reinstall grub with "grub-install /dev/hda".

but it could be that windows needs to be reinstalled also, since you are getting boot up screens when choosing windows. maybe try a dirty install of xp (make a linux boot disk though so you can boot into linux and reinstall grub as i believe xp will overwrite grub).

Last edited by megaspaz; 09-30-2003 at 10:18 PM.
 
Old 10-01-2003, 03:18 AM   #3
gkoutsog
Member
 
Registered: Sep 2003
Location: Greece
Distribution: RedHat,Mandrake
Posts: 38

Rep: Reputation: 15


How about re-writing your Master Boot Record?

fdisk /mbr
 
Old 10-01-2003, 03:53 AM   #4
raceprouk
LQ Newbie
 
Registered: Sep 2003
Distribution: RH9
Posts: 11

Rep: Reputation: 0
i also suggest a reinstall of windoxe, but do remember to make a linux boot floppy first!!

then again, if it was a perfect world you wouldn't have windoze installed in the first place lol
 
Old 10-01-2003, 06:05 AM   #5
UltimaGuy
Member
 
Registered: Aug 2003
Location: Chennai, India
Distribution: PCLinuxOS .92, FC4
Posts: 840

Rep: Reputation: 32
This problem happened to me, but with a win2k installation. There were no problems, then I installed the service pack 3, and in a week the system just restarts after giving me an option to choose safe-mode et.al., saying that I have done an incomplete shut-down.

I had to finally reinstall win2k, and that is one of my sad stories with windoz...
 
Old 10-01-2003, 06:03 PM   #6
georgeg4
LQ Newbie
 
Registered: Jun 2003
Location: Pennsylvania,USA
Distribution: RedHat 9
Posts: 2

Rep: Reputation: 0
I had the exact same problem with my install of RH9 and WinXP . It is a simple fix just configure to boot from your WinXp install disk and rewrite your MBR , and then I myself prefer Lilo boot loader but that is up to you .
P.S. I am running Win98 , WinXP ,Red Hat 9 and Mandrake 9.1 on the same HDD with no problems using Lilo
 
Old 10-01-2003, 07:27 PM   #7
sernan
LQ Newbie
 
Registered: Sep 2003
Location: manila philippines
Distribution: redhat, slackware
Posts: 4

Rep: Reputation: 0
i also had that problem with redhat and xp, i issued the command fixmbr in the console then reinstall redhat.. thats it!
 
Old 10-01-2003, 07:45 PM   #8
snype
Member
 
Registered: Sep 2003
Distribution: Windows 2000(just for my ipaq), Mandrake, Knoppix(h/d install)
Posts: 57

Rep: Reputation: 15
in future lilo is better (my opinion... never had problems)
 
Old 10-02-2003, 12:09 PM   #9
Robert G. Hays
Member
 
Registered: Jan 2003
Location: Atlanta, Ga., USA
Distribution: Gentoo, Mandrake, ~others
Posts: 157

Rep: Reputation: 30
IMHO-Food For Thought.

1) I agree about lilo, but as I get to know grub better, I may change my mind -- it does have some advantages.

2) if the computer will *allow* it (and some computers (BIOS?) don't), I always put the linux loader (lilo or grub) into the Linux partitions, specifically, I always use a 3-partition scheme: /boot, /, and swap, and use a normal win/os2/dos/linux/etc MBR, thus the worst after a WInstall is having to use a floppy or something to allow me to re-set the active partition to the Linux /boot. (Also means that only /boot has to be within whatever boot-allowed limits a given computer imposes -- I currently make /boot ~~70meg.)

3) havnig said all that, I have not played with W2K or WXP on the same computer as Linux, so it may not apply -- they may do more to the MBR..... Sigh.

4) W does have the most games, and arguably still has the best A/V stuff. (Hey Guys!, We're WAI-TING!)

5) for other types of Win-Progs, try Win4Lin (www.netraverse.com), or vmware or the that new one that came out recently (sorry, don't remember name at this particular nano-second... Sigh!).

P.S.: UltimaGuy, Like your sig, whadda you think of mine?

LOL!,
Robert G. Hays
----------
Words Of Wisdom:
If you fail to plan, you plan to fail.
Be sure brain is in gear before engaging mouth.
!!THINK FIRST!! (, last, and always!)
 
Old 10-02-2003, 01:18 PM   #10
corkyloftin
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
thanks. im really busy right now, i hope to try fdisk the mbr soon.
 
Old 10-08-2003, 08:06 PM   #11
corkyloftin
LQ Newbie
 
Registered: Aug 2003
Posts: 3

Original Poster
Rep: Reputation: 0
Its not linux its windows...

well i reinstalled red hat 9 and i got the same problem.

i took my computer into my linux class (only high school linux class in the state ) my teacher and some other students worked on it and we have determinded that its a 100% windows problem, though that doesent get me anywhere.

Windows just dies sometimes...
 
Old 10-08-2003, 08:22 PM   #12
Raspis21
Member
 
Registered: Jun 2003
Posts: 33

Rep: Reputation: 15
Hi,

Your problem has nothing to do with linux, your bootloader, or our mbr.

If you can even boot to an XP loading screen, it is fine. One thing I have seen in XP (and I have worked on a lot of machines with the pig of an OS on it, no offense to those who like it) when it has symptoms like that I have found a few different things can cause it. Device drivers that get corrupted can do it. Most of the times this is the problem. But, I have also seen a kernel dump and restart from a bios glitch as well. Reseting it can help sometimes. These are the main problems I have seen with it.

I think what you might be able to do is boot with the XP cd in recovery console (total misnomer) and clean out your startup, and remove the enum directory in the registry in HKLM>LOCAL_MACHINE>ENUM. This clears all record of the device drivers, and windows will redetect them when it boots again. One caveat, if it screws up do *not* blame me...I didnt design the system

So, having said that, I wish you all the luck, I have chased problems like that before, and have found that in 1 or 2 cases, I could not get it working and had to rebuild the system. I hope that doesnt happen to you.

One thing...as a side comment...I have found that of the OSs, windows is my most expendable...when Linux crashes, you can figure out how to get it running in most cases (unless you have a hardware failure). But Windows? Sometimes not. Little thought from me to you

Hope it helps!
 
Old 10-09-2003, 07:30 PM   #13
Raspis21
Member
 
Registered: Jun 2003
Posts: 33

Rep: Reputation: 15
oops, nothing to see here, move along, move along
 
Old 11-04-2003, 10:54 PM   #14
CompEng
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Rep: Reputation: 0
Same problem

Hey,

I received to my overwhelming disappointment, the same error (Windows inproperly shutdown, would you like to start in safe mode, etc. ). However, it quickly turned in a blue screen of death saying "PFN_LIST_CORRUPT"

So well, that was nice, I tried a lot of things, however, well once you lose your admin password you're pretty much stuck. I didn't try fixmbr though...

I ended up rebooting with the windows XP CD, formatting the drive and reinstalling windows. Lovely process... argh. Anyhow needless to say after 4 hours, I finally have my dual boot system.
 
Old 11-05-2003, 11:03 AM   #15
darkelf
LQ Newbie
 
Registered: Nov 2003
Location: AUS.QLD.BRIS.HOME
Distribution: Redhat 8.0
Posts: 5

Rep: Reputation: 0
just had an unlucky BSOD with XP after trying to use demo drivers to view my EXT3 drives... now I have to rewrite my MBR too. Just wait 9in vain I know) for photoshop for linux, I'll throw XP out as soon a photoshop4linux is developed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing a dual boot (Red Hat 8.0/XP) as400 Linux - Newbie 5 04-28-2004 10:59 AM
problem with Installing red hat linux dual boot(/boot < for 1024 cylinders ) praveenb Linux - Newbie 2 02-13-2004 08:49 PM
cannot boot Win Xp after installing Red hat 9.0 shahrahulb Linux - Hardware 11 10-13-2003 04:47 PM
cannot boot Win Xp after installing Red hat 9.0 shahrahulb Programming 5 07-25-2003 06:24 PM
Cannot boot into XP after installing Red Hat 8 fiburglas Linux - Software 4 12-10-2002 06:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration