LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-25-2003, 11:06 AM   #1
motyl
LQ Newbie
 
Registered: May 2003
Location: Galway, Ireland
Distribution: Redhat 9
Posts: 19

Rep: Reputation: 0
sendmail problems after i changed the name of my linux box


Hi gurus, need your help.

When I installed the linux, I didn't set the name of it, so it was set by default to localhost.localdomain. Today I changed the name to marsla03 because I need to access it by name from different pc's on a network. I changed it to marsla03 in network configurator tool and changed the /etc/hosts this way:
replaced 127.0.0.1 localhost.localdomain localhost
by 127.0.0.1 marsla03 localhost

When I rebooted, the graphics login screen sais "Welcome to marsla03" which is good, but I noticed that sendmail and sm-client services doesn't start quickly like they used to, but hang for few minutes. In system logs I see following messages.

May 25 14:44:06 marsla03 sendmail[2312]: alias database /etc/aliases rebuilt by root
May 25 14:44:06 marsla03 sendmail[2312]: /etc/aliases: 63 aliases, longest 10 bytes, 625 bytes total
May 25 14:44:06 marsla03 sendmail[2325]: starting daemon (8.12.8): SMTP+queueing@01:00:00
May 25 14:44:07 marsla03 sm-msp-queue[2334]: starting daemon (8.12.8): queueing@01:00:00
May 25 14:53:36 marsla03 sendmail[2304]: My unqualified host name (marsla03) unknown; sleeping for retry
May 25 14:54:36 marsla03 sendmail[2304]: unable to qualify my own domain name (marsla03) -- using short name
May 25 14:54:37 marsla03 sendmail[2304]: alias database /etc/aliases rebuilt by root
May 25 14:54:37 marsla03 sendmail[2304]: /etc/aliases: 63 aliases, longest 10 bytes, 625 bytes total
May 25 14:54:37 marsla03 sendmail[2317]: My unqualified host name (marsla03) unknown; sleeping for retry
May 25 14:55:38 marsla03 sendmail[2317]: unable to qualify my own domain name (marsla03) -- using short name
May 25 14:55:38 marsla03 sendmail[2319]: starting daemon (8.12.8): SMTP+queueing@01:00:00
May 25 14:55:39 marsla03 sm-msp-queue[2326]: My unqualified host name (marsla03) unknown; sleeping for retry
May 25 14:56:39 marsla03 sm-msp-queue[2326]: unable to qualify my own domain name (marsla03) -- using short name
May 25 14:56:39 marsla03 sm-msp-queue[2328]: starting daemon (8.12.8): queueing@01:00:00

Any ideas what else needs to be changed after renaming my linux box to marsla03?

THANKS A MILLION FOR HELP!

Last edited by motyl; 05-25-2003 at 11:21 AM.
 
Old 05-25-2003, 11:20 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
What exactly is the probelem? sendmail is starting fine you just don't have a FQDN.
 
Old 05-25-2003, 11:22 AM   #3
motyl
LQ Newbie
 
Registered: May 2003
Location: Galway, Ireland
Distribution: Redhat 9
Posts: 19

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by david_ross
What exactly is the probelem? sendmail is starting fine you just don't have a FQDN.
What is FQDN?

Yes, sendmail starts fine, it just take looooooong time and it used to take less than a second.
 
Old 05-25-2003, 12:41 PM   #4
motyl
LQ Newbie
 
Registered: May 2003
Location: Galway, Ireland
Distribution: Redhat 9
Posts: 19

Original Poster
Rep: Reputation: 0
HAVE A SOLUTION NOW

It was stupid mistake to change the /etc/hosts the way I did.

It should read:
127.0.0.1 localhost.localdomain localhost marsla03

Thanks for help anyway!
 
Old 05-25-2003, 01:31 PM   #5
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 67
Sorry for the late reply (I was getting hungry).

Glad you got it going better.

FQDN = Fully Qualified Domain Name (ie www.linuxquestions.org)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems joining a linux box to an active directory eantoranz Linux - Networking 2 10-05-2005 02:05 PM
path of mailbox in sendmail can be changed or not dhanju Linux - Networking 1 09-28-2005 09:17 AM
Problems resolving linux box running Samba from XP Pengus Linux - Networking 18 10-21-2004 02:34 PM
sendmail server mail box creation problems kjsubbu Linux - Networking 0 08-25-2003 05:47 AM
Trying to put linux on a windows box, but having problems. elpollodiablo Linux - Software 10 07-24-2003 02:02 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration