LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 04-01-2005, 02:07 AM   #1
Underhill
Member
 
Registered: Aug 2004
Location: Kuala Lumpur, Malaysia
Distribution: Debian Etch
Posts: 58

Rep: Reputation: 15
Terrible sound quality


Hi guys,

I got ALSA installed. But the sound quality is terrible, compared to in Windows. I'm using Turtule Beach Santa Cruz sound card by the way.

Any ideas?
 
Old 04-01-2005, 02:36 AM   #2
Thorium
Member
 
Registered: Dec 2004
Location: USA
Distribution: Debian
Posts: 124

Rep: Reputation: 15
I had a similar problem, are you using kde? Then you probably have kmix which you can use to play with the treble and bass, for my card I had to issue this command as root to get those mixer channels to do anything:

amixer sset Tone on

So do that and try lowering treble in a mixer app.
 
Old 04-01-2005, 02:40 AM   #3
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: London, England
Distribution: Ubuntu
Posts: 1,460

Rep: Reputation: 48
When I had this problem, it was because every channel was at 100%. Turned them down to 80% or so, and they had a bit more 'room to maneuver' - instant improvement.
 
Old 04-01-2005, 05:45 AM   #4
Underhill
Member
 
Registered: Aug 2004
Location: Kuala Lumpur, Malaysia
Distribution: Debian Etch
Posts: 58

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Thorium
I had a similar problem, are you using kde? Then you probably have kmix which you can use to play with the treble and bass, for my card I had to issue this command as root to get those mixer channels to do anything:

amixer sset Tone on

So do that and try lowering treble in a mixer app.
That's the problem. No treble and bass setting on my mixer.

Quote:
When I had this problem, it was because every channel was at 100%. Turned them down to 80% or so, and they had a bit more 'room to maneuver' - instant improvement.
It helps a little, thanks. But it doesn't sound as good on my Windows.
 
Old 04-01-2005, 11:33 AM   #5
marcheikens
Member
 
Registered: Aug 2003
Location: Cleveland, OH
Distribution: Ubuntu 6.06
Posts: 66

Rep: Reputation: 15
Have you tried turning down the PCM volume? That will cause awful distortion if it's up too high. Get into an xterm and type aumix . Go to the Pcm line and turn it down--I usually keep it around 50-70, along with the main volume. Then I just adjust volume with my speakers' volume control knob.

Oh, and if you don't have aumix, just apt-get install aumix .

marc
 
Old 04-01-2005, 04:31 PM   #6
Deeze
Member
 
Registered: Dec 2004
Distribution: Debian - Sarge -- Slackware 10.1 - Dropline
Posts: 154

Rep: Reputation: 30
Quote:
Originally posted by Underhill
That's the problem. No treble and bass setting on my mixer.



It helps a little, thanks. But it doesn't sound as good on my Windows.

I agree the sound system in Linux has room to grow yet. I have the same card, and it's a pity I can't take advantage of it's 7 channel hardware mixer (course if anybody knows that secret I'm all for learning). I also can't get as much volume out of my system as with windows. Well, I can make both go as loud as I can stand, but when I have my speakers set for a comfortable (really not loud) listening level in Debian, then when I boot 2k the sound is way, WAY too loud. This is with moderate (60-70%) settings in both os's for the volume controls. I'm talking literally a 25% difference in the setting of the volume knob on the speakers.

I'm all for a discussion on figuring out how to tweak up the sound system. Maybe a guru can chime in on this and give us some things to try .
 
Old 04-02-2005, 02:30 PM   #7
Underhill
Member
 
Registered: Aug 2004
Location: Kuala Lumpur, Malaysia
Distribution: Debian Etch
Posts: 58

Original Poster
Rep: Reputation: 15
marcheikens, done that. Thanks.

Quote:
Originally posted by Deeze
I agree the sound system in Linux has room to grow yet. I have the same card, and it's a pity I can't take advantage of it's 7 channel hardware mixer (course if anybody knows that secret I'm all for learning). I also can't get as much volume out of my system as with windows. Well, I can make both go as loud as I can stand, but when I have my speakers set for a comfortable (really not loud) listening level in Debian, then when I boot 2k the sound is way, WAY too loud. This is with moderate (60-70%) settings in both os's for the volume controls. I'm talking literally a 25% difference in the setting of the volume knob on the speakers.

I'm all for a discussion on figuring out how to tweak up the sound system. Maybe a guru can chime in on this and give us some things to try .
I'm all up for trying something new. Using software equalizer doesn't help much either (Beep Media Player, using Winamp EQF file).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
terrible sound while playing game vegetassj2 Linux - Games 1 04-24-2005 05:50 AM
Terrible Sound on Dell 8500 thereeper Linux - Hardware 0 04-23-2005 06:16 PM
Terrible sound quality with FreeBSD 5.2.1 magellanic *BSD 1 10-16-2004 12:37 PM
Laptop sound is terrible imagreg Slackware 4 04-22-2004 03:53 AM
Sound is terrible! 65_289 Slackware 8 10-28-2003 11:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration