LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-18-2005, 01:16 PM   #1
thenowherekid
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 12

Rep: Reputation: 0
How do I make Mouse Scroll work on Slackware 10.1


I have read a couple dozen forums and im still confused. I would like to use my mouse scroll on Slackware 10.1 and I can't do it. I can't find the file everyone says is in the ect/X11/ directory to edit and do whatever else i was suppost to. so can someone help a guy step by step on how to enable his mouse to scroll. thanks
 
Old 02-18-2005, 01:18 PM   #2
cathectic
Member
 
Registered: Sep 2004
Location: UK, Europe
Distribution: Slackware64
Posts: 761

Rep: Reputation: 35
What mouse is it, and how many buttons does it have?
 
Old 02-18-2005, 01:21 PM   #3
thenowherekid
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 12

Original Poster
Rep: Reputation: 0
The mouse is a HP mouse. it doesnt really say which kind it is. its got a laser sensor on the bottom. and its got 2 buttons, the left and right, and its got the scroll wheel in the middle.
 
Old 02-18-2005, 01:30 PM   #4
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
the file you want to configure is /etc/X11/xorg.conf

this is what mine says about the mouse:

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/mouse"

you probably just need to add the lines:

Option "Buttons" "5"
and
Option "ZAxisMapping" "4 5"

*edit
you'll need to be root to edit the file...

so step by step:

open a terminal such as xterm...
type:
su
your password
pico /etc/X11/xorg.conf
scroll down to the mouse input text....
add:
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
once thats done, hit cntrl X
it will ask if you want to write, click y for yes
hit enter and you're done...restart x and you should be good to go

be sure to put a space between the 4 and 5 after the ZAxisMapping entry...

Last edited by detpenguin; 02-18-2005 at 01:37 PM.
 
Old 02-18-2005, 01:39 PM   #5
thenowherekid
LQ Newbie
 
Registered: Feb 2005
Distribution: Slackware 10.2
Posts: 12

Original Poster
Rep: Reputation: 0
Thank you. its works and now im scrolling along.
 
Old 02-18-2005, 01:43 PM   #6
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
happy scrolling!!!
 
Old 02-18-2005, 02:09 PM   #7
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Rep: Reputation: 30
i had the same problem and this thred has helped fix it well it has fixed it.

however my mouse is one of those mice that has an extra button on each side of it so it has an extra 2 buttons pluss the scroll weel how can i make it so they can be used?

berrance
 
Old 02-18-2005, 02:28 PM   #8
roAder
Member
 
Registered: May 2004
Location: Sweden, Stockholm
Distribution: Slackware 10.1
Posts: 142

Rep: Reputation: 15
http://www.linux-gamers.net/modules/...php?category=6
there are lots of mouse config on that page....
 
Old 02-18-2005, 02:35 PM   #9
detpenguin
Senior Member
 
Registered: Oct 2003
Location: lost in the midwest...
Distribution: Slackware
Posts: 1,098

Rep: Reputation: 54
this site
might help you, berrance....i'm not sure about MX mice, never used one, but they offer a few suggestions which might work for ya? good luck

edit*

AHHHHHHHHHHH!!! roAder clearly types faster!!!

Last edited by detpenguin; 02-18-2005 at 02:40 PM.
 
Old 02-19-2005, 03:57 AM   #10
berrance
Member
 
Registered: Aug 2004
Location: Hull - England
Distribution: Ubunto and slowly switching to debian
Posts: 308

Rep: Reputation: 30
thanks i will have a look at those pages and see if i can get it working and as much as i dont like Microsoft i do like there mice as they are the most cumfortible i have ever used

thanks again

berrance
 
Old 02-03-2006, 03:29 PM   #11
_gnomm
Member
 
Registered: Nov 2005
Location: IL
Distribution: Slackware
Posts: 53

Rep: Reputation: 15
Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Buttons" "5"
Option "ZAxisMapping" "4 5"
Option "Resolution" "256"
Option "Protocol" "Auto"

the weel steel doesn't scroll??
 
Old 02-03-2006, 06:16 PM   #12
tuxdev
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 2,012

Rep: Reputation: 115Reputation: 115
It is probably detecting a Protocol that does not support the scroll wheel. It might have to do with "Buttons" or "Resolution". The scroll wheel may be buttons 6 and 7. and back/forward is buttons 4 and 5.
 
Old 02-03-2006, 07:54 PM   #13
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
And what about Slackware 10.2? I tried to change the parametres but didn't work... When I lick the scroll button it's pasting text.
Also, any ideas for the touchpad?
 
Old 02-03-2006, 08:37 PM   #14
evilDagmar
Member
 
Registered: Mar 2005
Location: Right behind you.
Distribution: NBG, then randomed.
Posts: 480

Rep: Reputation: 31
Try something like

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Buttons" "7"


...particularly if it's a USB mouse. I just got one of the new MS wireless mice around Christmastime, which has the extra two buttons under the thumb, and IIRC changing Buttons to 7 was all I had to do (although they don't actually do anything much under X anyway). (I'm no longer using that one because the sensitivity of the element on it's underside refuses to work worth a toot on my black desk surface.)

BTW, when you specify ZAxisMapping to have items 4 and 5, X apparently automatically assumes you meant Buttons 5 as well. What I'm using now is exactly what appears above minus any Buttons statement.
 
Old 02-04-2006, 12:37 AM   #15
_gnomm
Member
 
Registered: Nov 2005
Location: IL
Distribution: Slackware
Posts: 53

Rep: Reputation: 15
ok thanx it works!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scroll Button doesn't work with Logitech PS/2 MOuse. duffmckagan Slackware 10 12-02-2008 11:27 PM
how to make the mouse scroll faster in FC3? ooshiney00 Linux - Hardware 2 03-24-2005 07:55 AM
Scroll wheel of mouse - How to make it work? Redhat 9 umeshz Red Hat 19 12-29-2004 05:54 AM
Scroll feature in Logitech Scroll mouse does not work ssmaitra Linux - Hardware 6 11-11-2003 07:43 AM
Sorry, but my mouse scroll STILL doesn't work... BorgKing Linux - Hardware 1 06-15-2002 06:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 04:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration