LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-15-2004, 09:41 PM   #1
Ben136
LQ Newbie
 
Registered: Dec 2004
Posts: 14

Rep: Reputation: 0
Need to disable AGP


Hi,

I have an HP 6545C computer. It has an "Integrated Intel Direct AGP graphics with dynamic memory". Windows shows it as an 810 onboard graphics card. HP's website lists it as a "PCI Local Bus" video and there does not appear to be an AGP slot.

However, XFree86 does not start. The log files says:

"(EE) Unable to open /dev/agpgart (No such device)"

and

"AddScreen/ScreenInit failed for driver 0"

Which I assume the cause of the problem.

Any thoughts on fixing this? Is there a way to turn AGP off as a driver option? Should I reinstall and choose the VESA card option instead? Or will that try to use AGP as well?

Any help would be greatly appreciated.
 
Old 12-16-2004, 01:17 AM   #2
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 85
Welcome to LQ! Are you using a separate video card, or are you using the onboard? If you wish to disable the onboard, you should be able to do so by getting into the BIOS setup, then go to Video Configuration (or whatever it's called) and disable the onboard. HTH -- J.W.
 
Old 12-16-2004, 03:55 AM   #3
brfsa
LQ Newbie
 
Registered: Sep 2003
Location: Thailand
Distribution: Centos
Posts: 28

Rep: Reputation: 15
Hi Ben,

which Linux are you using? are you using default kernel? is it the first time you install linux? if not, did you make any changes to the X config file?

you should give more details bro..

there is a driver for your Graphics, the driver is "i810", but I think you still need the agpgart module for that.
or you can just use the vesa driver "vesa" it works fine

post your /etc/X11/xorg.conf or /etc/X11/XF86Config-4 file here, so that we can have a look.
 
Old 12-16-2004, 04:12 AM   #4
falcon79
LQ Newbie
 
Registered: Jun 2004
Posts: 15

Rep: Reputation: 0
/dev/agpgart is the char device the kernel uses to interface itself with your agp bus, which is used by dri drivers; dri needs to see accelerated 3d graphics on X.
So you have to:
1) Check that your kernel supports it, eventually recompiling it
2) Create the device (see mknod and devices.txt into kernel Documentation to obtain major and minor number for the device. It should be: major=10, minor=175, type=c)
3) Check that you have a valid dri driver for your card

If you can't do some of those points, you can disable dri (module drm on you XFree86 configuration file), but your openGl screensavers will be a little slow... :-)
 
Old 12-16-2004, 06:15 PM   #5
Ben136
LQ Newbie
 
Registered: Dec 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Sorry, I am using Debian 3.0r3 latest stable release. Using the onboard video card.
I have not made any configuration changes, other than choose the 810 as the choice during the Debian install.

I shall try the VESA driver.

Having only first installed Linux three days ago, I don't think I am going to try and compile the kernal yet!

At this point I am still continually re-installing it trying to get the network and video to work. The third attempt it did actually try to bring up the graphics environment. <g>

It does not like my RealTek 8139 card, but a friend of mine gave me a substitute that he says he has used witout any problems, so I may try that. The most likely cause of the card trouble at this point is the IRQ, but I though PCI dos not use IRQ? Card works fine under Windows, I can see no IRQ setting for it in the BIOS or in Windows either. <g>
 
Old 12-16-2004, 10:00 PM   #6
brfsa
LQ Newbie
 
Registered: Sep 2003
Location: Thailand
Distribution: Centos
Posts: 28

Rep: Reputation: 15
yes, try the vesa.
you don't have to reinstall it. once you are in command line, you can just use #xorgconfig or #xf86config, these tools you can configure the graphical system.

by the way, realtek 8139 has full support in linux, it should work very well for 2.4.x and 2.6.x... ohh.. wait, debian has kernel 2.2.. damm. graphical is gonna suk... unless you compile the latest 2.4.28

hey, WHY do you have to use debian? it's a great distro, but it is for a SERVER bro... get Slackware or at least fedora 3... much better.






* you should know that Slackware Rocks
 
Old 12-17-2004, 07:09 PM   #7
Ben136
LQ Newbie
 
Registered: Dec 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thumbs down

Ok, I got it working with VESA but the graphics look terrible. Gnome keeps drawing the clock all over the place and pieces of the desktop paint over other pieces etc. Hard to use. A friend of mine has an old Linux as well, and apparently had the same trouble.

Ok, so ditch Debian... Looks like the latest stable release is too old to support my RealTek 8139 network card, and without a network, what are you going to do?

Will have a look at the latest Slackware. And this time I shall go for the latest release, not the latest stable one. <g>
 
Old 12-18-2004, 12:00 AM   #8
Ben136
LQ Newbie
 
Registered: Dec 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Talking

Hi,

Thank you for all the good suggestions. I persevered (being a newby at Linux and all) and discovered this:

1) Reinstalling Debian using the bf24 option makes my RealTek 8139 network card work. The default safe 2.2 kernel install does not handle the card correctly.

2) You can run "dpkg-reconfigure xserver-xfree86" to reconfigure the gnome options. For my card, I had to disable the framebuffer support and set the desired display mode and refresh rate. Gnome now displays properly!

Thank you very much. So I shall stay with Debian for now and do some tinkering...
 
Old 12-18-2004, 01:44 AM   #9
Ben136
LQ Newbie
 
Registered: Dec 2004
Posts: 14

Original Poster
Rep: Reputation: 0
Thumbs up

Ok, take back all the bad things I said about Debian.

I just managed to get Apache, PHP, MySQL, Gnome etc. etc. all working.
Feels pretty nice....

Having been a Windows guy all these years, I think Linux will grow on me.
Hey, even vi is growing on me!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing agp-gart modules (moving from PCI to AGP video card) JLTB Debian 1 03-31-2005 04:08 AM
what are the services i can disable, also disable ads, banners in konqueror? greythorne SUSE / openSUSE 3 03-16-2005 08:30 AM
I have an onboard AGP, but want to use my nVidia card in my AGP slot. xorg.conf help LordRaven Slackware 16 09-17-2004 05:36 PM
Old AGP 2x card - can work in AGP 2x/4x slot? elnomadkvn Linux - Hardware 1 04-04-2004 01:35 AM
AGP??? bfloeagle Linux - General 1 05-06-2001 01:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration