LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices


Reply
  Search this Thread
Old 09-09-2017, 11:42 AM   #1
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
Is there any way to build pango without gtk-doc and all its dependencies?


LFS 8.1 names gtk-doc as recommended for building pango but not required. I don't want to have to build it because it comes with a lot of dependencies and I have no use for extensive documentation. But so far, I have not found a way to build this version of pango without it. And without pango, I shall have no gtk.

The autogen.sh file that comes with the package refuses point-blank to run without gtk-docs. If I comment out that test, it will run but not to completion, because one of the makefiles that it looks for (gtk-doc.make) isn't created.

None of the pango builds that I have done in previous LFS's played up like this, but there was a similar bug in pango about eight years ago which got patched. https://forums.gentoo.org/viewtopic-...6-start-0.html
 
Old 09-09-2017, 01:11 PM   #2
sr_ls_boy
Member
 
Registered: Apr 2015
Posts: 38

Rep: Reputation: Disabled
Whenever I want to skip the docs I just say: make -k && make -k install.
That will install the libs but fail on the docs. It will work.

You could try to comment out the doc target in the makefile.
 
Old 09-09-2017, 01:18 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,170

Rep: Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494
read the output of "./congfigure --help "
there should be a option "-without-gtk-doc" or something like that
 
Old 09-09-2017, 01:28 PM   #4
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
There isn't a Makefile or a configure script until you've run autogen.sh, and that won't run. The weird thing is that I just looked at how Crux does it and Crux has the next version upwards (pango-1.40.11) with a perfectly normal GNU-build setup: all the files you'd expect to find are there so you can just run ./configure like a civilised person. That weird autogen.sh script is there too but you don't have to use it. And there's a gtk-doc.make file too; it's part of the package. But I don't have gtk-docs on Crux and that didn't stop the package building there.

In fact if I do ./configure --help on the Crux Pango package, I get:
--enable-gtk-doc use gtk-doc to build documentation [[default=no]]

No docs by default. Just as you'd expect. I think I'll import this version into LFS and use it in preference to the 1.40.10 one.
 
Old 09-09-2017, 04:29 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,170

Rep: Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494
then run autoheader and autoconfig manually
or remove the m4 check for gtk-doc from the shell script

you can also set an "enable" to off
Code:
--enable-gtk-doc=no
that is the dame as
Code:
--without-gtk-doc
 
Old 09-10-2017, 12:28 PM   #6
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
I've been playing about with this all day. Doing it by hand, I can run aclocal, autoheader, autoconf and libtoolize without errors. But not automake.

If I don't have a gtk-doc.make file in the top-level directory, I get the error:
Code:
automake: error: cannot open < gtk-doc.make: No such file or directory.
If I copy the gtk-doc.make file over from Crux's pango-1.40.11, I get:
Code:
gtk-doc.make:7: error: GTK_DOC_USE_LIBTOOL does not appear in AM_CONDITIONAL
docs/Makefile.am:101:   'gtk-doc.make' included from here
gtk-doc.make:60: error: GTK_DOC_BUILD_HTML does not appear in AM_CONDITIONAL
docs/Makefile.am:101:   'gtk-doc.make' included from here
gtk-doc.make:65: error: GTK_DOC_BUILD_PDF does not appear in AM_CONDITIONAL
docs/Makefile.am:101:   'gtk-doc.make' included from here
gtk-doc.make:74: error: ENABLE_GTK_DOC does not appear in AM_CONDITIONAL
docs/Makefile.am:101:   'gtk-doc.make' included from here
gtk-doc.make:280: error: HAVE_GTK_DOC does not appear in AM_CONDITIONAL
docs/Makefile.am:101:   'gtk-doc.make' included from here
docs/Makefile.am:142: error: ENABLE_GTK_DOC does not appear in AM_CONDITIONAL
I can't see any way around this except to use the Crux source package for Pango (which was probably configured by a developer on a system with gtk-docs installed and then repackaged for users)
 
Old 09-10-2017, 01:23 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,170

Rep: Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494Reputation: 2494
then edit the *.am files to remove the m4 macro gtk-doc check

it should be starting on line 101
Code:
docs/Makefile.am:101:
 
Old 09-11-2017, 02:27 AM   #8
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
No, there's nothing on that line. There is a line earlier that includes gtk-doc.make and I commented that out, then corrected two lines that gave automake errors as a result of that edit. After that, automake only gives warnings, no errors, but it doesn't create any Makefiles.
Code:
docs/Makefile.am:54: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
examples/Makefile.am:6: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
pango-view/Makefile.am:30: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
pango/Makefile.am:16: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
pango/mini-fribidi/Makefile.am:3: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
tools/Makefile.am:3: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
win32/Makefile-newvs.am:23: warning: MSVC_TOOLSET was already defined in condition TRUE, which includes condition MSVC_NO_TOOLSET_SET ...
win32/vs15/Makefile.am:29:   'win32/Makefile-newvs.am' included from here
win32/vs15/Makefile.am:27: ... 'MSVC_TOOLSET' previously defined here
I'm attaching the docs/Makefile.am to this post, hoping that this will be more informative than my descriptions.
Attached Files
File Type: txt Makefile.txt (3.7 KB, 3 views)

Last edited by hazel; 09-11-2017 at 02:28 AM. Reason: Added output of automate
 
Old 09-11-2017, 05:27 AM   #9
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
I went to the Pango site because I wanted to see how they package it upstream and whether the Crux devs had done any repackaging. It turns out that pango-1.40.10 has no build tools included except the autogen.sh script, whereas 1.40.11 (the version Crux uses) has the full set. Some people must have complained about not being able to build 1.40.10 without gtk-docs. Oddly though, nothing appears in the NEWS.

I'm going to use 1.40.11 and count that as a solution. Otherwise I'll be going on at this all week.

Last edited by hazel; 09-11-2017 at 05:32 AM.
 
Old 09-12-2017, 08:54 PM   #10
rabidlinux
LQ Newbie
 
Registered: Aug 2017
Posts: 9

Rep: Reputation: Disabled
Hey Hazel,
Did you have any luck with that yet? I've ran into the same problem.
 
Old 09-13-2017, 01:10 AM   #11
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
I gave it up in the end after trying every combination of Makefile.am/Makefile.in edits that I could think of. I did get to the point where automake ran without errors, just a string of warnings. But it still wouldn't create a Makefile for me.

The solution is simple. Go to the pango website and download pango-1.40.11. It has the full GNU build set-up. Configure it with "./configure --prefix=/usr --sysconfdir=/etc" and build it. You won't need gtk-docs because that is disabled by default (as it ought to be!).

I've posted to the mailing list suggesting that gtk-docs be moved from Recommended to Required in the current 8.1 book. It can be left as is in svn because the pango people have clearly gone back to the normal mode of packaging in the later versions.

EDIT: Looks like it was actually a slip-up by the pango team. See https://mail.gnome.org/archives/gtk-.../msg00005.html and sequel.

Last edited by hazel; 09-13-2017 at 01:26 AM.
 
Old 09-13-2017, 06:08 AM   #12
rabidlinux
LQ Newbie
 
Registered: Aug 2017
Posts: 9

Rep: Reputation: Disabled
Thanks for the solution. Will see how far I get today
 
Old 09-13-2017, 11:15 AM   #13
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: Debian, Crux, LFS, AntiX, NuTyX
Posts: 1,276
Blog Entries: 1

Original Poster
Rep: Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578Reputation: 578
I just did a diff on these two versions. As far as I can see, there is no difference in any of the directories that contain actual code, but the later version has all the GNU build files that the earlier one lacks. Looks like the pango devs made a bubu and have now corrected it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] gtk+, pango and cairo dependencies chris-barry Linux - Software 3 02-17-2013 01:18 PM
not getting gtk support using ./configure, build dependencies installed fakie_flip Linux - Software 1 03-01-2012 02:35 PM
Pango and Python circles dependencies vivanguarda Slackware 9 04-17-2009 02:02 PM
Installing pango-devel...Recessive Dependencies haroldjclements Linux - Newbie 2 05-05-2008 03:51 AM
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 11:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch

All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration