LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 04-22-2018, 11:31 AM   #1
BigBird123
LQ Newbie
 
Registered: Apr 2018
Location: Canada
Distribution: Debian
Posts: 4

Rep: Reputation: Disabled
Is there any support for the audio card/codec Realtek ALC298?


I recently installed Ubuntu Gnome on my galaxy book 10. Everything works almost out of the box with the only exception being networking but that was an easy fix.

The only issue left unresolved is that of audio output. Neither the headphone jack nor built in speakers produce any sound.

The sound card used in this machine is the Realtek ALC298 which does not seem to be officially supported by Realtek themselves for linux. My question is;

Has anyone managed to make this or any other "non-supported" sound card work? If so how?

I ran a alsa-info script that contains the majority of the information pertaining to my system and how the sound is configured here.

This is my modprobe alsa-base.conf

Code:
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2

#Options that I changed from default
options snd_hda_intel enable=1 index=0
options snd_hda_intel index=1
options snd_hda_intel model=laptop-amic
dmesg audio output
Code:
:$ dmesg | grep audio
[    4.333720] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.489470] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC298: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    4.489473] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.489474] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.489476] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[    4.489477] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[    4.489479] snd_hda_codec_realtek hdaudioC0D0:      Mic=0x18
[    4.489480] snd_hda_codec_realtek hdaudioC0D0:      Internal Mic=0x12

Last edited by BigBird123; 04-23-2018 at 12:55 PM. Reason: Added some debugging logs
 
Old 04-23-2018, 12:12 PM   #2
beachboy2
Senior Member
 
Registered: Jan 2007
Location: Wild West Wales, UK
Distribution: Linux Mint 18.3 MATE, Solus 3 MATE, antiX-17, MX-17.1
Posts: 2,410
Blog Entries: 10

Rep: Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868Reputation: 868
BigBird123,

Welcome to LQ.

A sound setting may be muted by default.

Install pavucontrol via Terminal:

Code:
sudo apt-get install pavucontrol
Look here for a similar problem:
https://askubuntu.com/questions/8442...realtek-alc892
 
Old 04-23-2018, 12:49 PM   #3
BigBird123
LQ Newbie
 
Registered: Apr 2018
Location: Canada
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by beachboy2 View Post
BigBird123,

Welcome to LQ.

A sound setting may be muted by default.

Install pavucontrol via Terminal:

Code:
sudo apt-get install pavucontrol
Look here for a similar problem:
https://askubuntu.com/questions/8442...realtek-alc892

Thank you beachboy2,

This is one of two threads I attempted to post (first time posting to this site). The other goes into more detail what I have tried so far.

Using pavucontrol shows that nothing is muted, as does alsamixer.

I will update my original post to include more debug logs (if possible, if not I will just post them in another comment).
 
Old 04-24-2018, 09:30 AM   #4
_roman_
Member
 
Registered: Dec 2017
Location: _Austro_Bavaria_
Distribution: gentoo / linux mint
Posts: 433

Rep: Reputation: 28
sounds like hda_intel soundcard (which was also later told in your outputs: snd_hda_intel)

hda_intel is sometimes problematic. hda_intel is a summary of many different sound cards


--

Common mistake is to just unmute only alsa based soundcard or only pulseaudio soundmixer.

that'S the reason why you were told to use pavucontrol.

you need to unmute, and set some volume levels for both the software sound mixer, usually called pulseaudio and for your hardware sound card. afaik f6 keys in alsamixer can switch soundcards.

--

also note, that wiht my similar hda_intel based notebook sound card, certain linux kernels had issues.

only working kernel here is kenrel branch 4.10. So you may try different linux kernel branches.
Just for information, my outdated antique asus g75vw notebook, did not work properly with kernels 4.11-4.15. Sound card did only work sometimes / special keys broken / power management broken ... and other issues. kernel 4.0 and kernel 4.4 were more stable and more tested in my point of view. also some subkernels / updated kernels also do not work always. hda_intel is a bit problematic. also gentoo linux guys used certain compiler flags which also caused many linux kernel bugs which were related to untested "gcc compiler flags", "unused / unusual gcc compiler flags".

--

I would not recommend touching any alsa based config files. Usually it works or it does not work with a certain kernels. playing around with config files introduce a second source of why it may not work
 
Old 04-24-2018, 07:38 PM   #5
BigBird123
LQ Newbie
 
Registered: Apr 2018
Location: Canada
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thank you _roman_ for the reply,

When I open alsa mixer and attempt to switch sound cards my options are

1. (default)
2. HDA Intel PCH
3. enter device name...

When I try and switch from HDA Intel PCH to (default)

I get the error

Code:
Cannot open mixer device 'default' No such file or directory
Hopefully this means something to you.
 
Old 04-25-2018, 09:01 PM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,609
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
$ cat /proc/asound/cards

If it has a driver and it's used, it'll show up there. Along side an index number that lets you reference it in the absence of audio extras like pulse audio.

$ alsamixer -c 1
(or press F6 and select it)
( press F1 for the help while in alsamixer )

In the presence of pulseaudio, things get more difficult. Pulse locks the device from other methods. What might be "default" as a parameter will change to "pulse". Baring a .asoundrc that specifies pulse as the default. Lots of layers with lots of toe stepping these days.

The i915 is the intel GPU, so HDMI OUT? Which probably is NOT hw:0,0 in alsa naming conventions.

$ egrep -r -i HDMI /proc/asound/* | grep -i pcm
 
1 members found this post helpful.
Old 05-02-2018, 03:47 AM   #7
drunkenmaster!
LQ Newbie
 
Registered: Dec 2013
Posts: 2

Rep: Reputation: Disabled
Hi Shadow 7,

egrep -r -i HDMI /proc/asound/* | grep -i pcm gives (only last lines):

/proc/asound/pcm:00-03: HDMI 0 : HDMI 0 : playback 1
/proc/asound/pcm:00-07: HDMI 1 : HDMI 1 : playback 1
/proc/asound/pcm:00-08: HDMI 2 : HDMI 2 : playback 1
/proc/asound/pcm:00-09: HDMI 3 : HDMI 3 : playback 1
/proc/asound/pcm:00-10: HDMI 4 : HDMI 4 : playback 1

I couldn't try USB-C -> HDMI because of a missing adapter. But sound over bluetooth works with headphones and speakers. In addition mkchromecast connected to a chromecast also playes sound. Bluetooth sometimes works with glitches and mkchromecast refuses to work - e.g. start video everythings works fine. Stop and start again, sound is missing. Repeat and sound works again.

------------------
Hardware Samsung Book 10.6
 
Old 05-03-2018, 03:23 PM   #8
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,609
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
/proc/asound/pcm:00-03: HDMI 0 : HDMI 0 : playback 1 === hw:0,3
/proc/asound/pcm:00-07: HDMI 1 : HDMI 1 : playback 1 === hw:0,7
/proc/asound/pcm:00-08: HDMI 2 : HDMI 2 : playback 1 === hw:0,8
/proc/asound/pcm:00-09: HDMI 3 : HDMI 3 : playback 1 === hw:0,9
/proc/asound/pcm:00-10: HDMI 4 : HDMI 4 : playback 1 === hw:0,10

Or something like that in terms of alsa names.

$ speaker-test -c 2 -l 1 -D hw:0,3
$ speaker-test -c 2 -l 1 -D hw:0,7
$ speaker-test -c 2 -l 1 -D hw:0,8
$ speaker-test -c 2 -l 1 -D hw:0,9
$ speaker-test -c 2 -l 1 -D hw:0,10

You can have a .asoundrc that reflects one of those as default (when using alsa natively) that looks a bit like this:

FILE: $HOME/.asoundrc
Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 3
Replace the .device number as appropriate, depending on which HDMI out your monitor (with audio) is plugged into. The default is hw:0,0 which is normally the speakers or headphone jack depending on the type of computer.

And yes bluetooth is quite quirky IME. Even with the switch-on-connect module, it'll work great when it's first setup, and then get very unreliable with pavucontrol interventions to make it work again. Although most time's I've used it, it has been on small embedded devices like a pocketchip.
 
1 members found this post helpful.
Old 05-08-2018, 05:06 PM   #9
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,475

Rep: Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994Reputation: 994
I think it's a kernel regression. You might consider reporting it to the distro bug system under the kernel-version.
 
Old 05-16-2018, 06:59 PM   #10
BigBird123
LQ Newbie
 
Registered: Apr 2018
Location: Canada
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thanks shadow,

I ran the commands you suggested with little success.

Here is the result of

Code:
egrep -r -i HDMI /proc/asound* | grep -i pcm
Code:
/proc/asound/pcm:01-03: HDMI 0 : HDMI 0 : playback 1
/proc/asound/pcm:01-07: HDMI 1 : HDMI 1 : playback 1
/proc/asound/pcm:01-08: HDMI 2 : HDMI 2 : playback 1
/proc/asound/pcm:01-09: HDMI 3 : HDMI 3 : playback 1
/proc/asound/pcm:01-10: HDMI 4 : HDMI 4 : playback 1
/proc/asound/card1/pcm3p/info:id: HDMI 0
/proc/asound/card1/pcm3p/info:name: HDMI 0
/proc/asound/card1/pcm3p/sub0/info:id: HDMI 0
/proc/asound/card1/pcm3p/sub0/info:name: HDMI 0
/proc/asound/card1/pcm7p/info:id: HDMI 1
/proc/asound/card1/pcm7p/info:name: HDMI 1
/proc/asound/card1/pcm7p/sub0/info:id: HDMI 1
/proc/asound/card1/pcm7p/sub0/info:name: HDMI 1
/proc/asound/card1/pcm8p/info:id: HDMI 2
/proc/asound/card1/pcm8p/info:name: HDMI 2
/proc/asound/card1/pcm8p/sub0/info:id: HDMI 2
/proc/asound/card1/pcm8p/sub0/info:name: HDMI 2
/proc/asound/card1/pcm9p/info:id: HDMI 3
/proc/asound/card1/pcm9p/info:name: HDMI 3
/proc/asound/card1/pcm9p/sub0/info:id: HDMI 3
/proc/asound/card1/pcm9p/sub0/info:name: HDMI 3
/proc/asound/card1/pcm10p/info:id: HDMI 4
/proc/asound/card1/pcm10p/info:name: HDMI 4
/proc/asound/card1/pcm10p/sub0/info:id: HDMI 4
/proc/asound/card1/pcm10p/sub0/info:name: HDMI 4
I also tried
Code:
speaker-test -c 2 -l 1 -D h2:x,x
on HDMI 0-4 with no success

Thank you

Last edited by BigBird123; 05-16-2018 at 07:00 PM. Reason: Forgot to add details
 
Old 05-18-2018, 12:10 AM   #11
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,609
Blog Entries: 1

Rep: Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782Reputation: 782
/proc/asound/card1/pcm10p/info:id: HDMI 4

this would be hw:1,10 for the alsa name.

/proc/asound/pcm:01-10: HDMI 4 : HDMI 4 : playback 1

This would also be hw:1,10 for the alsa name.

Where 1 is the card # and 10 is the device. Technically there is a subdevice as well which is likely 0 and assumed so hw:1,10,0 if you want to get overly technical. Rarely needed, except when doing exotic things like snd-aloop / alsaloop.

$ cat /proc/asound/card1/pcm10p/info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install " REALTEK HD AUDIO CODEC " in ubuntu ? vulopal Linux - Newbie 3 11-06-2016 09:28 PM
[SOLVED] No sound or bad sound card with Codec: Realtek ALC888 ludger Linux - Hardware 3 02-16-2011 03:20 AM
Enabling 7.1 support for ALC892 audio codec in Kubuntu 10.10 KickMeElmo Linux - Hardware 0 02-12-2011 04:13 PM
support for Realtek ALC262 HDA Audio Codec under linux-2.6.24 barunparichha Linux - Hardware 9 08-14-2008 05:38 AM
newbie looking for help in installing Realtek audio card driver 1sciroccofahrer Linux - Hardware 8 03-11-2008 01:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration