LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices

Reply
 
LinkBack Search this Thread
Old 02-20-2014, 10:13 PM   #76
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 177

Rep: Reputation: Disabled

If you want to try replacing network-manager with wicd (another connection manager), you can try this procedure. Check out this video for more information, and to see the procedure before trying it!

http://youtu.be/anxCy45m-Ok

Procedure:

Code:
notes for installing wicd in xubuntu 13.10

1.  from the software center, install wicd (search for wicd).

2.  when the software center asks to add a user to group netdev, select your user with the check box and click Forward.

3.  when the software center finishes installing wicd, go ahead and reboot.

4.  upon reboot, you'll get asked for your user password (not network password). you should get some error messages about wicd failing to start.  this is normal for xubuntu.

5.  once your reboot is done, network-manager should still be running your connection.

6.  open a terminal and type the following:
	sudo  rm /var/lib/wicd/resolv.conf.orig
	sudo  ln -s /run/resolvconf/resolv.conf /var/lib/wicd/resolv.conf.orig

7.  Now use network-manager left click menu to disconnect.  

8.  From the terminal, type the following to stop network-manager from controling your connections:
	sudo service network-manager stop

8.  from the Internet area of your menu, select WiCD.  It should be scanning for networks.  

9.  You should be able to connect to your network with the client.  You may need to put the name of the interface in preferences (little arrow in the upper right of the wicd menu bar).  If you are using encryption, you'll get a little notice and a window will open with connection parameters.  Type in your network password.

10.  Click Connect.  If you connect and get an IP address, we can remove network manager.

To remove network-manager

1.  Open a terminal and type:
	sudo apt-get purge network-manager
	
	say yes when it asks you about removing packages.
	
2.  Reboot.  You should now be totally running on wicd to manage your network and you should be connected.

please note:  this procedure, while tested in a virtual environment and on two real laptops of different makes and wireless chipsets, is offered free and without warranty.  Depening on your own local installation, your mileage may vary.
 
Old 02-21-2014, 10:48 PM   #77
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
I appreciate these very helpful and instructive solutions. What an amazingly supportive and constructive group this is...I'm truly impressed. I want to look into these things a bit more closely before I execute them. Right now I am able to get online simply by dis-abling and then re-enabling wireless. That's very little manual work to get online. If I go through the procedure to delete and then reinstall the network manager I may wind up with more damage, or complications, than I have right now. On the other hand, it may work which would be great. For right now I'll maintain the situation I have until I can determine what's best. It sounds like it could be dicey to mess with the network manager and I don't want to chance that until I know more. Once again, these comments have been helpful and encouraging--thanks to all! If I find out more and get additional clarification, I will post that information here. I hope anyone else will do likewise. Thanks again!
 
Old 03-28-2014, 01:51 PM   #78
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Just checking back on this...I still have the same problem only I get around it by "disable wireless" and then clicking "enable wireless." Once I do that--Voila!--the computer connects to my router. The router has to be compatible with Linux otherwise it wouldn't connect at all. I did not try rebooting the router--would that make a difference seeing as the computer does connect after disabling and re-enabling the wireless connection? I'm not sure how to reboot the router short of unplugging it and then plugging it back in. My router has no switch on it of any kind. Thanks again for all this input!
 
Old 04-02-2014, 11:40 AM   #79
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,355

Rep: Reputation: 205Reputation: 205Reputation: 205
Many routers have a web interface. So open a browser and goto http://<ip_of_router> and login. There's a reboot button on the web page served by the router. If you're using ddwrt, you might have to go to the admin tab and then find the reboot button at the bottom of that page.

$ route -n
or
$ netstat -r

Should show the IP as the router is probably the default gateway. Or if you're lazy, get a power strip with a switch specifically for the router. Which is how I turn my bedroom light on and off. It's a bit old school, but knobs and switches have their place. My speakers pipe through a headphone preamp. Volume knobs and a mute button does wonders for ones sanity.
 
Old 04-10-2014, 04:23 PM   #80
Yuhan
Member
 
Registered: Oct 2010
Posts: 165

Original Poster
Rep: Reputation: 2
Thanks for that, Shadow 7. A very strange thing happened a few days ago. We had an electrical storm and the power was out in my house for about an hour. When the power was restored of course my computer, router, etc., all came back on and rebooted. After that, the wireless connection on my laptop works perfectly again! Go figure! Could it have been something as simple as the router simply needed to be rebooted (unplugged and then plugged in again)? Whatever the case, it is working fine now and it had to be something connected with that power out. Any ideas?
 
Old 04-10-2014, 05:51 PM   #81
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 177

Rep: Reputation: Disabled
nothing clears out the cruft like a reboot.
 
Old 04-10-2014, 10:10 PM   #82
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,355

Rep: Reputation: 205Reputation: 205Reputation: 205
I need to reboot my router once in a while. Although not for the routers sake, but so the ISP has a fresh lease for me. The system seems to forget about me if I don't reboot to have the router scream at the ISP.

It's more likely that the outage caused the ISPs routers to reboot and that fixed your quirk. Although some wireless drivers in linux can have different signal strengths with each reboot. Back in the early days of b43, the b43 driver would have a lower range than using the ndiswrapper method (for my hardware at the time). Pros and cons for each, but if you needed distance, you had to favor ndiswrapper over b43 in those days (for that particular hardware at that particular time).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Laptop won't recognize home router with Xubuntu Yuhan Linux - Laptop and Netbook 2 12-17-2013 11:38 PM
New laptop, connects to router, will not connect to internet BobNutfield General 2 01-12-2013 06:44 PM
Toshiba won't connect to Netgear wireless router.. shirky Linux - Networking 4 02-14-2012 08:04 PM
How do I set up a laptop as a router to connect wirelessly to my ADSL router hairysocks Linux - Networking 12 12-20-2009 06:51 AM


All times are GMT -5. The time now is 12:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration