LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 03-30-2016, 03:17 PM   #1
Aeneas32
LQ Newbie
 
Registered: Mar 2016
Posts: 4

Rep: Reputation: Disabled
Disable window auto-maximize auto-tile in Red Hat


How does the user disable this absurd feature, which automatically tiles/maximizes windows when they are dragged to the edge of the screen ?
This feature makes it impossible for the user to move windows around and navigate using mouse-drags to the window one is seeking.

Windows 7 provides a means to disable this in their Ease Of Access menu, but I have yet to find how to disable this in Red Hat.
Who thought this ridiculous idea up in the first place ?
 
Old 03-30-2016, 04:24 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,438

Rep: Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591
this is redhat so you did buy the required support contract
you know the desktop license that is $299 per year
or the server license that is $799/year

have you looked on the redhat site ?
you ARE paying for the support you might want to use it


also What version of RHEL ?
the current is RHEL 7.2

and What Desktop manager are you using ?
Gnome2
Gnome3
KDE4
xfce
lxde
e19
???

Last edited by John VV; 03-30-2016 at 04:25 PM.
 
Old 03-30-2016, 10:51 PM   #3
Aeneas32
LQ Newbie
 
Registered: Mar 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Red Hat Enterprise Workstation 7.2 64-bit
Gnome Version 3.14.2
i7-4770
---------------------------------
If this feature helps visually impaired, so be it,
but there must be an easily accessible method to turn it off/disable
such an overwhelmingly debilitating feature for those
who have many windows open on the desktop -- i.e. real users.
 
Old 03-30-2016, 11:30 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,438

Rep: Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591Reputation: 2591
so Gnome3

as a long time Gnome user Gnome3 forced me to KDE

so

is the "tweak tool" installed ?

from your desktop
click on Activities

then the tile menu ( yes JUST like Win 10 )

and select the tweak tool

click on "windows" on the left

turn on the minimize and maximize buttons ( toggle off to on )
-- this will show those buttons

you also might want to turn on the "application menu" also using the tweak tool ( this turns off the Win10 tiles )
 
Old 03-31-2016, 01:00 AM   #5
Aeneas32
LQ Newbie
 
Registered: Mar 2016
Posts: 4

Original Poster
Rep: Reputation: Disabled
Tried installing and found tweak-tool was installed.
Found and turned off the 2 max and min buttons -- made no difference to
the window auto-maximize/tile behavior, which continues.
Cannot imagine why Red Hat or anyone would want to hide the ability to
turn off this auto-maximize anti-feature.

Do not use Windows 10 -- I need Windows Media Center to watch TV,
on Windows 7 64.
Not installing Windows 10 until they give the all clear that WMC is
installed (by Microsoft) and ready to go.
Looks like Top Bar/Application Menu was already on.
 
Old 05-24-2019, 09:32 AM   #6
Vanyel
Member
 
Registered: Jul 2007
Location: NY, NY
Distribution: RHEL, CentOS, MacOS X
Posts: 137

Rep: Reputation: 29
Disable window auto-maximize auto-tile in Red Hat/CentOS 7

I find this highly annoying too and found this unanswered thread in my search.

I found the solution to this on StackExchange.

The settings that control this are not available in the configuration dialogues. It has to be changed from the command line with gsettings, like so:

Code:
 $ gsettings set org.gnome.shell.extensions.classic-overrides edge-tiling false
 
Old 06-12-2019, 10:46 AM   #7
Vanyel
Member
 
Registered: Jul 2007
Location: NY, NY
Distribution: RHEL, CentOS, MacOS X
Posts: 137

Rep: Reputation: 29
Hmmmm ... I discovered that the drawback to the above gsettings solution I found is that it can only be run when you're logged into the GUI, otherwise you get an error -
Quote:
(process:25683): dconf-WARNING **: 11:42:42.645: failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY
That means I can't ssh into a remote machine and set it so that when I'm at that machine later, the annoying auto-tiling will already be nullified when I login. Even MORE important, I can't put it into an Ansible script to have as a default for all users as a machine is built.

Does anybody else have a way to disable the auto-tiling in CentOS (I'm on CentOS but this would apply to RHEL too) as a global default, for good?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Auto maximize a program ThomasRonshof Linux - Desktop 7 03-14-2014 02:49 AM
Auto Shutdown - Red Hat 9 jt1020 Linux - General 5 06-01-2003 09:38 PM
Red Hat auto-mounting hotrodowner Linux - Distributions 5 12-22-2002 07:46 PM
Why does Red Hat 7.2 not auto detect my connection as 7.1 does? AMDPwred Linux - Distributions 4 01-15-2002 05:17 PM
Red Hat 7.1 and auto scsi emulation items Linux - Software 0 06-04-2001 11:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 06:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration