LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-13-2021, 06:32 AM   #1
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 217

Rep: Reputation: Disabled
'kget' and 'ktorrent' odd behaviour


Good day everyone,

last night I noticed that neither 'kget' nor 'ktorrent' started any magnet download as usual.

I was too tired to test further and went to bed. I had forgotten all about it and, this morning while doing some other work, the ktorrent window suddenly appeared and asked me the usual file save location question.

It was surprising, and I blamed my overloading the CPU with other video work thnking that maybe it was an execution delay; after choosing the location, nothing happened. The file did not even appear nor downloading.

I closed all my other work and repeated the process and I had the same outcome.

Then, i chose 'kget', like i did last night, as download applicaion and it returned this error msg
Quote:
The following URL cannot be downloaded, its protocol is not supported by KGet:magnet:?xt=urn:btih:E0CC405E07321941F2E758EF171142ABF9AB9FFE&dn=Alpha+Blondy+-+Human+Race+%5B320+KBPS%5D%5B2018%5D%5Bpradyutvam%5D&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969%2Fannounce&tr=udp%3A%2F%2Ftracker.open-internet.nl%3A6969%2Fannounce&tr=udp%3A%2F%2Ftracker.coppersurfer.tk%3A6969%2Fannounce&tr=udp%3A%2F% 2Ftracker.opentrackr.org%3A1337%2Fannounce&tr=udp%3A%2F%2Feddie4.nl%3A6969%2Fannounce&tr=udp%3A%2F%2 Fopen.demonii.si%3A1337%2Fannounce&tr=udp%3A%2F%2Finferno.demonoid.pw%3A3418%2Fannounce&tr=udp%3A%2F %2Finferno.demonoid.pw%3A3391%2Fannounce&tr=udp%3A%2F%2F9.rarbg.com%3A2770%2Fannounce&tr=udp%3A%2F%2 Fexodus.desync.com%3A6969%2Fannounce&tr=udp%3A%2F%2Ftracker.uw0.xyz%3A6969%2Fannounce&tr=udp%3A%2F%2 Ftracker.zer0day.to%3A1337%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969%2Fannounce&tr=udp%3A%2F%2Fcoppersurfer.tk%3A6969%2Fannounce&tr=udp%3A%2F%2Ftrack er.zer0day.to%3A1337%2Fannounce&tr=udp%3A%2F%2Ftracker.leechers-paradise.org%3A6969%2Fannounce&tr=udp%3A%2F%2Fcoppersurfer.tk%3A6969%2Fannounce
(this may be normal as I was trying to open torrent files, although i vaguely remember that kget was also capable to do so)

Buffled by the sentence "insanity is repeating the same thing over and expecting different results" I tried again with ktorrent. Nothing.

LQ for help. All of sudden while typing this post the ktorrent window appeared again asking me where to save the file. This time the download completed.

I decided to try another random download: again, no luck. The ktorrent window appear but no file seems to be saved anywhere nor a download seems to start (i guess that in a few hrs it will decide to start on its own).

I quit ktorrent and try again. No dice. I changed web browser. Same result.

Has anyone experienced such a thing?

Last edited by however; 04-13-2021 at 07:17 AM.
 
Old 04-13-2021, 09:53 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 8,476

Rep: Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784Reputation: 7784
Are you using these magnet links through a proxy? Proxies are usually distributed server infrastructures and it can happen that your proxy does not receive peer information for a long time. And then all of a sudden you get moved to a different proxy server and it works.
 
Old 04-13-2021, 01:14 PM   #3
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 217

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Alien Bob View Post
Are you using these magnet links through a proxy? Proxies are usually distributed server infrastructures and it can happen that your proxy does not receive peer information for a long time. And then all of a sudden you get moved to a different proxy server and it works.
HI Bob,
I didnt change any proxy or network settings but i checked the system network, kget and ktorrent settings anyway and, i confirm that no proxies are being used.
 
Old 04-17-2021, 02:39 PM   #4
however
Member
 
Registered: Jan 2019
Distribution: slackware current
Posts: 217

Original Poster
Rep: Reputation: Disabled
It seems that removing the package and reinstalling it solved the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Odd situation with raid10 array, odd number of drives, and it took, can't regrow now Red Squirrel Linux - Software 9 08-08-2014 02:15 PM
Odd e-mail behaviour when swtiching between DHCP and BOOTP for IP leasing indienick General 3 09-25-2008 08:15 AM
Odd behaviour when copying files from cdrom to hard drive... pdmackenzie Linux - Hardware 9 03-21-2003 06:34 PM
Very odd CPAN behaviour! bluehz Linux - Software 0 07-08-2002 04:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 07:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration