LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook
User Name
Password
Linux - Laptop and Netbook Having a problem installing or configuring Linux on your laptop? Need help running Linux on your netbook? This forum is for you. This forum is for any topics relating to Linux and either traditional laptops or netbooks (such as the Asus EEE PC, Everex CloudBook or MSI Wind).

Notices


Reply
  Search this Thread
Old 03-14-2019, 10:19 PM   #1
llewellen
Member
 
Registered: Oct 2016
Location: Vancouver Island, Canada
Distribution: Parabola-Enlightenment Manjaro-Budgie
Posts: 288

Rep: Reputation: Disabled
Defang a Laptop Keyboard


Manjaro Linux Budgie DE Dell Inspiron 13 7000

How to reduce the keyboard and touchpad to doing only what I specifically direct them to do? I'm tired of accidentally hitting the shift key and having the cursor jump back a paragraph and delete everything in between. I'm tired of the cursor suddenly jumping somewhere while I'm typing, resulting in text being entered in the wrong place. I'm tired of accidentally hitting apparent keyboard shortcuts I didn't even know existed.

If my finger hits a key, render only that character and nothing else. If I accidentally hit two keys at once, thereby giving ambivalent instructions, do nothing. If I don't touch the touchpad deliberately, don't do anything and don't move randomly.

Any clues?
 
Old 03-15-2019, 12:57 AM   #2
crwmike
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Take a look at Touchpad Indicator.

https://aur.archlinux.org/packages/t...indicator-bzr/
https://launchpad.net/touchpad-indicator
 
Old 03-15-2019, 06:13 AM   #3
petelq
Member
 
Registered: Aug 2008
Location: UK
Distribution: openSUSE(Leap and Tumbleweed) and a regularly changing third
Posts: 362

Rep: Reputation: Disabled
Or just be very careful when you use them.
 
Old 03-15-2019, 10:35 AM   #4
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 2,826

Rep: Reputation: Disabled
I nearly always use a USB mouse with my 'laptops', they're more portable computers, to me, so I could turn off the touchpad completely, if I wanted to, maybe that would work for you too.
 
Old 03-15-2019, 11:55 AM   #5
DavidMcCann
LQ Veteran
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Xubuntu
Posts: 5,200

Rep: Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742Reputation: 1742
Adjust the sensitivity of the touch-pad, or disable it and use a mouse.
Edit the keyboard shortcuts, removing all those that you don't use.
Be more careful!
 
Old 03-15-2019, 07:02 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / Linux Mint / Debian / Void Linux
Posts: 8,131

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
that is something I was experiencing with the touch-pad on, my thumb or palm or some part of my hand, would lightly slip over it while typing then the menu would pop up and select cut or delete or whatever it did it would be gone

Code:
xinput set-prop $(xinput | awk '/TouchPad/ {print $6}' | cut -d= -f2) "Device Enabled" 0 &
so I put that in my autostart to turn it off every time I log in. not used in dt but wm's. DT's have a settings that you can turn off the touch pad.

Last edited by BW-userx; 03-15-2019 at 07:06 PM.
 
Old 03-16-2019, 06:11 AM   #7
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,046
Blog Entries: 7

Rep: Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780Reputation: 2780
Quote:
Originally Posted by llewellen View Post
Manjaro Linux Budgie DE Dell Inspiron 13 7000

How to reduce the keyboard and touchpad to doing only what I specifically direct them to do? I'm tired of accidentally hitting the shift key and having the cursor jump back a paragraph and delete everything in between. I'm tired of the cursor suddenly jumping somewhere while I'm typing, resulting in text being entered in the wrong place. I'm tired of accidentally hitting apparent keyboard shortcuts I didn't even know existed.

If my finger hits a key, render only that character and nothing else. If I accidentally hit two keys at once, thereby giving ambivalent instructions, do nothing. If I don't touch the touchpad deliberately, don't do anything and don't move randomly.

Any clues?
that's funny.
for the touchpad issues, i'd try syndaemon. it's not perfect but fairly simple to set up.
the rest - to make it system wide you'd have to disable all "special" keys on your keymap, like Ctrl, Shift, Alt etc. i'm sure that's possible, but it would render your system unusable.
or go manually through each and every application and disable ALL offending keyboard shortcuts.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Layout initially different between USB keyboard and laptop's integrated keyboard BrutalMusic Linux - Laptop and Netbook 6 02-07-2014 04:06 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Laptop and Netbook

All times are GMT -5. The time now is 03:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration