LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 10-10-2021, 02:46 PM   #1
alp_c
LQ Newbie
 
Registered: Oct 2021
Posts: 7

Rep: Reputation: Disabled
Strange Youtube stutter


Dear all,

I am experiencing a very strange way of stutter when watching Youtube videos. Every couple of minutes it repeats the previous ~0.5 sec of audio and video. There is no regular pattern of when it occurs. All other applications run without any problems.

The system is a Core2Duo desktop with 4GB RAM, 160GB SSD. I'll paste the HW specs at the end of this post. It is set up as a triple boot configuration:

1) Linux Mint 20.2 Cinnamon with proprietary Nvidia-340-legacy drivers, X11, latest Firefox, kernel 5.4, SystemD init.
2) Devuan 4 Gnome (Debian Bullseye based) with Nouveau drivers, Wayland, latest Firefox-ESR, kernel 5.10, Runit init.
2a) (previously I also tried Devuan 4 Mate with Nouveau drivers, X11, latest Firefox-ESR, kernel 5.10, OpenRC init)
3) MS Windows 8.1 with latest Firefox

All GNU/Linux systems are having the issue, on Windows however it does NOT occur.

It appears to be independent of distro, kernel version, GPU drivers, X11/Wayland, Firefox version, desktop environment and init system. No peaks in resource usage (RAM/HDD). No entries in dmesg. I am using Ethernet rather than Wifi, if that matters.

Toggling gfx.webrender.all setting in Firefox makes no difference. And just tested latest Chromium browser in Linux Mint - same issue.

Could anyone think of what could be causing this? I've searched the web but could not find any solution so far.

Greetings
alp_c

--------


Machine: Type: Desktop Mobo: Gigabyte model: EP41-UD3L v: x.x serial: <filter> BIOS: Award v: F6
date: 04/22/2010
CPU: Topology: Dual Core model: Intel Core2 Duo E7500 bits: 64 type: MCP arch: Penryn rev: A
L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 11733
Speed: 1600 MHz min/max: 1600/2933 MHz Core speeds (MHz): 1: 1600 2: 1600
Graphics: Device-1: NVIDIA G96C [GeForce 9500 GT] vendor: ZOTAC driver: nvidia v: 340.108
bus ID: 01:00.0 chip ID: 10de:0640
Display: x11 server: X.Org 1.20.11 driver: nvidia
unloaded: fbdev,modesetting,nouveau,vesa resolution: 1440x900~60Hz
OpenGL: renderer: GeForce 9500 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes
Audio: Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: Gigabyte GA-D525TUD
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:27d8
Sound Server: ALSA v: k5.4.0-88-generic
Network: Device-1: Realtek RTL8192CE PCIe Wireless Network Adapter driver: rtl8192ce v: kernel
port: ce00 bus ID: 03:00.0 chip ID: 10ec:8178
IF: wlp3s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte
driver: r8169 v: kernel port: be00 bus ID: 04:00.0 chip ID: 10ec:8168
IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives: Local Storage: total: 149.05 GiB used: 10.76 GiB (7.2%)
ID-1: /dev/sda vendor: Intel model: SSDSA2CW160G3 size: 149.05 GiB speed: <unknown>
serial: <filter>
Partition: ID-1: / size: 27.35 GiB used: 10.76 GiB (39.3%) fs: ext4 dev: /dev/sda7
ID-2: swap-1 size: 7.45 GiB used: 768 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors: System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 70 C
Fan Speeds (RPM): N/A
 
Old 10-13-2021, 09:02 PM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: debian IceWM
Posts: 5,550

Rep: Reputation: Disabled
Hi

some of this may relate to hardware acceleration or the lack thereof. I note you do have one distro with accel.

https://askubuntu.com/questions/1085...rks-on-windows

Its the second reply but the pathway of /lib/modprobe.d may need to be /etc/modprobe.d

2) there is fair discussion in this post too.

lots of trouble shooting there

https://www.linuxquestions.org/quest...os-4175684140/
 
Old 10-14-2021, 04:19 AM   #3
alp_c
LQ Newbie
 
Registered: Oct 2021
Posts: 7

Original Poster
Rep: Reputation: Disabled
Hi aus9,

thank you for looking into this.

Regarding the KMS setting in your first link I found an Arch wiki entry, that "The proprietary NVIDIA driver supports KMS (since 364.12)". My card is a legacy 340.xx, so I assume it does not apply to my card. I also couldn't locate the file nvidia-kms.conf anywhere on my system. So the only thing I changed on my Mint system was changing NVIDIA settings from auto to high performance. In a first quick test the stutter has gone.

I'm going to check with my Devuan install though, which uses Nouveau, and Arch wiki states "Intel, Nouveau, ATI and AMDGPU drivers already enable KMS automatically for all chipsets"

Source: https://wiki.archlinux.org/title/kernel_mode_setting

Your second link refers to a discussion which talks about symptoms I don't have, i.e. black screen, resolution changes, waiting circle.

Best
alp_c
 
Old 10-15-2021, 03:29 AM   #4
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 17,934
Blog Entries: 11

Rep: Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409Reputation: 5409
Quote:
Originally Posted by alp_c View Post
Your second link refers to a discussion which talks about symptoms I don't have
Yes, but it was provided with the comment "lots of troubleshooting here", which I take as a hint for you to look what people did to troubleshoot the problem, and repeat some of these steps, to be able to provide some palpable info on the problem.
 
Old 10-15-2021, 01:42 PM   #5
alp_c
LQ Newbie
 
Registered: Oct 2021
Posts: 7

Original Poster
Rep: Reputation: Disabled
Back with some results.

In my Mint install, all I had to do was changing the "PowerMizer Settings" in NVIDIA Control panel from Auto/Adaptive to Maximum. Right from this moment, the stutter has gone. After rebooting, this setting changes back to Auto/Adaptive, but _still_ the issue does not appear again.

On my Devuan install with Nouveau however, the stutter is still there and I didn't find a way to fix it. I tried the h264ify extension in Firefox to force the codec to H264, but it didn't make a difference.

So it seems to be a video driver thing. Maybe Nouveau is just not that perfect for an aged video card like mine, or the video card itself might have a glitch which only the proprietary driver is able to circumnavigate?

@ondoho: I'll take another look into the troubleshooting link.

Edit: I also couldn't locate the file nvidia-kms.conf anywhere on my Devuan install, so I am assuming that KMS is not used with Nouveau either.

Last edited by alp_c; 10-15-2021 at 01:44 PM. Reason: added KMS comment
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strang Youtube stutter alp_c Linux - Newbie 6 10-11-2021 02:58 AM
LXer: How To Cast YouTube Videos From Your Phone To Raspberry Pi Using YouTube On TV (youtube.com/tv) LXer Syndicated Linux News 0 04-16-2021 01:30 AM
ffmpeg grabbing full screen youtube: first seconds of sound - stutter kaza Linux - Software 2 06-03-2018 02:05 AM
Audio stutter - how to restart ALSA? axelsharper Linux - Software 3 07-16-2004 01:58 AM
Strange Stutter toadmaster Linux - General 6 03-02-2003 12:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 09:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration