LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-19-2020, 06:41 PM   #1
jrch
Member
 
Registered: Mar 2006
Posts: 118

Rep: Reputation: 15
Thumbs down Slack 14.2 will not allow change 'open with' property of image


*OK so I 'SOLVED' the problem. But this should be unnecessary.

-----------------------------------------------
Still in Thunar (!) I 'copied' the file, making a new '...(Copy 1).png' file.
NOW the property 'open with - Geegie', which I had TRIED to make work in the original - came across and WORKS now (!!). It also works in the original.

As I said, this should not be necessary, and is by any definition a *bug*. But not worth the red tape to 'report' it.
------------------------------------------------

Using Slackware64 14.2 with xfce4. So my problem is with Thunar (file manager).

png image with me as owner, all privs. Set to open with GIMP.

I *CANNOT CHANGE* this. CANNOT make it 'open with Geegie' for instance, or any other viewer.

---
BUT - 'solved' as above.

jrc

Last edited by jrch; 01-19-2020 at 07:03 PM. Reason: SOLVED as described
 
Old 01-19-2020, 06:56 PM   #2
termayto
LQ Newbie
 
Registered: Jan 2019
Distribution: Slackware64 14.2
Posts: 16

Rep: Reputation: 16
In using KDE (or just using dolphin) you should be able to right click the file, click properties, then click the "File Type Options" button. From there you should be able to add, remove and change the order of programs used to open that file type by default.

In Xfce4 (or just using thunar) you should be able to right click on the file, click properties, then select from the "Open with:" list.

If that doesn't work, is it just this one file? just PNG files? or are you unable to change the default application for any files?
 
Old 01-19-2020, 07:08 PM   #3
vtel57
Senior Member
 
Registered: Jul 2006
Location: VPN Tunnel, USA
Distribution: Slackware64 14.2
Posts: 1,265

Rep: Reputation: 270Reputation: 270Reputation: 270
Hmm... I have thousands of images that are .png on my system. I have no trouble at all opening them with Thunar/Geeqie. And I'm very sorry to hear that you don't care for The GIMP. There's good documentation out there for this app. Possibly you aren't aware of these sites:

https://docs.gimp.org/en/

https://www.gimp.org/

http://www.gimpology.com/

https://www.unixmen.com/30-great-tutorials-for-gimp/

https://www.gimpusers.com/

Getting back to your .png issues, though. I can't really help you without some more detailed information about what is actually happening when you try to open your .pngs. Can you post descriptions and/or screenshots? Where are your .pngs located on your system? In your /home/<username> directory or elsewhere? What permissions are set for these images? Any info you can give will help us help you.

Standing by...
 
Old 01-19-2020, 07:18 PM   #4
vtel57
Senior Member
 
Registered: Jul 2006
Location: VPN Tunnel, USA
Distribution: Slackware64 14.2
Posts: 1,265

Rep: Reputation: 270Reputation: 270Reputation: 270
Quote:
Originally Posted by jrch View Post
*OK so I 'SOLVED' the problem. But this should be unnecessary.

And I apologize for not completely understanding your issue here regarding the .png files.



Now that I see what you were talking about, I've tried on my own system to change the default viewer of .png images from Geeqie to Gwenview. All worked fine for me, so I'm just not sure what was causing the issue on your system.


Regards,


~Eric
 
Old 01-25-2020, 11:33 PM   #5
Geist
Member
 
Registered: Jul 2013
Distribution: Slackware 14 / current
Posts: 365

Rep: Reputation: Disabled
For future reference:


To find out the 'mime type" of a file, if you don't know it yourself ( in this case a png ):
Code:
xdg-mime query filetype /tmp/a_png_file.png
This would return "image/png"

To find which application is currently the default for 'xdg-open' operations (aka, usually "most" things like double clicking stuff in a file manage)
For pngs, for example:
Code:
xdg-mime query default image/png
To set a default application:
In this case, open pngs with Krita
Code:
xdg-mime  default krita.desktop  image/png
Note: It might need a reboot, or at least a session restart (log out completely) to show the changes.
There is of course a better way for that but let's keep it like this for now, if you're a user who doesn't really care about keeping the computer up at all times.

Last edited by Geist; 01-25-2020 at 11:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Publisher 'DRMs' Physical Legal Textbook About 'Property,' Undermines Property And First Sale LXer Syndicated Linux News 0 05-08-2014 08:11 AM
image/text bound property aayu09 Linux - Software 2 11-03-2010 01:19 PM
[ruby][gtk2] Style Property - How to change? robuxbiz Programming 3 06-06-2010 05:46 AM
LXer: "Intellectual Property" a Violation of Real Property LXer Syndicated Linux News 1 11-11-2009 06:39 AM
How do you change the file Property from Read Only to .... Charlie Chan Linux - Newbie 1 05-16-2004 01:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration