LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-12-2018, 01:57 PM   #1
panpo
LQ Newbie
 
Registered: Aug 2018
Distribution: Slackware
Posts: 3

Rep: Reputation: Disabled
Problems with UTF-8 characters after installing the multilib on 14.2


Hi,

I have some problems with UTF-8 characters. I have found an issue with nvi, vim and less.

With nvi, if I type a non-ascii character, the program exited with the message: "Aborted (core dumped)".

With vim, non-ascii characters are not properly rendered. For example, the "é" character is inserted as "é ", "€" as "�~B�", etc. I have the same problem with elvis.

With less, some UTF-8 are print in hex value, for exemple, "é" is printed as "<C3><A9>".

Other informations :

- I am running Slackware 14.2,
- I have commented the "export LANG=en_US" line in /etc/profile.d/lang.sh file and uncommented the "export LANG=en_US.UTF-8" line,
- when I have installed the multilib, I did it with slackpkg+ but I seleccted the wrong slackware version. I installed the multilib for -current. So I tried to remove it and, then, install the 14.2 one instead,
- I have a quick fix for those problems:

Code:
# slackpkg upgrade-all
# slackpkg upgrade multilib
# slackpkg install multilib
For now, I do not now how and when the bug comes again. Is there any way to fix it?

Thanks !
 
Old 08-13-2018, 09:50 AM   #2
RandomTroll
Senior Member
 
Registered: Mar 2010
Distribution: Slackware
Posts: 1,009

Rep: Reputation: 164Reputation: 164
Code:
append="vt.default_utf8=1"
in /etc/lilo.conf ? I thought this was the default.
 
Old 08-13-2018, 03:16 PM   #3
panpo
LQ Newbie
 
Registered: Aug 2018
Distribution: Slackware
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thank you for you reply. I have already added this in my elilo.conf file. I tried to reboot without and it gave the same result. Here is what I have:

Code:
append="resume=/dev/sda2 vt.default_utf8=1"
To answer what business_kid said in my other post (cf. double post) I tried other terminals: st, xtrem and rxvt. I don't know about the "runlevel 3" however. I tried to run nvi in the TTY before doing startx and the same problem occurs.

Sorry for the other post btw! I thought the first one was not published since I get disconnected when I created it.

Last edited by panpo; 08-14-2018 at 01:08 AM. Reason: Just realized I made 2 threads…
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with UTF-8 characters after installing the multilib in 14.2 panpo Slackware 1 08-13-2018 09:39 AM
[SOLVED] how can I draw flowcharts with utf-8 characters rblampain Programming 4 10-15-2015 10:51 PM
gimp text and utf characters dokkalf Slackware 2 09-14-2014 11:18 PM
[SOLVED] MySQL, UTF-8 and accented characters Tinkster Linux - Software 15 02-03-2010 11:45 AM
How to input non-utf characters from utf-8 linux enviroment? jadas Linux - General 6 02-07-2009 04:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration