LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin
User Name
Password
Linux Deepin This forum is for the discussion of Linux Deepin.

Notices


Reply
  Search this Thread
Old 01-15-2020, 11:37 AM   #1
Vlvi
LQ Newbie
 
Registered: Dec 2019
Posts: 15

Rep: Reputation: Disabled
Install touchpad drivers


Hi again!

I'm back with another problem, but i think this one is significantly easier to fix. My touchpad isn't working (not detected by deepin). It didn't either work in windows 10 but I simply had to install the driver from acer support (synaptics one) here https://www.acer.com/ac/en/US/conten...oduct/8028?b=1

that driver is only for windows 10. I found synaptic touchpad driver for linux but couldn't make it work.

Reference for linux synaptics https://wiki.debian.org/SynapticsTouchpad

the first step (egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices) doesn't return anything
 
Old 01-16-2020, 01:16 PM   #2
teckk
Senior Member
 
Registered: Oct 2004
Distribution: FreeBSD Arch
Posts: 2,524

Rep: Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613Reputation: 613
Some info
Code:
pkgname=xf86-input-synaptics
pkgver=1.9.1

curl -I https://xorg.freedesktop.org/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2{,.sig}
HTTP/1.1 200 OK
Date: Thu, 16 Jan 2020 18:11:18 GMT
Server: Apache/2.4.38 (Debian)
Last-Modified: Tue, 29 May 2018 03:19:22 GMT
ETag: "7afaa-56d4fb356c38c"
Accept-Ranges: bytes
Content-Length: 503722
Content-Type: application/x-bzip2

HTTP/1.1 200 OK
Date: Thu, 16 Jan 2020 18:11:18 GMT
Server: Apache/2.4.38 (Debian)
Last-Modified: Tue, 29 May 2018 03:19:22 GMT
ETag: "5f-56d4fb3623d1b"
Accept-Ranges: bytes
Content-Length: 95
Content-Type: application/pgp-signature
According to the arch PKGBUILD it needs
Code:
depends=('libxtst' 'libevdev')
makedepends=('xorg-server-devel' 'X-ABI-XINPUT_VERSION=24.1' 'libxi' 'libx11' 'xorgproto')
conflicts=('xorg-server<1.19' 'X-ABI-XINPUT_VERSION<24.1' 'X-ABI-XINPUT_VERSION>=25')
Do you have a package in your repo called something like xf86-input-synaptics?
 
1 members found this post helpful.
Old 01-17-2020, 06:30 AM   #3
Vlvi
LQ Newbie
 
Registered: Dec 2019
Posts: 15

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by teckk View Post
Some info
Code:
pkgname=xf86-input-synaptics
pkgver=1.9.1

curl -I https://xorg.freedesktop.org/releases/individual/driver/${pkgname}-${pkgver}.tar.bz2{,.sig}
HTTP/1.1 200 OK
Date: Thu, 16 Jan 2020 18:11:18 GMT
Server: Apache/2.4.38 (Debian)
Last-Modified: Tue, 29 May 2018 03:19:22 GMT
ETag: "7afaa-56d4fb356c38c"
Accept-Ranges: bytes
Content-Length: 503722
Content-Type: application/x-bzip2

HTTP/1.1 200 OK
Date: Thu, 16 Jan 2020 18:11:18 GMT
Server: Apache/2.4.38 (Debian)
Last-Modified: Tue, 29 May 2018 03:19:22 GMT
ETag: "5f-56d4fb3623d1b"
Accept-Ranges: bytes
Content-Length: 95
Content-Type: application/pgp-signature
According to the arch PKGBUILD it needs
Code:
depends=('libxtst' 'libevdev')
makedepends=('xorg-server-devel' 'X-ABI-XINPUT_VERSION=24.1' 'libxi' 'libx11' 'xorgproto')
conflicts=('xorg-server<1.19' 'X-ABI-XINPUT_VERSION<24.1' 'X-ABI-XINPUT_VERSION>=25')
Do you have a package in your repo called something like xf86-input-synaptics?
~$dpkg-query --list xf86-input-synaptics
not packages found

But i don't know if that's the correct command to use.

The debian article i posted above says "In most cases, make sure you have xserver-xorg-input-libinput xserver-xorg-input-evdev xserver-xorg-input-mouse installed, and not the xserver-xorg-input-synaptics package."

xserver-xorg-input-synaptics and xserver-xorg-input-libinput came installed, i installed the other 2 and remove -input-synaptics as article said, but it didn't work.

Last edited by Vlvi; 01-17-2020 at 06:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Touchpad disable button permanently disables touchpad until reboot William (Dthdealer) Linux - Hardware 12 08-01-2009 11:51 PM
Need to kill touchpad click. (Synaptics Touchpad / FC4) sarysa Linux - Laptop and Netbook 4 02-19-2007 04:15 PM
IBM laptop & touchpad & TrackPoint - touchpad doesn't work! espinosa_cz Linux - Laptop and Netbook 1 08-20-2004 01:45 PM
Using Touchpad + USB WLAN means touchpad and keyboard stops responding randomly ultrabeam16 Linux - Laptop and Netbook 0 03-21-2004 03:19 PM
USBmouse/touchpad together, touchpad behaves erratically Pathian Mandriva 2 01-07-2004 03:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin

All times are GMT -5. The time now is 11:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration