LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-13-2018, 10:56 AM   #1
White Witch
LQ Newbie
 
Registered: Jun 2018
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 9

Rep: Reputation: Disabled
Google Earth 6 Stopped Working with Upgrade to Ubuntu 18.04


Hello, all. I had previously installed Google Earth 6 on an older laptop, an HP Pavilion d71285dx, when I was still running Ubuntu 16.04 LTS. The program worked perfectly until I upgraded to Ubuntu 18.04 LTS, and I couldn't get it working again. The new version of Google Earth Pro will not work on this computer. Does anyone have any experience with this issue, or any suggestions? Thanks.
 
Old 06-13-2018, 12:12 PM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Augsburg
Distribution: Opensuse 15.0, Kubuntu 18.04, Win 10
Posts: 2,050

Rep: Reputation: 144Reputation: 144
Can you start google earth on console and post the output here?
 
Old 06-13-2018, 01:03 PM   #3
White Witch
LQ Newbie
 
Registered: Jun 2018
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 9

Original Poster
Rep: Reputation: Disabled
I tried reinstalling and running it, and here's what I got in response:

jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC:~$ sudo apt-get install googleearth-package
[sudo] password for jennifer:
Reading package lists... Done
Building dependency tree
Reading state information... Done
googleearth-package is already the newest version (1.2.2).
The following packages were automatically installed and are no longer required:
dkms libgsoap-2.8.60 libvncserver1 python-pysqlite2 virtualbox-dkms
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 20 not upgraded.
jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC:~$ make-googleearth-package --force
cat: /etc/mailname: No such file or directory
Google Earth for GNU/Linux 6.0.3.2197
Supported Google Earth version: 6.0.3.2197
./
./googleearth.xpm
./desktop_icons/
./desktop_icons/pro/
./desktop_icons/pro/product_logo_128.png
./desktop_icons/pro/product_logo_22.png
./desktop_icons/pro/product_logo_64.png
./desktop_icons/pro/product_logo_16.png
./desktop_icons/pro/product_logo_256.png
./desktop_icons/pro/product_logo_32.xpm
./desktop_icons/pro/product_logo_24.png
./desktop_icons/pro/product_logo_48.png
./desktop_icons/pro/product_logo_32.png
./desktop_icons/ec/
./desktop_icons/ec/product_logo_128.png
./desktop_icons/ec/product_logo_22.png
./desktop_icons/ec/product_logo_64.png
./desktop_icons/ec/product_logo_16.png
./desktop_icons/ec/product_logo_256.png
./desktop_icons/ec/product_logo_32.xpm
./desktop_icons/ec/product_logo_24.png
./desktop_icons/ec/product_logo_48.png
./desktop_icons/ec/product_logo_32.png
./desktop_icons/consumer/
./desktop_icons/consumer/product_logo_128.png
./desktop_icons/consumer/product_logo_22.png
./desktop_icons/consumer/product_logo_64.png
./desktop_icons/consumer/product_logo_16.png
./desktop_icons/consumer/product_logo_256.png
./desktop_icons/consumer/product_logo_32.xpm
./desktop_icons/consumer/product_logo_24.png
./desktop_icons/consumer/product_logo_48.png
./desktop_icons/consumer/product_logo_32.png
./setup.sh
./googleearth-linux-x86.tar
./setup.data/
./setup.data/locale/
./setup.data/locale/es/
./setup.data/locale/es/LC_MESSAGES/
./setup.data/locale/es/LC_MESSAGES/setup.mo
./setup.data/locale/es/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/fr/
./setup.data/locale/fr/LC_MESSAGES/
./setup.data/locale/fr/LC_MESSAGES/setup.mo
./setup.data/locale/fr/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/nl/
./setup.data/locale/nl/LC_MESSAGES/
./setup.data/locale/nl/LC_MESSAGES/setup.mo
./setup.data/locale/nl/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/sv/
./setup.data/locale/sv/LC_MESSAGES/
./setup.data/locale/sv/LC_MESSAGES/setup.mo
./setup.data/locale/sv/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/ru/
./setup.data/locale/ru/LC_MESSAGES/
./setup.data/locale/ru/LC_MESSAGES/setup.mo
./setup.data/locale/ru/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/it/
./setup.data/locale/it/LC_MESSAGES/
./setup.data/locale/it/LC_MESSAGES/setup.mo
./setup.data/locale/it/LC_MESSAGES/loki-uninstall.mo
./setup.data/locale/de/
./setup.data/locale/de/LC_MESSAGES/
./setup.data/locale/de/LC_MESSAGES/setup.mo
./setup.data/locale/de/LC_MESSAGES/loki-uninstall.mo
./setup.data/setup.xml
./setup.data/setup.glade
./setup.data/splash.xpm
./setup.data/setup.gtk2.glade
./setup.data/config.sh
./setup.data/bin/
./setup.data/bin/OpenBSD
./setup.data/bin/NetBSD
./setup.data/bin/Linux/
./setup.data/bin/Linux/x86_64
./setup.data/bin/Linux/x86/
./setup.data/bin/Linux/x86/setup.gtk2
./setup.data/bin/Linux/x86/uninstall
./setup.data/bin/Linux/x86/setup.gtk
./setup.data/bin/Linux/amd64
./setup.data/bin/FreeBSD
./README.linux
./googleearth-icon.png
./linux/
./linux/xdg/
./linux/xdg/xdg-desktop-menu
./linux/xdg/xdg-desktop-icon
./linux/xdg/xdg-mime
./googleearth-data.tar
./postinstall.sh
./bin/
./bin/googleearth
./preuninstall.sh
Package: googleearth
Version: 6.0.3.2197+1.2.0-1
Section: non-free/science
Priority: optional
Maintainer: <jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC>
Architecture: amd64
Depends: fonts-liberation, libfreeimage3, lsb-core, libqtcore4, libgl1-mesa-glx, libglu1-mesa , libcurl3:i386, libsm6:i386, libfontconfig1:i386, libxt6:i386, libxrender1:i386, libxext6:i386, libgl1-mesa-glx:i386, libgl1-mesa-dri:i386
Suggests: lib32nss-mdns|libnss-mdns:i386, libgl1-nvidia-glx:i386, libgl1-fglrx-glx:i386
Description: Google Earth, a 3D map/planet viewer
Package built with googleearth-package.
dpkg-deb: building package 'googleearth' in './googleearth_6.0.3.2197+1.2.0-1_amd64.deb'.
-----------------------------
Success!
You can now install the package with e.g:

sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb
-----------------------------
jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC:~$ sudo dpkg -i googleearth_6.0.3.2197+1.2.0-1_amd64.deb
Selecting previously unselected package googleearth.
(Reading database ... 281710 files and directories currently installed.)
Preparing to unpack googleearth_6.0.3.2197+1.2.0-1_amd64.deb ...
Unpacking googleearth (6.0.3.2197+1.2.0-1) ...
dpkg: dependency problems prevent configuration of googleearth:
googleearth depends on libfreeimage3; however:
Package libfreeimage3 is not installed.
googleearth depends on lsb-core; however:
Package lsb-core is not installed.
googleearth depends on libcurl3:i386; however:
googleearth depends on libsm6:i386; however:
Package libsm6:i386 is not installed.
googleearth depends on libxt6:i386; however:

dpkg: error processing package googleearth (--install):
dependency problems - leaving unconfigured
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.23-1ubuntu3) ...
Processing triggers for menu (2.1.47ubuntu2) ...
Processing triggers for shared-mime-info (1.9-2) ...
Errors were encountered while processing:
googleearth
jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC:~$ googleearth
/usr/bin/googleearth: 18: /usr/bin/googleearth: /usr/lib/googleearth/googleearth-bin: not found
jennifer@jennifer-HP-Pavilion-dv7-Notebook-PC:~$
 
Old 06-13-2018, 03:34 PM   #4
White Witch
LQ Newbie
 
Registered: Jun 2018
Distribution: Ubuntu 18.04 Bionic Beaver
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hi, again. I solved the problem on my own:

It turns out that Google Earth Pro is incompatible with the Nouveau video driver. I uninstalled Google Earth 6 and installed the .deb file for Google Earth Pro from Google's website. Then I went into Software & Updates/Additional Drivers and enabled the Nvidia driver. Then I blacklisted the Nouveau driver in /etc/modprobe.d/blacklist.conf and rebooted, and it Google Earth Pro is now working fine. Thanks anyway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Earth 7.1.8 on Ubuntu 16.04 not working with proxy jkurucar Linux - Software 2 01-28-2017 07:27 PM
google earth worked for a few days, then it stopped! jjge Slackware 4 04-01-2016 12:06 PM
[SOLVED] DLNA from Plex server stopped working after Ubuntu 13.04->13.10 upgrade fincher69 Linux - General 5 10-31-2013 09:53 AM
[SOLVED] Mounting USB Flash Drive Stopped Working with Upgrade to Ubuntu 13.04 Steve R. Ubuntu 0 04-28-2013 04:45 AM
Ubuntu 10.10: DVD playback stopped working after the upgrade tinker123 Ubuntu 3 12-03-2010 02:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration