LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices


Reply
  Search this Thread
Old 07-04-2018, 09:55 PM   #1
m0rt
LQ Newbie
 
Registered: Jun 2018
Posts: 8

Rep: Reputation: Disabled
Problem with apache2 package


Hello, everyone. You can help me with the following problem I have, I tell you I installed apache2 and php7 on my server Suse 12 Sp2 and it has brought me quite a few problems with php and I want to mount a laravel project I've been hours and well as I have no internet access from the server so I have installed all the components with rpm but as it has not worked the php files are downloaded and show me the source code and I have reviewed httpd -M and I am missing the component of apache2-mod_php7, so i decided to download all the dependencies thinking that i am missing some and i am surprised that when i download the apache2 files i get the following, someone knows what i can do?
Attached Thumbnails
Click image for larger version

Name:	Captura.PNG
Views:	7
Size:	61.9 KB
ID:	28047  
 
Old 07-04-2018, 10:00 PM   #2
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.4
Posts: 1,207

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
It looks like you got a warning, then aborted the installation. Why?
 
Old 07-04-2018, 10:33 PM   #3
m0rt
LQ Newbie
 
Registered: Jun 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
It looks like you got a warning, then aborted the installation. Why?
well in that image I am not installing the package I am downloading them, and already in the server that I have in production I installed the complement apache2_mod_php7 but when I access my php project and write something like this 127.0.0.0.1/project/index.php, what the browser does is to download the index.php file also when I put this command httpd -M does not appear this apache2_mod_phpp7 module so I think it is incompatible at the moment with Suse 12 SP2
 
Old 07-04-2018, 11:42 PM   #4
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.4
Posts: 1,207

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Did you restart the web server? l
The issue you describe has nothing to do with the OS. If a restart of the web server doesnt fix it, then your web server (apache2) is mis-configured.
 
Old 07-04-2018, 11:46 PM   #5
m0rt
LQ Newbie
 
Registered: Jun 2018
Posts: 8

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
Did you restart the web server? l
The issue you describe has nothing to do with the OS. If a restart of the web server doesnt fix it, then your web server (apache2) is mis-configured.
restart apache several times, the default setting is as default
 
Old 07-05-2018, 01:28 AM   #6
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.4
Posts: 1,207

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
If you call a php file and the web server downloads it instead of executing it, that indicates a mis-configuration of the web server.

In apache 2.4.6 there needs to be
Code:
<FilesMatch \.php$>
    SetHandler application/x-httpd-php  
</FilesMatch>
in one of the config files...on my server it's /etc/httpd/conf.d/php.conf

Please study and understand how to configure your web server. See this Let us know if you have any questions.

Last edited by scasey; 07-05-2018 at 01:30 AM.
 
Old 07-05-2018, 02:27 AM   #7
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.4
Posts: 1,207

Rep: Reputation: 405Reputation: 405Reputation: 405Reputation: 405Reputation: 405
Quote:
Originally Posted by ShonSpawnst View Post
Greeting.
I'm faced with a problem. I can not find a driver for my laptop(Toshiba).
There are a lot of viruses or doesn't work at all or more,they want me to make a paid subscription.Need a help.
Welcome to LQ.
I don’t see how your question relates to the topic of this thread in any way.

Please start your own thread, maybe in the Linux laptops forum.
Please read the How To Ask A Question link in my signature, first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Problem installing Vagrant - another package is holding the yum lock and it can't find the package ikhall Linux - Newbie 4 03-18-2018 05:26 PM
No Apache2 package in 13.37? wolf2600 Slackware 5 05-02-2013 12:31 PM
Compiling LAMP from source - apache2 error “no MPM package installed” nicky77 Linux - Software 2 03-09-2010 09:19 AM
message "Problem during installation: x package needed for (installed) x package frayed2 Linux - Newbie 1 04-24-2005 07:05 PM
apache2 + php4 package problems atheist Debian 4 10-25-2004 09:22 PM

LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise

All times are GMT -5. The time now is 07:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration