LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-02-2020, 09:55 PM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,625

Rep: Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072
current cannot use MAKE it broke ....


I am lost one this one.... I just installed current on this laptop, updated it, and am adding what I need and I see this...

Code:
$ make
make: Warning: File 'Makefile' has modification time 10013 s in the future
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/sh /home/userx/Downloads/wmbutton-0.7.1/missing aclocal-1.15 
/home/userx/Downloads/wmbutton-0.7.1/missing: line 81: aclocal-1.15: command not found
WARNING: 'aclocal-1.15' is missing on your system.
         You should only need it if you modified 'acinclude.m4' or
         'configure.ac' or m4 files included by 'configure.ac'.
         The 'aclocal' program is part of the GNU Automake package:
         <http://www.gnu.org/software/automake>
         It also requires GNU Autoconf, GNU m4 and Perl in order to run:
         <http://www.gnu.org/software/autoconf>
         <http://www.gnu.org/software/m4/>
         <http://www.perl.org/>
make: *** [Makefile:395: aclocal.m4] Error 127
 
Old 01-02-2020, 09:59 PM   #2
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,625

Original Poster
Rep: Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072
DL'ed a fresh copy of the dockapp and it works....
 
Old 01-02-2020, 10:00 PM   #3
orbea
Senior Member
 
Registered: Feb 2015
Distribution: Slackware64-current
Posts: 1,855

Rep: Reputation: Disabled
The wmbutton-0.7.1 slackbuild at SBo builds fine on current for me, I'm not sure how you are getting to this result. Maybe you need to try 'autoreconf -fi' before ./configure?
 
Old 01-02-2020, 10:03 PM   #4
Loomx
Member
 
Registered: Sep 2012
Distribution: Slackware
Posts: 74

Rep: Reputation: Disabled
Quote:
make: Warning: File 'Makefile' has modification time 10013 s in the future
Is your time set correctly?
 
Old 01-02-2020, 10:19 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,625

Original Poster
Rep: Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072
Quote:
Originally Posted by Loomx View Post
Is your time set correctly?
yeahhhh it is a copy I've been saving, and I moved it onto the new install then ntp set time on system afterwards.
 
Old 01-02-2020, 10:20 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,625

Original Poster
Rep: Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072Reputation: 2072
Quote:
Originally Posted by orbea View Post
The wmbutton-0.7.1 slackbuild at SBo builds fine on current for me, I'm not sure how you are getting to this result. Maybe you need to try 'autoreconf -fi' before ./configure?
yeahhh it is a mod one I keep, I changed the buttons to custom ones using gimp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Swaret: --current upgrade broke some programs deadlikeoscar Slackware 30 05-16-2006 10:35 AM
Swaret upgrade from 10.0 to current broke glibc - unable to login vharishankar Slackware 6 04-03-2006 01:30 AM
-current broke open gl bird603568 Slackware 2 07-15-2005 09:16 PM
Alsa broke while upgrading to Slackware-current Almighty-Bob Linux - Software 5 03-16-2005 09:07 PM
Xorg broke after update to current coffeedemon Slackware 1 11-10-2004 01:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration