LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices


Reply
  Search this Thread
Old 05-17-2018, 10:49 AM   #1
T32803
LQ Newbie
 
Registered: May 2018
Posts: 1

Rep: Reputation: Disabled
RHEL 7.5 - Storing Automount Maps in LDAP not working


I followed the Red Hat document here:
https://access.redhat.com/documentat...ig-autofs-LDAP

But it does not work as stated. The above linked instructions state 3 tasks:

-------------------------------------------------------------------------
1. Verify BASE and URI are set correctly in /etc/openldap/ldap.conf:
-------------------------------------------------------------------------
#
# LDAP Defaults
#

# See ldap.conf(5) for details
# This file should be world readable but not world writable.

#BASE dc=example,dc=com
#URI ldap://ldap.example.com ldap://ldap-master.example.com:666

#SIZELIMIT 12
#TIMELIMIT 15
#DEREF never

TLS_CACERTDIR /etc/openldap/cacerts

# Turning this off breaks GSSAPI used with krb5 when rdns = false
SASL_NOCANON on
URI ldap://ldap02.testdomain.com/
BASE dc=testdomain,dc=com


-------------------------------------------------------------------------
2. edit /etc/autofs.conf to uncomment these lines:
-------------------------------------------------------------------------
map_object_class = automountMap
entry_object_class = automount
map_attribute = automountMapName
entry_attribute = automountKey
value_attribute= automountInformation

(By the way, the document seems in error stating /etc/sysconfig/autofs.
The location to uncomment is at /etc/autofs.conf. To be safe, I added these
lines in both files.)

-------------------------------------------------------------------------
3. Create the autofs ldif and ingest it with ldapadd command:
-------------------------------------------------------------------------
# extended LDIF
#
# LDAPv3
# base <> with scope subtree
# filter: (&(objectclass=automountMap)(automountMapName=auto.master))
# requesting: ALL
#

# auto.master, testdomain.com
dn: automountMapName=auto.master,dc=testdomain,dc=com
objectClass: top
objectClass: automountMap
automountMapName: auto.master

# extended LDIF
#
# LDAPv3
# base <automountMapName=auto.master,dc=testdomain,dc=com> with scope subtree
# filter: (objectclass=automount)
# requesting: ALL
#

# /home, auto.master, testdomain.com
dn: automountMapName=auto.master,dc=testdomain,dc=com
objectClass: automount
cn: /home

automountKey: /home
automountInformation: auto.home

# extended LDIF
#
# LDAPv3
# base <> with scope subtree
# filter: (&(objectclass=automountMap)(automountMapName=auto.home))
# requesting: ALL
#

# auto.home, testdomain.com
dn: automountMapName=auto.home,dc=testdomain,dc=com
objectClass: automountMap
automountMapName: auto.home

# extended LDIF
#
# LDAPv3
# base <automountMapName=auto.home,dc=testdomain,dc=com> with scope subtree
# filter: (objectclass=automount)
# requesting: ALL
#

# /home, auto.home, testdomain.com
dn: automountKey=/home,automountMapName=auto.home,dc=testdomain,dc=com
objectClass: automount
automountKey: /home
automountInformation: ldap02.testdomain.com:/export/home/&

-------------------------------------------------------------------------

The above procedure as followed by Red Hatís online documentation does not work.
When I try to ingest the autofs ldif I get this error:

# ldapadd -x -D "cn=ldapadmin,dc=testdomain,dc=com" -f /etc/openldap/ldifs/autofs.ldif -W
Enter LDAP Password:
adding new entry "automountMapName=auto.master,dc=testdomain,dc=com"
ldap_add: Invalid DN syntax (34)
additional info: invalid DN

Has anyone been down this road and found out how to make this work ?

Background:
1. My test ldap server (ldap02.testdomain.com) works and I can login using ldap accounts.
2. I have autofs set up manually on one of my test clients mount /home and that works also.

Thanks for helping..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
RHEL 7 getent passwd not working for LDAP bluforce Linux - Newbie 2 07-12-2017 11:18 AM
How to automount a windows fileserver to RHEL 5.3 clients using ldap authentication? AttilaTheMom Linux - Server 0 06-06-2012 04:33 PM
[SOLVED] Enable LDAP in PHP for Mediawiki - not working in RHEL khandu Red Hat 1 05-14-2012 07:11 PM
RHEL 5.1 Server - automount stopped working boxyzzy Red Hat 1 03-25-2008 07:17 PM
Automount NFS from LDAP info not working klnasveschuk Linux - Networking 2 07-26-2005 01:04 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat

All times are GMT -5. The time now is 02:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration