LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 04-07-2021, 09:52 AM   #1
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 700

Rep: Reputation: Disabled
libmpeg2?


Has anyone managed to get libmpeg2 to compile on aarch64? When I try, I get an "invalid configuration" error:

Code:
checking build system type... Invalid configuration `aarch64-slackware-linux': machine `aarch64-slackware' not recognized
configure: error: /bin/sh .auto/config.sub aarch64-slackware-linux failed
I've tried deleting everything in the --build string except "aarch64" and also replacing "slackware" with "slarm" to no effect. I've also tried deleting the --build string altogether, but it didn't like that, either!

Other distros seem to have built this library on aarch64, but I haven't been able to find any patches for it, and it doesn't seem to have been maintained for years!

Any suggestions gratefully received!

--
Pete
 
Old 04-07-2021, 10:44 AM   #2
sndwvs
Member
 
Registered: Aug 2014
Posts: 919

Rep: Reputation: Disabled
Code:
./configure --build=aarch64-unknown-linux
 
1 members found this post helpful.
Old 04-07-2021, 10:50 AM   #3
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 1,048

Rep: Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853
Quote:
Originally Posted by pchristy View Post
Code:
checking build system type... Invalid configuration `aarch64-slackware-linux': machine `aarch64-slackware' not recognized
configure: error: /bin/sh .auto/config.sub aarch64-slackware-linux failed
Try this within the source dir:
Code:
find . -name config.guess -print0 | xargs -0i cp -favv /usr/share/libtool/build-aux/config.guess '{}'
find . -name config.sub -print0 | xargs -0i cp -favv /usr/share/libtool/build-aux/config.sub '{}'
The toolchain quadlet for Slackware AArch64 will be: aarch64-slackware-linux-gnu btw.

Last edited by drmozes; 04-07-2021 at 10:54 AM. Reason: added proper aarch64 toolchain name for slack.
 
1 members found this post helpful.
Old 04-07-2021, 11:19 AM   #4
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 700

Original Poster
Rep: Reputation: Disabled
Thanks for the prompt replies, folks!

sndwvs: Yes! Substituting "unknown" in the --build string seems to have sorted it! Many thanks!

Drmozes:

Code:
find . -name config.guess -print0 | xargs -0i cp -favv /usr/share/libtool/build-aux/config.guess '{}'
'/usr/share/libtool/build-aux/config.guess' -> './.auto/config.guess'

find . -name config.sub -print0 | xargs -0i cp -favv /usr/share/libtool/build-aux/config.sub '{}'
'/usr/share/libtool/build-aux/config.sub' -> './.auto/config.sub'
I'm afraid that doesn't mean a lot to me - definitely not a programmer (though I used to be pretty good on 6502 code back in the day! ) those config.sub and config.guess files do exist in the locations found, and since substituting "unknown" into the --build string seems to work, I guess its all working as it should!

Anyway, I learn something new everyday!

Many thanks!

--
Pete
 
Old 04-07-2021, 11:26 AM   #5
sndwvs
Member
 
Registered: Aug 2014
Posts: 919

Rep: Reputation: Disabled
one more solution

Code:
xzcat $CWD/config.guess.xz > config.guess || exit 1
xzcat $CWD/config.sub.xz > config.sub || exit 1

Last edited by sndwvs; 04-07-2021 at 11:28 AM.
 
Old 04-07-2021, 11:26 AM   #6
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 1,048

Rep: Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853Reputation: 853
Quote:
Originally Posted by pchristy View Post
Code:
find . -name config.sub -print0 | xargs -0i cp -favv /usr/share/libtool/build-aux/config.sub '{}'
'/usr/share/libtool/build-aux/config.sub' -> './.auto/config.sub'
I'm afraid that doesn't mean a lot to me [..]
These are the scripts libtool uses to determine what it can do for a particular architecture.
The problem is that the libtool scripts packaged within that source are old. Updating them with newer ones will most likely fix it. I've updated 100s of package build scripts like this for Slackware AArch64.
Glad it works for you!
 
Old 04-07-2021, 12:43 PM   #7
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 700

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by drmozes View Post
I've updated 100s of package build scripts like this for Slackware AArch64.
And I'm looking forward to being able to try out the fruits of your labour!

Thanks for your efforts and advice - and sdnwvs, as well!

--
Pete
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 02:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration