LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-13-2019, 03:23 PM   #1
phalange
Member
 
Registered: May 2018
Distribution: Slackware, Nixos, Arch, Centos
Posts: 188

Rep: Reputation: Disabled
Touchy trackpad not tamed by libinput


I've hit the wall with this trackpad. I'm CONSTANTLY typing away only to find the the slightest whisper of my thumb against the trackpad changes focus and leads to chaos - either wasted keystrokes or typing into the wrong app / window and so on.

I have libinput under touchpad set to

Code:
Option "Tapping" "on"
Option "DisableWhileTyping" "on"
Option "TappingDrag" "on"
Option "TappingDragLock" "off"
I know the code is working since tapping is indeed activated and does not work without that entry. But DisableWhileTyping (if it's doing anything) is nowhere near to getting the job done.

I use a window manager so there's no control panel for mouse settings, but even in xfce4 it's persnickety.

Any suggestions?
 
Old 09-13-2019, 10:03 PM   #2
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,457

Rep: Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798
I can't help with this problem, but I can provide heart-felt sympathy.

For those who might be able to help, what version of Slackware are you running?
 
1 members found this post helpful.
Old 09-13-2019, 11:05 PM   #3
phalange
Member
 
Registered: May 2018
Distribution: Slackware, Nixos, Arch, Centos
Posts: 188

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
I can't help with this problem, but I can provide heart-felt sympathy.

For those who might be able to help, what version of Slackware are you running?
I thank you for that. Perhaps one of these things has bedeviled you too? Sometimes I pine for those stamp-sized pads of yesteryear.

Slack -Current.
 
Old 09-14-2019, 06:00 AM   #4
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,841

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
You may find that property is not supported for your touchpad. Check with
Code:
libinput list-devices
FWIW, I recall this old thread where I posted a script that implements 'disable-while-typing' functionality, and will work even if a touchpad is being treated as a mouse input device. It might be an option here perhaps.
 
Old 09-14-2019, 12:25 PM   #5
Jan K.
Member
 
Registered: Apr 2019
Location: Esbjerg
Distribution: slackware...
Posts: 64

Rep: Reputation: 28
I've just aquired a laptop for playing with/learning Linux and after a very short time decided not to waste any more time with that %#&¤% touchpad thing, so disabled it in BIOS, bought a brilliant Logitech M705 mouse and - Voilá!

But then I'm of course old school... and it's of course no help at all to you!
 
Old 09-14-2019, 01:42 PM   #6
phalange
Member
 
Registered: May 2018
Distribution: Slackware, Nixos, Arch, Centos
Posts: 188

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by ferrari View Post
You may find that property is not supported for your touchpad
Thanks for the link. Running a script like that is an interesting idea.


Quote:
Originally Posted by Jan K. View Post
and it's of course no help at all to you!
I'll say, I may need to go this route. In home position, my hands smother the entire trackpad. I used synaptics long ago which allows you to deactivate edges of the touchpad to new presses. You can shrink the active area. In practice it was hit or miss though.
 
Old 09-16-2019, 08:50 AM   #7
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,457

Rep: Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798Reputation: 1798
Quote:
Originally Posted by phalange View Post
I thank you for that. Perhaps one of these things has bedeviled you too? Sometimes I pine for those stamp-sized pads of yesteryear.

Slack -Current.
Well, I grew up using manual typewriters and have a nasty habit of resting my thumbs on the spacebar; that doesn't work well when the trackpad sits at about the same place.
 
Old 09-17-2019, 10:47 PM   #8
phalange
Member
 
Registered: May 2018
Distribution: Slackware, Nixos, Arch, Centos
Posts: 188

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Richard Cranium View Post
Well, I grew up using manual typewriters and have a nasty habit of resting my thumbs on the spacebar; that doesn't work well when the trackpad sits at about the same place.
Yeah, I have some of the same habits and a trackpad that large has no leniency. Picking up my palms - which I probably ought to do anyway - seems to be more effective that noodling with settings.
 
1 members found this post helpful.
Old 09-17-2019, 11:51 PM   #9
upnort
Senior Member
 
Registered: Oct 2014
Distribution: Slackware, Proxmox, Debian, CentOS, Ubuntu MATE
Posts: 1,198

Rep: Reputation: Disabled
Quote:
Well, I grew up using manual typewriters and have a nasty habit of resting my thumbs on the spacebar; that doesn't work well when the trackpad sits at about the same place.
I also learned typing on manual typewriters. I have a similar habit of hovering my thumbs over the space bar.

I remember when "self-correcting" IBM Selectrics were introduced in the school typing class during my peach fuzz days. So cool with auto-erase ribbons. And they just sounded cool.

An uncle had a 1940's something Remington. Almost needed a sledge hammer to press the keys. No, not really.

Regarding trackpads, I don't know if this helps.
 
Old 09-18-2019, 01:29 AM   #10
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,841

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
Quote:
Regarding trackpads, I don't know if this helps.
Not for devices using libinput.
 
Old 09-18-2019, 01:37 AM   #11
Desiderius
Member
 
Registered: Jun 2017
Posts: 42

Rep: Reputation: Disabled
I had the same problem of touchpad on my Dell laptop.

And I succeeeded to solve it using syndaemon :

syndaemon - a program that monitors keyboard activity and disables the
touchpad when the keyboard is being used.
 
Old 09-18-2019, 08:18 AM   #12
phalange
Member
 
Registered: May 2018
Distribution: Slackware, Nixos, Arch, Centos
Posts: 188

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Desiderius View Post
I had the same problem of touchpad on my Dell laptop.

And I succeeeded to solve it using syndaemon :

syndaemon - a program that monitors keyboard activity and disables the
touchpad when the keyboard is being used.

Yes, synaptics had more settings than libinput, meaning you could (through tedious trial and error) reduce the surface area of a trackpad to new touches - meaning the whole trackpad still worked but new touches were only accepted in the very center. In theory this sounds good, but in practice it was so-so. And now synaptics is EOL and I'm on to libinput.

Thanks for posting this though - you are correct that syndaemon was more fine grained than libinput. I'll have to see if options have been added to libinput; last I checked it was limited.

Last edited by phalange; 09-18-2019 at 08:23 AM.
 
Old 09-19-2019, 04:30 PM   #13
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.2 64-bit
Posts: 487

Rep: Reputation: 161Reputation: 161
I got a new HP Elitebook this summer and when running current the touchpad and keyboard were very sensitive and jumping all over the place making it hard to write text files or search the web. When I ran "xinput" it showed that two touchpads were set up with two different IDs. When starting up there was an error message that two Synaptics touchpads were found.

Then running
Code:
egrep -i "input.*driver" /var/log/Xorg.0.log
showed that all devices used the libinput driver, except the two Synaptics touchpads which were using the synaptics driver. It seemed like they were fighting for some attention so I entered these two files in /etc/X11/xorg.conf.d:

Code:
/etc/X11/xorg.conf.d$ ls 
40-libinput.conf  50-synaptics.conf
File contents:

Code:
40-libinput.conf 

# Match on all types of devices but joysticks#
# If you want to configure your devices, do not copy this file.
# Instead, use a config snippet that contains something like this:
#
# Section "InputClass"
#   Identifier "something or other"
#   MatchDriver "libinput"
#
#   MatchIsTouchpad "on"
#   ... other Match directives ...
#   Option "someoption" "value"
# EndSection
#
# This applies the option any libinput device also matched by the other
# directives. See the xorg.conf(5) man page for more info on
# matching devices.

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

50-synaptics.conf


# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#

Section "InputClass"
        Identifier "SynPS/2 Synaptics TouchPad"
        MatchProduct "SynPS/2 Synaptics TouchPad"
        MatchDriver "SynPS/2 Synaptics TouchPad"
        MatchIsTouchPad "on" 
        MatchOS "Linux"
        MatchDevicePath "/dev/input/event"
        Option "Ignore" "on"
EndSection
Then after reboot
Code:
egrep -i "input.*driver" /var/log/Xorg.0.log
the touchpads are now also using the libinput driver and the keyboard and touchpad are working as expected with the correct sensitivity.

Looking at the web it seems like the high sensitivity/jumping cursor issue is a problem that occurs often with newer laptops. But there is a lot of different solution proposed for adjusting settings in the conf files instead of the simpler solution above that took some time to find out. Should there be a more resilient resolution for this for the new Slackware version so f.ex. not two touchpads are set up that competes with resources?
 
1 members found this post helpful.
Old 09-20-2019, 08:50 AM   #14
san2ban
Member
 
Registered: May 2013
Location: Bengaluru / India
Distribution: Slackware14.2-64bit, on libreboot
Posts: 147

Rep: Reputation: Disabled
Quote:
Originally Posted by upnort View Post
I also learned typing on manual typewriters. I have a similar habit of hovering my thumbs over the space bar.

I remember when "self-correcting" IBM Selectrics were introduced in the school typing class during my peach fuzz days. So cool with auto-erase ribbons. And they just sounded cool.

An uncle had a 1940's something Remington. Almost needed a sledge hammer to press the keys. No, not really.

Regarding trackpads, I don't know if this helps.
I helped me. Thanks!!
 
Old 09-20-2019, 05:46 PM   #15
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,841

Rep: Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657Reputation: 657
Quote:
Originally Posted by jostber View Post
Then running
Code:
egrep -i "input.*driver" /var/log/Xorg.0.log
showed that all devices used the libinput driver, except the two Synaptics touchpads which were using the synaptics driver. It seemed like they were fighting for some attention so I entered these two files in /etc/X11/xorg.conf.d:
If libinput and synaptics are both installed concurrently, the numeric order of the configuration files will determine which takes precedence (since it is processed last by Xorg). In the example posted, 50-synaptcs.conf will take effect, (although if the configuration file is set to ignore the device it won't obviously). This can be confirmed with something like...
Code:
grep -i Using "input" /var/log/Xrog.0.log
https://wiki.archlinux.org/index.php...iguration_file

Best to remove the Xorg synaptics driver package if not absolutely requiring it...it's been deprecated for a few years now anyway.

Last edited by ferrari; 09-20-2019 at 05:47 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
libinput can't compile on Crux 3.3. Error on linking libinput.so.10.13.0. mariojuniorjp Linux - Software 1 03-31-2018 06:43 AM
Toshiba Wireless Keyboard with built in "trackpad" - Trackpad not working. plowers Linux - Newbie 1 11-02-2010 11:12 PM
Overly touchy webserver security jayjwa LQ Suggestions & Feedback 6 03-25-2007 02:32 AM
LXer: Cuba and Open Source: A Touchy Subject LXer Syndicated Linux News 0 02-21-2007 01:46 PM
LXer: CyberCynic: The Touchy Subject of Open-Sourcing Java LXer Syndicated Linux News 0 04-02-2006 08:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration