LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 09-26-2017, 01:52 PM   #16
PragmaticCypher
LQ Newbie
 
Registered: Feb 2016
Posts: 7

Rep: Reputation: Disabled

Hey guys,

I've have a xe303c12 chromebook setup using the kernel and modules from archlinux as described here, but I cannot seem to get pulseaudio working. The sound card is detected, but pulseaudio is only listing a null sink. Any ideas what might be wrong?

pacmd list-sinks
1 sink(s) available.
* index: 0
name: <auto_null>
driver: <module-null-sink.c>
flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
state: IDLE
suspend cause:
priority: 1000
volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
balance 0.00
base volume: 65536 / 100% / 0.00 dB
volume steps: 65537
muted: no
current latency: 183.39 ms
max request: 344 KiB
max rewind: 344 KiB
monitor source: 0
sample spec: s16le 2ch 44100Hz
channel map: front-left,front-right
Stereo
used by: 0
linked by: 0
configured latency: 2000.00 ms; range is 0.50 .. 2000.00 ms
module: 16
properties:
device.description = "Dummy Output"
device.class = "abstract"
device.icon_name = "audio-card"
 
Old 09-26-2017, 10:07 PM   #17
slackartist
Member
 
Registered: Oct 2015
Location: Where the buffalo's roam
Distribution: Slackware Current Multilib
Posts: 126
Blog Entries: 13

Rep: Reputation: 21
did you test your speakers
how does your aplay -l look like

then do aplay -D plughw:0,0 {or 0,1} /usr/share/sound/alsa/Front_Left.wav



yea with that kernel should work...
check your .asoundrc file or asound.conf

I'm not sure how you are looking at pulse though since i thought that was more of just like a wrapper esp for bluetooth
 
Old 09-27-2017, 01:24 PM   #18
PragmaticCypher
LQ Newbie
 
Registered: Feb 2016
Posts: 7

Rep: Reputation: Disabled
Alsa's working , I even copied the asound.conf from archlinux.

root@slackware:~# uname -a
Linux slackware 3.8.11-4-ARCH #1 SMP Sat Oct 22 11:59:55 MDT 2016 armv7l SAMSUNG EXYNOS5 (Flattened Device Tree) GNU/Linux
root@slackware:~# aplay /usr/share/sounds/alsa/*.wav
shared memfd open() failed: Function not implemented
Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Front_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Front_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Rear_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Rear_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Rear_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Side_Left.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Playing WAVE '/usr/share/sounds/alsa/Side_Right.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono

I think it may be related to the error message produced. I was getting the same issue under a chroot on archlinux, but I tried with an archlinux install and it worked fine. Its all a bit odd.
 
Old 09-27-2017, 03:51 PM   #19
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware x86 & ARM
Posts: 108

Rep: Reputation: 26
@PragmaticCypher

what's your output of?
aplay -l
aplay -L

- backup your current /etc/asound.conf and substitute with the following content:
Code:
# ALSA system-wide config file
# By default, redirect to PulseAudio:
##pcm.default pulse
##ctl.default pulse

pcm.mmap0 {
    type mmap_emul;
    slave {
      pcm "hw:0,0";
    }
}

pcm.!default {
  type plug;
  slave {
    pcm mmap0;
  }
}
- a reboot might be useful, although not really necessary if you kill and start pulseaudio (pulseaudio -k & pulseaudio -D)

- check the whole list of pulseaudio devices & sinks and look for a card entry:
pulseaudio -D
pacmd list

1 card(s) available.
index: 0
name: <alsa_card.0>
driver: <module-alsa-card.c>

...etc

- you should check /var/log/syslog for pulseaudio potential issues (that's where pulseaudio logs by default)
- and try what's documented on:
https://wiki.archlinux.org/index.php...oting#No_cards
 
Old 09-30-2017, 06:46 AM   #20
PragmaticCypher
LQ Newbie
 
Registered: Feb 2016
Posts: 7

Rep: Reputation: Disabled
@abga thanks for the help

I've managed to get things working. Pulseaudio was not loading alsa's sink module (not sure why). I've fixed this by forcing the load of it on startup

/etc/pulse/default.pa:
load-module module-alsa-sink

The device takes some time to work, so I also had to stop 'suspend on idle'. Otherwise there's a significant delay when trying to play anything.

/etc/pulse/system.pa:
#load-module module-suspend-on-idle

I'm still very curious why I am getting the error messages "shared memfd open() failed: Function not implemented". I would be grateful if anyone could explain.
 
Old 09-30-2017, 04:20 PM   #21
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware x86 & ARM
Posts: 108

Rep: Reputation: 26
@PragmaticCypher

Always happy to help! Glad you made it work.

Quote:
/etc/pulse/default.pa:
load-module module-alsa-sink
- that's weird, try to amend both:
default.pa
system.pa

Code:
### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0 ignore_dB=1
Quote:
I'm still very curious why I am getting the error messages "shared memfd open() failed:
- there are many discussions around this on the net and it looks like it is safe to ignore ...

Worth to mention that there were some issues between pulseaudio 10 - 11.1, you might want to check the changelogs at:
https://www.freedesktop.org/wiki/Software/PulseAudio/
 
Old 10-01-2017, 03:16 AM   #22
slackartist
Member
 
Registered: Oct 2015
Location: Where the buffalo's roam
Distribution: Slackware Current Multilib
Posts: 126
Blog Entries: 13

Rep: Reputation: 21
yeah im workig with a older kernel than yours.

you could just bypass pulse altogether if you comment everything in asound.conf

and use this .asoundrc

Code:
pcm.!default {
                                type plug
                                slave.pcm "dmixer"
                              }

                              pcm.dsp0 {
                                type plug
                                slave.pcm "dmixer"
                              }

                              pcm.dmixer {
                                type dmix
                                ipc_key 1024
                                slave {
                                  pcm hw:0
                                  #card 2 #front:VSL
                                  format S32_LE
                                  rate 48000
                                }
                              }
i hear the brackets arent the bests but it works for mine...

ps aux | grep pulse
Code:
someone 933 0.0 0.0 3112 964 tty1 S+ 02:16 0:00 grep pulse
then reboot

Last edited by slackartist; 10-01-2017 at 03:20 AM.
 
Old 10-03-2017, 11:25 AM   #23
PragmaticCypher
LQ Newbie
 
Registered: Feb 2016
Posts: 7

Rep: Reputation: Disabled
@abga

Modifying the config files as you suggested did not seems to work . I'm using slackwarearm-14.2 so I'm with pulseaudio version 9. For the moment I'm staying away from -current to avoid the constant updates. I was running it before though and I had the same problems.

I think I'll just stick with the current configuration I have as it seems to be working.

@slackartist

Thanks for the recommendation but I need pulseaudio. I'm using the chromebook as a remote bluetooth speaker, and I need it for this .

Just to reiterate, if anyone else is having similar issues, this was my 'fix':

/etc/pulse/default.pa:
load-module module-alsa-sink

/etc/pulse/system.pa:
#load-module module-suspend-on-idle
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Slackware on Acer C720-3605 Chromebook (Core i3) siralucardt Slackware 9 09-09-2015 06:44 PM
[SOLVED] What distros can be installed on a Chromebook ARM lmassey43 Linux - Newbie 1 04-15-2014 09:10 PM
LXer: Call for help: Slackware on an ARM Chromebook? LXer Syndicated Linux News 0 03-20-2013 03:13 PM
[SOLVED] Having trouble installing Flash player onto ChrUbuntu on the ARM based Chromebook MrBlargable Linux - Newbie 7 02-23-2013 08:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration