LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 02-17-2018, 05:21 PM   #31
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled

I do below instructions on Ubuntu 14.04 64bit with Ns2.35 on a virtual machine.

Code:
$ sudo apt install gdebi  ---> ok
$ sudo gdebi nist-pmip6-ns_229-ubuntu12_i386.deb  ---> ok
$ ns229-nist-pmip6-el6 pmip.tcl   ---> I have below error!
error is:
Code:
bash: /usr/local/bin/ns229-nist-pmip6-el6: No such file or directory
Could you please tell me where files of nist-pmip6-ns_229-ubuntu12_i386.deb are? Or what am i doing wrong?

Thank you so much in advance for your attention.

Last edited by nazanin rezaie; 02-17-2018 at 05:24 PM.
 
Old 02-18-2018, 07:25 AM   #32
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 17,040

Rep: Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456
Re #31.

Ubuntu 14.04 - amd64 refuses to recognize 32bits executable as files that can be run.
→ → reason :
The old package "nist-pmip6-ns_229-ubuntu12_i386.deb" has an incomplete dependency list.
... and the required 32bits dependencies are not being installed.

A quick fix is to install a small newer package to get the 32bits dependencies installed.
... Then Ubuntu 14 - amd64 will recognize `ns229-nist-pmip6-el6´

$ sudo gdebi uwsn-ns2_2.30-ubuntu14_i386.deb
https://drive.google.com/file/d/1p2n...ew?usp=sharing
-
 
1 members found this post helpful.
Old 02-18-2018, 08:26 AM   #33
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 17,040

Rep: Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456
Updated package, nist-pmip6-ns_229-1-ubuntu12_i386.deb

https://drive.google.com/file/d/1-6A...ew?usp=sharing
 
1 members found this post helpful.
Old 02-18-2018, 11:29 AM   #34
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 17,040

Rep: Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456
New packages with 6LoWPAN : NIST-mob + PMIPv6 + 6LoWPAN

nist-pmip6-6lowpan-ns_2.29-ubuntu12_i386.deb
https://drive.google.com/file/d/1UuX...ew?usp=sharing

nist-pmip6-6LoWPAN-2.29-1.el6.i686.rpm
https://drive.google.com/file/d/1tin...ew?usp=sharing

-
 
1 members found this post helpful.
Old 02-18-2018, 11:43 AM   #35
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled
Re #32, #33 and #34.

Thanks alot knudfl.

If i use packages file.deb, Could you please tell me can i change or add somethings to protocol file.patch or protocol file.tcl? for example when i use nist-pmip6-6lowpan-ns_2.29-ubuntu12_i386.deb, can i change or add somethings to PMIPv6 file.patch or PMIPv6 file.tcl?

Thank you so much in advance for your attention.
 
Old 02-18-2018, 12:21 PM   #36
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled
I do below instructions:
Code:
$ sudo apt install gdebi  ---> OK
$ sudo gdebi uwsn-ns2_2.30-ubuntu14_i386.deb ---> OK
$ sudo gdebi nist-pmip6-ns_229-1-ubuntu12_i386.deb   ---> OK
$ sudo gdebi nist-pmip6-6lowpan-ns_2.29-ubuntu12_i386.deb  ---> OK
$ ns pmip.tcl  ---> have below error!
error is:
Code:
invalid command name "Agent/PMIPv6"

    while executing

"Agent/PMIPv6 set debug_ $opt(debug)"

    (file "pmip.tcl" line 34)
Could you please tell me what am i doing wrong?
Thank you so much in advance for your attention.
 
Old 02-18-2018, 01:41 PM   #37
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 17,040

Rep: Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456
Re #36 : You are using an executable 'ns' with no Agent/PMIPv6 !

`nist-pmip6-ns_229-1-ubuntu12_i386.deb´ provides /usr/local/bin/ns229-nist-pmip6-el6

`nist-pmip6-6lowpan-ns_2.29-ubuntu12_i386.deb´ provides /usr/local/bin/ns229-pmip6-nist-6LoWPAN-el6

... Which means you can try out both commands :
Code:
$ ns229-nist-pmip6-el6 pmip.tcl
$ ns229-pmip6-nist-6LoWPAN-el6 pmip.tcl
-

Last edited by knudfl; 02-18-2018 at 01:48 PM.
 
1 members found this post helpful.
Old 02-18-2018, 03:06 PM   #38
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled
Re #37.
Thank you very much knudfl.

When i use below instruction:
Code:
ns229-nist-pmip6-el6 pmip.tcl
I have error:
Code:
bash: /usr/local/bin/ns229-nist-pmip6-el6: Permission denied
BUT when i use :
Code:
$ ns229-pmip6-nist-6LoWPAN-el6 pmip.tcl
I can do it, Ofcourse just with your help.
Thanks ALOT knudfl.

Last edited by nazanin rezaie; 02-18-2018 at 03:21 PM.
 
Old 02-18-2018, 03:13 PM   #39
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled
Please could you see #35 !

I'd like to apologize to repeat the below question.

If i use packages file.deb, Could you please tell me can i change or add somethings to protocol file.patch or protocol file.tcl? for example when i use nist-pmip6-6lowpan-ns_2.29-ubuntu12_i386.deb, can i change or add somethings to PMIPv6 file.patch or PMIPv6 file.tcl?

Thank you so much in advance for your attention.

Last edited by nazanin rezaie; 02-18-2018 at 03:26 PM.
 
Old 02-18-2018, 04:33 PM   #40
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2017 CentOS6.9 CentOS7.4 + 50+ other Linux OS, for test only.
Posts: 17,040

Rep: Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456Reputation: 3456
Re #38.

Something happened. `ns229-nist-pmip6-el6´ lost the executable bit.
Solution
Code:
$ sudo chmod +x /usr/local/bin/ns229-nist-pmip6-el6
( I will update the package.)


Re #39.
Protocols cannot be changed when using just an executable.
A change will require CentOS 6.9 for building the edited "ns-2.29".

The examples.tcl can be edited, and you can create new simulation files.tcl .

-
 
1 members found this post helpful.
Old 02-18-2018, 10:45 PM   #41
nazanin rezaie
Member
 
Registered: Jan 2018
Posts: 37

Original Poster
Rep: Reputation: Disabled
Re #40.
Thanks alot knudfl.
 
  


Reply

Tags
mipv6, mobiwan, nist-mob, ns2


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MIPv6 sibs Linux - Newbie 17 02-10-2014 11:41 AM
MIPv6 addressing in ns2 zmezm14 Linux - Software 0 09-13-2012 07:17 AM
Script of hierarchical MIPv6 ghassan_akrem Linux - Newbie 3 01-30-2011 12:16 AM
how to calculate handoff latency in mipv6 environment manjunath11 Linux - Newbie 0 11-30-2010 03:41 AM
Req help with Freeswan, MIPv6, USAGI kernel sujayy1983 Linux - Security 1 07-09-2006 05:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration