LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Containers
User Name
Password
Linux - Containers This forum is for the discussion of all topics relating to Linux containers. Docker, LXC, LXD, runC, containerd, CoreOS, Kubernetes, Mesos, rkt, and all other Linux container platforms are welcome.

Notices


Reply
  Search this Thread
Old 11-15-2019, 05:31 AM   #1
jnagaraj
LQ Newbie
 
Registered: Jun 2019
Posts: 6

Rep: Reputation: Disabled
Unable to update packages on Ubuntu 17.10


Hi Team,

I have facing some issue on one of the Ubuntu 17.10.

apt-get update
Ign:1 http://us.archive.ubuntu.com/ubuntu artful InRelease
Ign:2 http://security.ubuntu.com/ubuntu artful-security InRelease
Ign:3 http://us.archive.ubuntu.com/ubuntu artful-updates InRelease
Err:4 http://security.ubuntu.com/ubuntu artful-security Release
404 Not Found [IP: 91.189.91.14 80]
Ign:5 http://us.archive.ubuntu.com/ubuntu artful-backports InRelease
Err:6 http://us.archive.ubuntu.com/ubuntu artful Release
404 Not Found [IP: 91.189.91.14 80]
Err:7 http://us.archive.ubuntu.com/ubuntu artful-updates Release
404 Not Found [IP: 91.189.91.14 80]
Err:8 http://us.archive.ubuntu.com/ubuntu artful-backports Release
404 Not Found [IP: 91.189.91.14 80]
Reading package lists... Done
E: The repository 'http://security.ubuntu.com/ubuntu artful-security Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu artful Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu artful-updates Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://us.archive.ubuntu.com/ubuntu artful-backports Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.


While am trying to remove particular package, wherein I do find the error message

apt-get remove nagios-nrpe-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
libsnmp-dev : Depends: libwrap0-dev but it is not going to be installed
Depends: libsensors4-dev but it is not going to be installed
Depends: libpci-dev but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Already I have the latest version snmpd been installed.

Can you please anybody help me on this issue as am not expert on Ubuntu server.



Thanks
Nagaraj
 
Old 11-15-2019, 09:42 AM   #2
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,036

Rep: Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586Reputation: 586
Quote:
Originally Posted by jnagaraj View Post
I have facing some issue on one of the Ubuntu 17.10.
Ubuntu 17.10 is out-of-support since July 19 2018, so there are no updates anymore.
Update your system to at least 18.04 (.3 is the latest point update), which will be supported until april 2023 or if you really want the newest, to 19.10 (but that is again a short-term release, which will expire in july 2020).
See this page wiki.ubuntu.com/Releases for the release and end-of-support dates for ubuntu releases/
 
  


Reply

Tags
ubuntu 17.10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
update -u Did Not Update Kernel Packages cmnorton Red Hat 1 03-15-2008 10:09 AM
Unable to upgrade to ubuntu 7.10, update manager fails to update.... jonbvgood Linux - Software 2 02-05-2008 04:58 PM
No sound after update packages....(including update alsa) Mathsniper Debian 8 11-22-2006 05:43 AM
Saving Update Packages for multisystem update... Dimitriy Fedora 2 12-18-2005 09:07 AM
Mandrake Update/Install Packages/Remove Packages wslyhbb Mandriva 2 03-15-2004 10:43 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Containers

All times are GMT -5. The time now is 04:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration