LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 07-13-2018, 12:46 PM   #1
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 999

Rep: Reputation: 49
make pulseaudio ignore hdmi


this is what i have, slackware current, runs great, but i have analog speakers plugged in to the analog audio out on the back of the PC tower, i also have a hdmi video card and i dont use the audio in it if it even has audio, what i want to do is make pulseaudio ignore the hdmi but so far have not found a solution other than opening pulseadio mixer and switching it every time i want to play a movie or music,

i even tried blacklisting the kernel module and it wont blacklist,
Code:
blacklist snd_hda_codec_hdmi
blacklist snd-hda-codec-hdmi
what i find odd is lsmod shows the kernel module with underscores snd_hda_codec_hdmi , but if you look at the kernel module filename in /lib/modules/[kernel version]/kernel/sound/pci/hda/ the file name of the module uses dashes (snd-hda-codec-hdmi

would a quick and dirty way of fixing be to delete this offending module or do i have to rebuild the kernel and omit the module before running make???

i would delete the module but i wonder if it will cause the system to hang or crash because it was looking for a module that is no longer on the system because some dummy deleted it :O
 
Old 07-13-2018, 01:47 PM   #2
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,534

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
I've also had this problem, what I do is set the soundcard order in alsa, pulseaudio should respect the order. For instance I have 3 sound devices, my Xonar DX, my webcam microphone, and my video cards hdmi. I make a file in /etc/modprobe.d called "alsa-base.conf" then I set the soundcard order like so..

Code:
options snd slots=snd_virtuoso,snd_usb_audio,snd_hda_intel
options snd_virtuoso index=0
options snd_usb_audio index=1
Your modules will be different, but you get the idea, put the soundcard you want to be the default device first. There are other ways to do this, but this is what I do and it works.

You can see the same info here basically at "set default sound device", its from arch but it works here
https://wiki.archlinux.org/index.php...d_Architecture

Last edited by Daedra; 07-13-2018 at 02:00 PM.
 
Old 07-13-2018, 02:47 PM   #3
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 999

Original Poster
Rep: Reputation: 49
i did something a little different and got the same results, in /etc/pulse/system.pa i added

Code:
set-default-source alsa_output.pci-0000_0b_00.3.analog-stereo
set-default-sink alsa_output.pci-0000_0b_00.3.analog-stereo
and it defaults to the analog stereo duplex like i want, so far so good, if it gives me problems in the future i may just rebuild the kernel without the hdmi module, i checked the pulseaudio source and there is nothing for disabling it in the ./configure same with alsalib, so i think the only way of hard coding it out of the system is a kernel rebuild

i found this info helpful
https://wiki.archlinux.org/index.php...Audio/Examples
 
Old 07-13-2018, 09:14 PM   #4
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 999

Original Poster
Rep: Reputation: 49
sheesh, i am beginning to hate pulseaudio, linux audio was much nicer before pulseadio appeared, there is the pure-alsa thing in the extras, i will try that,
 
Old 07-13-2018, 09:35 PM   #5
RadicalDreamer
Member
 
Registered: Jul 2016
Location: USA
Distribution: Slackware64-Current
Posts: 855

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You should be able to adjust audio sources with pavucontrol for pulse audio.
 
Old 07-13-2018, 11:16 PM   #6
gus3
Member
 
Registered: Jun 2014
Distribution: Slackware (x86 and ARM)
Posts: 134

Rep: Reputation: Disabled
HOWTO remove a code library/kernel driver from a runtime environment, reversibly:

Once you locate a possibly offending file, you don't need to delete it. Use this simple thing instead:
Code:
mv library.so library-OFF.so
or
Code:
mv driver.ko driver-OFF.ko
So that the search for library.so or driver.ko will fail to load. The file itself will still be present, ready to return to its original place, if things go south for you.

You have no idea how many hundred times I've used this idea. Keep the file, but put it under a temporary witness protection program for trial purposes.
 
1 members found this post helpful.
Old 07-13-2018, 11:36 PM   #7
Darth Vader
Senior Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 2,727

Rep: Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226
Quote:
Originally Posted by Okie View Post
this is what i have, slackware current, runs great, but i have analog speakers plugged in to the analog audio out on the back of the PC tower, i also have a hdmi video card and i dont use the audio in it if it even has audio, what i want to do is make pulseaudio ignore the hdmi but so far have not found a solution other than opening pulseadio mixer and switching it every time i want to play a movie or music,

i even tried blacklisting the kernel module and it wont blacklist,
Code:
blacklist snd_hda_codec_hdmi
blacklist snd-hda-codec-hdmi
what i find odd is lsmod shows the kernel module with underscores snd_hda_codec_hdmi , but if you look at the kernel module filename in /lib/modules/[kernel version]/kernel/sound/pci/hda/ the file name of the module uses dashes (snd-hda-codec-hdmi

would a quick and dirty way of fixing be to delete this offending module or do i have to rebuild the kernel and omit the module before running make???

i would delete the module but i wonder if it will cause the system to hang or crash because it was looking for a module that is no longer on the system because some dummy deleted it :O
To put down the support for audio over HDMI, you should disable the audio support in your video driver; for example for AMD Radeon you should add in the kernel command line:
Code:
radeon.audio=0
That's all.

Last edited by Darth Vader; 07-13-2018 at 11:46 PM.
 
1 members found this post helpful.
Old 07-14-2018, 12:37 AM   #8
cwizardone
Senior Member
 
Registered: Feb 2007
Distribution: Slackware64-current with "True Multilib" & Xfce.
Posts: 4,165
Blog Entries: 1

Rep: Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494Reputation: 1494
Well.... in Xfce I just click on the pulseaudio speaker icon on the panel, pick analog or HDMI and the choice is remembered. Haven't tried it in kde-4.
 
Old 07-14-2018, 01:42 AM   #9
Darth Vader
Senior Member
 
Registered: May 2008
Location: Romania
Distribution: DARKSTAR Linux 2008.1
Posts: 2,727

Rep: Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226Reputation: 1226
Quote:
Originally Posted by cwizardone View Post
Well.... in Xfce I just click on the pulseaudio speaker icon on the panel, pick analog or HDMI and the choice is remembered. Haven't tried it in kde-4.
In this thread I seen people messing around with kernel modules, that's why I given a suggestion along.

But, yeah. Same is also in KDE4, just like you say.
 
1 members found this post helpful.
Old 07-14-2018, 02:18 PM   #10
Okie
Member
 
Registered: Mar 2002
Location: Oklahoma
Posts: 999

Original Poster
Rep: Reputation: 49
i did it, i jumped head first in to a pure-alsa-system from extra, and i will say i like it better, i did have to rebuild qt-5.7.1 with -pulse-no and -alsa, i installed portaudio which made building gqrx without pulseaudio possible, the only thing that dont get sound is my web browser which is acceptable as long as the rest works good and i am glad for that and thanks to all who bothered to help, and thanks to the slackware developers that put together the pure-alsa-system
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pulseaudio, nVidia HDMI/DisplayPort, nothing... dimm0k Slackware 7 11-05-2016 03:31 PM
[ProLiant MicroServer, ATI R6xx HDMI, Digital Out, HDMI] No HDMI sound at all vnatius Linux - Hardware 15 08-16-2012 01:09 PM
HDMI Pulseaudio and ac3 passthrough kristhor Linux - Hardware 7 05-22-2012 05:55 AM
Should I ignore this pulseaudio log lhorace Linux - Newbie 1 10-28-2009 04:38 AM
Make ls ignore symlinks Creep Linux - Software 3 01-23-2004 05:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration