LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-18-2019, 05:23 AM   #1
ueghio
LQ Newbie
 
Registered: Dec 2010
Posts: 11

Rep: Reputation: 0
VSFTPD login incorrect


Hello guys I Need your help. I have a pogo e02 running alarm and I can't manage to login anymore using vsftp. Software version is 3.0.3-4.
I was able to login before using these configuration file
Code:
Example config file /etc/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
#local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
#xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
idle_session_timeout=0
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd.banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
# (Warning! chroot'ing can be very dangerous. If using chroot, make sure that
# the user does not have write access to the top level directory within the
# chroot)
chroot_local_user=YES
#chroot_list_enable=NO
# (default follows)
#chroot_list_file=/etc/vsftpd.chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd with two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES
#ssl_enable=YES
#force_local_logins_ssl=YES
#ssl_tlsv1=YES
allow_writeable_chroot=YES
Error code is "530 login incorrect"
Log file isn't vert helpful unfortunately .. do you have any suggestion?
Thank you in Advance.

Last edited by ueghio; 02-18-2019 at 05:24 AM.
 
Old 02-18-2019, 11:39 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,409

Rep: Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727
Quote:
Error code is "530 login incorrect"
Log file isn't vert helpful unfortunately .. do you have any suggestion?
Are you sure you're using the correct username and/or password?
 
Old 02-18-2019, 12:28 PM   #3
ueghio
LQ Newbie
 
Registered: Dec 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Are you sure you're using the correct username and/or password?
I created two local users and i can login whithout problems with each one. Maybe arch changed some ftp configuration file in the last update? Where can i figure it out?
 
Old 02-18-2019, 12:54 PM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,409

Rep: Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727
Quote:
Originally Posted by ueghio View Post
I created two local users and i can login whithout problems with each one. Maybe arch changed some ftp configuration file in the last update? Where can i figure it out?
Looks like you hit this bug, introduced by the latest update.
 
1 members found this post helpful.
Old 02-18-2019, 03:08 PM   #5
ueghio
LQ Newbie
 
Registered: Dec 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Looks like you hit this bug, introduced by the latest update.
Thank you very much Bathory. I Hope It Will Be fixed soon.
 
Old 02-19-2019, 12:41 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,409

Rep: Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727
Quote:
Originally Posted by ueghio View Post
Thank you very much Bathory. I Hope It Will Be fixed soon.
According to the patch in the link I've posted above, you need to add:
Code:
pam_service_name=vsftpd
 
Old 02-19-2019, 09:40 AM   #7
ueghio
LQ Newbie
 
Registered: Dec 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Question

Quote:
Originally Posted by bathory View Post
According to the patch in the link I've posted above, you need to add:
Code:
pam_service_name=vsftpd
Adding this string to /etc/vsftpd.conf didn't any difference. Maybe I modified the wrong file?

Last edited by ueghio; 02-19-2019 at 10:13 AM.
 
Old 02-19-2019, 03:28 PM   #8
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,409

Rep: Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727
Quote:
Originally Posted by ueghio View Post
Adding this string to /etc/vsftpd.conf didn't any difference. Maybe I modified the wrong file?
Does /etc/pam.d/vsftpd exist?
I guess you've restarted the vsftpd service after changing /etc/vsftpd.conf
 
Old 02-20-2019, 02:34 AM   #9
ueghio
LQ Newbie
 
Registered: Dec 2010
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
Does /etc/pam.d/vsftpd exist?
I guess you've restarted the vsftpd service after changing /etc/vsftpd.conf
I restarted the service correctly, but /etc/pam.d/vsftpd does not exist.
 
Old 02-20-2019, 04:30 AM   #10
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,409

Rep: Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727Reputation: 1727
Quote:
Originally Posted by ueghio View Post
I restarted the service correctly, but /etc/pam.d/vsftpd does not exist.
Since I'm not using arch but a distro that is pam-less (Slackware), the only reference I've found for this file, is this:
Code:
auth required pam_pwdfile.so pwdfile /etc/vsftpd/.passwd
account required pam_permit.so
I guess you could use the pair "username/password" from /etc/shadow in order to create the /etc/vsftpd/.passwd file.

Also I'm posting here the /etc/pam.d/vsftpd file that comes with Centos for reference. You may try it also and see what happens.
Code:
#%PAM-1.0
session    optional     pam_keyinit.so    force revoke
auth       required	pam_listfile.so item=user sense=deny file=/etc/vsftpd/ftpusers onerr=succeed
auth       required	pam_shells.so
auth       include	password-auth
account    include	password-auth
session    required     pam_loginuid.so
session    include	password-auth

Anyway, if it still doesn't work better ask archwiki for support, or add a vote to the bug report in my previous post.


Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd 530 login incorrect pocon Slackware 11 07-31-2015 03:56 PM
vsftpd & virtual users - 530 Login incorrect mjtice Linux - Software 3 12-08-2008 03:15 PM
Vsftpd login incorrect nitro_punk85 Linux - Server 2 08-05-2007 07:18 AM
vsftpd and "incorrect login" herc Linux - Networking 11 02-03-2004 01:41 PM
vsftpd 1.1.2 on redhat 7.1 -- 530 incorrect login issue triggerfish Linux - Software 4 08-17-2003 07:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration