LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 06-29-2020, 05:13 AM   #1
saturn1955
Member
 
Registered: Nov 2019
Location: Berlin
Distribution: AntiX 19
Posts: 59

Rep: Reputation: Disabled
changing the keyboard layout


hello,

I am using an english ( US ) keyboard. The position for @ on the keybord is shift 2, but I ve to do it with Alt Q and I want to correct this. The # should be on shift 3 but is positioned on the key beyound the tab key. I d like to correct this in the xmodmap, but I dont know to do it. can anybobody help me with this?
 
Old 06-29-2020, 05:41 AM   #2
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 3,638

Rep: Reputation: Disabled
Sounds like you have the wrong keyboard layout selected, look for a system control centre, or such, on your menu, it all depends on your desktop environment as to where you will find it, but it should be on your menu somewhere.
 
Old 06-29-2020, 05:49 AM   #3
saturn1955
Member
 
Registered: Nov 2019
Location: Berlin
Distribution: AntiX 19
Posts: 59

Original Poster
Rep: Reputation: Disabled
when installing lubuntu, I marked english ( US ) keybord and german language.
 
Old 06-29-2020, 06:08 AM   #4
shruggy
Member
 
Registered: Mar 2020
Posts: 950

Rep: Reputation: Disabled
First, see this question and this page in Ubuntu Community Help Wiki.

Next, please show the output of
Code:
xmodmap -pke|egrep -w 24\|108

Last edited by shruggy; 06-29-2020 at 06:35 AM.
 
Old 06-29-2020, 02:54 PM   #5
saturn1955
Member
 
Registered: Nov 2019
Location: Berlin
Distribution: AntiX 19
Posts: 59

Original Poster
Rep: Reputation: Disabled
Code:
madmax@travelmate4021:~$ xmodmap -pke|egrep -w 24\|108
keycode  24 = q Q q Q at Greek_OMEGA at Greek_OMEGA
keycode 108 = ISO_Level3_Shift Multi_key ISO_Level3_Shift Multi_key
madmax@travelmate4021:~$
 
Old 07-03-2020, 05:05 AM   #6
saturn1955
Member
 
Registered: Nov 2019
Location: Berlin
Distribution: AntiX 19
Posts: 59

Original Poster
Rep: Reputation: Disabled
I found out in etc\default\keyboard,that the keyboarad layout installation is british and not american although the keyboard is american.

with

Quote:
sudo dpkg-reconfigure keyboard-configuration
I changed that and now the prob has been solved.

Last edited by saturn1955; 07-04-2020 at 03:51 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Selecting the correct keyboard layout corresponding to my laptop's physical layout nidra Linux - Newbie 2 08-28-2017 08:14 AM
Switching keyboard layout - Mandriva2006 - K.D.E. Windows Layout! itz2000 Mandriva 3 08-13-2006 06:43 PM
crash when changing language(keyboard layout) atkbd.c cuk Mandriva 0 06-20-2004 04:16 AM
Changing my keyboard layout (language) globally by command (shell) Santorres Linux - Newbie 1 05-17-2004 02:04 PM
Changing keyboard layout? Eits0 Linux - General 2 08-13-2002 06:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 04:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration