LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-30-2020, 07:24 PM   #1
TTWE
LQ Newbie
 
Registered: Dec 2019
Posts: 10

Rep: Reputation: Disabled
apt-get update "GPG error" Ubuntu 18.04.4 LTS


Hi trying to do apt-get update returns the error

Code:
W: GPG error: http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release: The following signatures were invalid: EXPKEYSIG BC711F9BA15703C6 MongoDB 3.4 Release Signing Key <packaging@mongodb.com>
E: The repository 'http://repo.mongodb.org/apt/ubuntu xenial/mongodb-org/3.4 Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
I've worked out its a key verification error I have tried to find the expired key using "apt-key list" that returns

Code:
pub   rsa4096 2016-01-11 [SC] [expired: 2020-01-05]
      0C49 F373 0359 A145 1858  5931 BC71 1F9B A157 03C6
uid           [ expired] MongoDB 3.4 Release Signing Key <packaging@mongodb.com>

/etc/apt/trusted.gpg.d/nordvpn-keyring.asc
I can't see a "key" as described in the examples (https://askubuntu.com/questions/4816...id-in-terminal) so I tried using
Code:
BC711F9BA15703C6
from the earlier output and I get the error

Code:
apt-key adv --keyserver keys.gunnpg.net --recv-keys BC711F9BA15703C6
Executing: /tmp/apt-key-gpghome.u3L44IDyJS/gpg.1.sh --keyserver keys.gunnpg.net --recv-keys BC711F9BA15703C6
gpg: keyserver receive failed: No name
Any help would be appreciated.

TTWE
 
Old 06-30-2020, 08:53 PM   #2
tinfoil3d
Member
 
Registered: Apr 2020
Location: Japan/RJCC
Distribution: debian, lfs, whatever else i need in qemu
Posts: 195

Rep: Reputation: Disabled
The key has expired, there's nothing you can do about it, search or ask mongodb for new keys and maybe new repo link, this seems pretty strange they'd leave it dead for half a year like that though.
Maybe your distro isn't supported anymore?
 
1 members found this post helpful.
Old 06-30-2020, 08:57 PM   #3
TTWE
LQ Newbie
 
Registered: Dec 2019
Posts: 10

Original Poster
Rep: Reputation: Disabled
Well I'm running Ubuntu 18.04.4 LTS so idk. I was thinking about switching to debian anyway.
 
Old 06-30-2020, 09:17 PM   #4
tinfoil3d
Member
 
Registered: Apr 2020
Location: Japan/RJCC
Distribution: debian, lfs, whatever else i need in qemu
Posts: 195

Rep: Reputation: Disabled
ubuntu 18 is not xenial but bionic iirc
 
  


Reply

Tags
apt-get update, registry


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gpg / gpg-agent -- Can't connect to /root/.gnupg/S.gpg-agent jrtayloriv Linux - Security 9 06-03-2019 10:06 AM
Not able to run this command "sudo apt-get install libdevil-dev" even after trying "apt-get -f install" getting below error message srihariu1 Linux - Embedded & Single-board computer 2 04-26-2018 06:33 AM
[SOLVED] Questions on GPG keyrings for debain apt-get? (fixing problem with gpg) frog-o Debian 2 05-12-2013 10:50 AM
GPG: Bad session key gpg between gpg on linux and gpg gui on windows XP konqi Linux - Software 1 07-21-2009 09:37 AM
what to do? gpg error on apt-get update darkleaf Debian 7 04-30-2006 04:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration