LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE
User Name
Password
SUSE / openSUSE This Forum is for the discussion of Suse Linux.

Notices


Reply
  Search this Thread
Old 06-27-2020, 01:23 PM   #1
bifferos
Member
 
Registered: Jul 2009
Posts: 353

Rep: Reputation: 126Reputation: 126
OpenSUSE + Xen (nested)


Hi All,

I'm just wondering what are my chances of getting this combo to work nested, under VMWare. I've installed OpenSuSE Leap 15.1, installed yast2-vm, configured Xen and booted a dom0 kernel, but the Xen service won't start (xen-dom0-modules.service).

The log complains about modules not being found, e.g. evtchn, gntdev, netbk, xen-scsibk, usbbk, pciback, blktap2
It's looking in /lib/modules/4.12.14-lp151.28.52-default

I've seen instructions for older versions of OpenSUSE where this is just supposed to work due to the excellent Xen support, however it's not working for me.

Any ideas?

thanks!
 
Old 06-29-2020, 04:50 AM   #2
bifferos
Member
 
Registered: Jul 2009
Posts: 353

Original Poster
Rep: Reputation: 126Reputation: 126
In the end I just installed XCP-ng and used that to run Xen nested. Much easier than getting Xen setup in OpenSUSE.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Learning Xen: Converting Existing Non-Xen Hypervisor Images for Use in Xen LXer Syndicated Linux News 0 08-24-2013 10:00 AM
LXer: Downgrade udev 157->151 on opensuse 11.3 to bring back to life Xen 4.0 (2.6.34-12-xen) LXer Syndicated Linux News 0 07-26-2010 08:50 PM
LXer: Managing Xen With Xen-Tools, Xen-Shell, And Argo LXer Syndicated Linux News 0 11-05-2006 12:21 PM
LXer: Managing Xen With Xen-Tools, Xen-Shell, And Argo LXer Syndicated Linux News 0 10-21-2006 11:33 PM
XEN-SUSE 10.1-- DHCP Server works under plain but not under XEN Dimitriy Linux - Networking 4 06-08-2006 05:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > SUSE / openSUSE

All times are GMT -5. The time now is 04:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration