LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2018, 09:33 AM   #1
etcetera
Member
 
Registered: Aug 2004
Posts: 120

Rep: Reputation: 15
Weird input sent to the screen constantly - visible in editors


I am not new to either Emacs or vi but when in either, I constantly get hit with a generated code (without touching the keyboard), I am sitting there and all of a sudden, it does this on its own. This in vim. It splits the screen in half and I have to do :q! to exit that session back into the main buffer. I thought it was something to do with this version of vi (vim) and installed emacs, which does something similar and generates mesg about F1.


*vi-help.txt* For Vim version 7.1. Last change: 2008 Mar 03

VIM - minimal help file
(NOTE: This is a minimal help file and many tags won't work. Use 'vim' or
'gvim' to read the complete help docs.)
k
Move around: Use the cursor keys, or "h" to go left, h l
"j" to go down, "k" to go up, "l" to go right. j
Close this window: Use ":q<Enter>".
Get out of Vim: Use ":qa!<Enter>" (careful, all changes are lost!).

Jump to a subject: Position the cursor on a tag between |bars| and hit CTRL-].
Jump back: Type CTRL-T or CTRL-O (repeat to go further back).

Get specific help: It is possible to go directly to whatever you want help
on, by giving an argument to the ":help" command |:help|.
It is possible to further specify the context:
*vi-help-context*
WHAT PREPEND EXAMPLE
Normal mode command (nothing) :help x
Insert mode command i_ :help i_<Esc>
Command-line command : :help :quit
vi_help.txt [Help][RO]



abc
abc
abc
abc





~
~
~
~
~
~
~
~
~
~
a [+]
E434: Can't find tag pattern



system info:

root@ngrca4-mup:~# uname -a
Linux xxxxxxxxxxx 2.6.32-696.20.1.el6.x86_64 #1 SMP Fri Jan 12 15:07:59 EST 2018 x86_64 x86_64 x86_64 GNU/Linux


I connect to the machine from Windows using Putty, the latest version. It happens to all the linux machines I access to, not just this one. I connect to other various Unix machines where I do not see this behavior. It happens randomly. I thought my keyboard had an issue and was sending out this code and replaced it to no avail. It's not the keyboard. Looked at settings in the terminal, I cannot trace it to anything.

# env


SHELL=/bin/bash
TERM=xterm
HISTSIZE=1000
USER=root
LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00i=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01r=40;31;0 1:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42w=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01 ;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:* .Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31 :*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7 z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01 ;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;3 5:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:* .mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm= 01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35 :*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.a ac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg= 01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:
MAIL=/var/spool/mail/root
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin
PWD=/tmp
LANG=en_US.UTF-8
HISTCONTROL=ignoredups
SHLVL=1
HOME=/root
LOGNAME=root
CVS_RSH=ssh
LESSOPEN=||/usr/bin/lesspipe.sh %s
G_BROKEN_FILENAMES=1
_=/bin/env
OLDPWD=/root

Last edited by etcetera; 06-13-2018 at 09:39 AM.
 
Old 06-13-2018, 10:04 AM   #2
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,380

Rep: Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979Reputation: 979
Are you working in a console terminal? Are they system messages appearing in the editor? If so, see this post: https://superuser.com/questions/1536...-linux-session
 
Old 06-13-2018, 11:20 AM   #3
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,633

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Carefully check your PuTTY settings. Especially compare the settings for the machines where you don't have the problem with the machines that do.
In particular check terminal type and the settings in the Terminal configuration tree, but do a side-by-side compare of all the settings.
 
Old 06-13-2018, 11:38 AM   #4
etcetera
Member
 
Registered: Aug 2004
Posts: 120

Original Poster
Rep: Reputation: 15
I connect via the Putty X-windows emulator that runs on Windows.

Have multiple windows open. I am not at the console of the machine. It's a virtual image.
 
Old 06-13-2018, 01:11 PM   #5
etcetera
Member
 
Registered: Aug 2004
Posts: 120

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AwesomeMachine View Post
Are you working in a console terminal? Are they system messages appearing in the editor? If so, see this post: https://superuser.com/questions/1536...-linux-session
Nope. It has nothing at all to do with the broadcast messages.

I am in vi in the escape mode and again it's doing this:

*vi-help.txt* For Vim version 7.1. Last change: 2008 Mar 03

VIM - minimal help file
(NOTE: This is a minimal help file and many tags won't work. Use 'vim' or
'gvim' to read the complete help docs.)
k
Move around: Use the cursor keys, or "h" to go left, h l
"j" to go down, "k" to go up, "l" to go right. j
Close this window: Use ":q<Enter>".
Get out of Vim: Use ":qa!<Enter>" (careful, all changes are lost!).

Jump to a subject: Position the cursor on a tag between |bars| and hit CTRL-].
Jump back: Type CTRL-T or CTRL-O (repeat to go further back).

Get specific help: It is possible to go directly to whatever you want help
on, by giving an argument to the ":help" command |:help|.
It is possible to further specify the context:
*vi-help-context*
WHAT PREPEND EXAMPLE
Normal mode command (nothing) :help x
Insert mode command i_ :help i_<Esc>
Command-line command : :help :quit
vi_help.txt [Help][RO]


~
~
~
~
[No Name] [+]
E434: Can't find tag pattern
 
Old 06-13-2018, 05:48 PM   #6
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,633

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
Quote:
Originally Posted by etcetera View Post
I connect via the Putty X-windows emulator that runs on Windows.

Have multiple windows open. I am not at the console of the machine. It's a virtual image.
Yes, I understand. I'm suggesting that there may be a glitch in the settings of putty on your Windows PC.
If you have connections defined to computers that work, compare those to the settings defined for computers with the problem.

X-windows? Are you using PuTTY to establish a connection to the X client on the remote machine? I don't do that. I use it to connect via ssh to the command line.
 
Old 06-13-2018, 06:12 PM   #7
rtmistler
Moderator
 
Registered: Mar 2011
Location: MA, USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu, Debian
Posts: 7,074
Blog Entries: 12

Rep: Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604
I agree with the consensus about Putty settings.

My potential solution: (?)
Any way to just default them, default Putty by uninstalling/re-installing? Or create a new Putty saved session for that system?

I've sparingly used Putty. In fact, the side thought I have is that the Non-Linux personnel in my company. A.K.A. Everyone else. They ALWAYS have used Putty to communicate with our embedded Linux systems. Between 95, 98, XP, 8, and 10, nary a problem like this. I know for a fact that they do use vi from time to time even though they hate it. Their main problem is that if they take a file to Windows, edit it, then send it back, there's a format problem. So they've bowed to using vi through an SSH session over Putty. Once again, nary a complaint about this type of problem. And some of these people are the types that click-click-click-click, smash enter, enter, enter, or hit the (close window) X, or use the task manager to kill things because they have little patience for stuff that delays them.
 
Old 06-13-2018, 06:36 PM   #8
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.5
Posts: 1,633

Rep: Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534Reputation: 534
I'm not sure there's a consensus. I seem to be the only one suggesting that, but thanks.

I have not made the never-use-windows decision yet, so use PuTTY on a daily basis to manage both my remote servers and my local Linux desktops most of the time. I can toggle over to the local desktops if I want to try something with the GUI, but when doing things like configuring servers, etc., I just do it from my Windows box via PuTTY. The remote servers are headless.

Putty has default settings. Unfortunately they are preserved through an upgrade (they're actually stored in the Window registry, by default). One would have to delete all the saved connections and re-input them. I presume that would be painful.
Creating a new connection could work, if the defaults haven't been modified and saved.

My "theory" (and I'd remind all that it's a SWAG), is that something is set in PuTTY that's causing text or control characters to be sent to the remote server resulting in the "wierd input." Perhaps something to do with keep-alive? An incorrect terminal type string? Incorrect internet protocol version? (what happens if that's set to IPv6 on an IPv4 connection? I don't know)

One can also turn on logging on the local, Windows machine to see what's actually being sent and received over the PuTTY connection.

PuTTY will allow X-forwarding. I've never tried it but if the OP is using that, I'd suspect it.

Last edited by scasey; 06-13-2018 at 06:44 PM.
 
Old 06-19-2018, 02:12 AM   #9
Stéphane Ascoët
Member
 
Registered: Feb 2004
Location: Orleans, 120 km south of Paris
Distribution: Mandrake, Freeduc (the one I'm making), Slackware, MacOS X
Posts: 214

Rep: Reputation: 45
Post

I'm sure the concerned key is F1

If you can't find the solution a SSH level, and if it's the only key causing problems, you could try to deactivate it in Vim or system-wise

For information this thread gave birth to another one: https://www.linuxquestions.org/quest...8/#post5867260

Last edited by Stéphane Ascoët; 06-19-2018 at 02:18 AM. Reason: Adding link to other subject
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] A weird character that actually doesnt exist but visible when you do a less or vi the SAbhi Programming 4 01-21-2014 07:38 PM
Adobe Reader - Why Characters inside input boxes are only partially visible??? eshwartamil Linux - Software 1 04-21-2013 04:44 PM
Linux image editors, video editors, audio editors, designing programs? vieya Linux - Software 3 12-06-2009 10:02 AM
Weird Problem: Folder not visible vikas027 Linux - Server 4 08-07-2009 05:23 AM
two ISP and a weird LAN setting / services not visible from outside (routing problem) pe2338 Linux - Networking 2 01-31-2005 05:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration