LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Containers
User Name
Password
Linux - Containers This forum is for the discussion of all topics relating to Linux containers. Docker, LXC, LXD, runC, containerd, CoreOS, Kubernetes, Mesos, rkt, and all other Linux container platforms are welcome.

Notices


Reply
  Search this Thread
Old 10-18-2019, 02:13 AM   #1
emon_lq
LQ Newbie
 
Registered: Feb 2016
Posts: 13

Rep: Reputation: Disabled
Question kubectl ConfigMap creation fails (or so it seems)..


Hi everyone

I am trying to setup 'Single Sign On' via Active Directory on my Kubernetes cluster.

So I am trying to deploy Dex+Gangway.

Weird thing is that I can't seem to deploy a ConfigMap for Dex!!?

I am following this link
https://github.com/vmware-tanzu/tgik...39/yaml/05-dex

I have downloaded the files and modified them to work with LDAP.

Now when I do

Code:
kubectl apply -f ~/path/to/03-dex-configmap.yaml
It says

Code:
configmap/dex created
But can't seem to find it?!

Code:
kubectl delete configmap dex
Error from server (NotFound): configmaps "dex" not found
Also

Code:
kubectl get configmaps | grep dex
Returns nothing
I also tried

Code:
kubectl get configmaps
It lists other ConfigMaps that I have previously installed, but there is no 'dex'

But when I do

Code:
kubectl delete -f ~/path/to/03-dex-configmap.yaml
It says

Code:
configmap "dex" deleted
How did it delete something that did not exist!??
What am I doing wrong??

Thanks in advance
Emon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Install kubectl and minikube on Linux LXer Syndicated Linux News 0 06-15-2019 01:20 PM
LXer: The definitive pronunciation guide for kubectl LXer Syndicated Linux News 0 12-24-2018 11:40 AM
[SOLVED] CDROM seems to be there but also seems not to be mounted. Crb999 SUSE / openSUSE 47 02-06-2017 04:33 PM
[SOLVED] Prevent subdirectory creation while allowing file creation bweddell Linux - Security 5 07-31-2011 09:54 PM
System user creation with mysql user creation moos3 Programming 1 08-11-2007 09:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Containers

All times are GMT -5. The time now is 11:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration