LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 01-10-2022, 10:05 AM   #1
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Rep: Reputation: 297Reputation: 297Reputation: 297
OpenBSD: does anyone know how to disable screen blanking ?


gnome-shell 40.4

i have a openbsd 7 installled on my firewall machine, it has some gui programs that keep an eye on my network, thing is that it goes to gdm? and i have to log in again and again ...

i have this script and have tried different combinations but i cant get it to work.
Code:
#!/bin/bash
# xs.sh

xset dpms 0 0 0
xset -dpms
xset s off
xset s noblank
anyone with knowledge about it ?

thanks.


EDIT:
Quote:
gsettings set org.gnome.desktop.session idle-delay 0
Quote:
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'
^those work.

EDIT:

just made a new install of OpenBSD 7.0 and nothing works.
EDIT2:
i just play vlc muted on a loop that forces the screen to stay on. talk about dirty hacks

Last edited by //////; 01-17-2022 at 05:37 AM. Reason: solutions doesn't work.
 
Old 01-10-2022, 03:52 PM   #2
jggimi
Member
 
Registered: Jan 2016
Distribution: None. Just OpenBSD.
Posts: 253

Rep: Reputation: 117Reputation: 117
I believe you need to set Gnome's idle timeout. If so, this is a Gnome provision, it is not an X11 setting, nor is it an OpenBSD setting.

https://www.techrepublic.com/article...-command-line/
 
1 members found this post helpful.
Old 01-10-2022, 04:03 PM   #3
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Original Poster
Rep: Reputation: 297Reputation: 297Reputation: 297
Quote:
Originally Posted by jggimi View Post
I believe you need to set Gnome's idle timeout. If so, this is a Gnome provision, it is not an X11 setting, nor is it an OpenBSD setting.

https://www.techrepublic.com/article...-command-line/
thanks man, just set it to 0.
Code:
gsettings set org.gnome.desktop.session idle-delay 0
i hope it works, and someone finds this post if he/her needs to set it off
 
Old 01-10-2022, 04:54 PM   #4
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Original Poster
Rep: Reputation: 297Reputation: 297Reputation: 297
i set it to "0",as user, it tried to go to gdm, now i did as a root :
Code:
gsettings set org.gnome.desktop.session idle-delay 99999999
i added 16 x 9's but it complained ...
Code:
number out of range for type 'u':
... 8 x 9's works without error.

ill wait for some time to see if it works now.
 
Old 01-10-2022, 05:22 PM   #5
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Original Poster
Rep: Reputation: 297Reputation: 297Reputation: 297
didnt work, even tho at "settings -> power -> blank screen" says 337 hours 42 minutes 31 seconds.

ill try with 0 this time.
 
Old 01-10-2022, 07:19 PM   #6
mredc
Member
 
Registered: May 2016
Location: USA
Distribution: Debian, Ubuntu
Posts: 69

Rep: Reputation: Disabled
This works for me on FeeeBSD.

Code:
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'
 
1 members found this post helpful.
Old 01-11-2022, 03:14 AM   #7
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Original Poster
Rep: Reputation: 297Reputation: 297Reputation: 297
Quote:
Originally Posted by mredc View Post
This works for me on FeeeBSD.

Code:
gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'
hello.

i get it to work with :
Code:
gsettings set org.gnome.desktop.session idle-delay 0
just woke up and it is working.
 
Old 01-13-2022, 12:28 PM   #8
Xeratul
Senior Member
 
Registered: Jun 2006
Location: UNIX
Distribution: FreeBSD
Posts: 2,364

Rep: Reputation: 214Reputation: 214Reputation: 214
what about doing with a X11/Xorg desktop on a firewall machine?

Typically BSD will rather recommend a console usage.

try not to use X11 on your machine, if possible, especially for similar use.

anyhow, here the magic:
Code:
xset s off ;  xset -dpms ;  xset s noblank  ; setterm -blank 0
1.) It is highly time for your usage of OpenBSD to read the FAQ OpenBSD.
2.) Secondly here a cool book:
Absolute OpenBSD, 2nd Edition: UNIX for the Practical Paranoid, Michael W. Lucas
 
1 members found this post helpful.
Old 01-13-2022, 08:34 PM   #9
//////
Member
 
Registered: Nov 2005
Location: Land of Linux :: Finland
Distribution: Arch x86_64 | OpenBSD 7 bridge | Windows 10
Posts: 625

Original Poster
Rep: Reputation: 297Reputation: 297Reputation: 297
Quote:
Originally Posted by Xeratul View Post
what about doing with a X11/Xorg desktop on a firewall machine?

Typically BSD will rather recommend a console usage.

try not to use X11 on your machine, if possible, especially for similar use.

anyhow, here the magic:
Code:
xset s off ;  xset -dpms ;  xset s noblank  ; setterm -blank 0
1.) It is highly time for your usage of OpenBSD to read the FAQ OpenBSD.
2.) Secondly here a cool book:
Absolute OpenBSD, 2nd Edition: UNIX for the Practical Paranoid, Michael W. Lucas
yea, i know it is against OpenBSD core values :P
i just practice bridging and using rrdtool etc.

thanks for the book suggestion, ill have to buy it.
 
Old 01-14-2022, 01:56 AM   #10
Xeratul
Senior Member
 
Registered: Jun 2006
Location: UNIX
Distribution: FreeBSD
Posts: 2,364

Rep: Reputation: 214Reputation: 214Reputation: 214
Quote:
Originally Posted by ////// View Post
yea, i know it is against OpenBSD core values :P
i just practice bridging and using rrdtool etc.

thanks for the book suggestion, ill have to buy it.
Well, come to join the chat... I guess, you might need direct information over IRC, so that the Desktop for bridging is no longer needed.
Bridge is not so easy stuff.

https://kiwiirc.com/nextclient/irc.l...nnels=#openbsd
 
  


Reply

Tags
blanking, dpms, gdm, screen, xset


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to disable screen "blanking" WindowBreaker Slackware 5 11-12-2008 08:47 PM
disable automatic screen blanking in console mode drkstr Slackware 3 10-10-2006 10:25 PM
how to disable screen blanking in fedora core 1? ujjwal_mh Linux - Software 3 07-26-2004 12:58 PM
How to disable screen blanking in X? make Linux - General 14 07-15-2004 06:15 PM
how can I disable the auto screen blanking? r0dr0ddy Linux - Newbie 9 02-03-2004 02:33 PM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 03:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration