LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop
User Name
Password
Linux - Desktop This forum is for the discussion of all Linux Software used in a desktop context.

Notices


Reply
  Search this Thread
Old 07-01-2020, 08:04 PM   #1
KGIII
Member
 
Registered: Sep 2015
Location: North-Western, Maine - in the mountains.
Distribution: Lubuntu 18.04 LTS
Posts: 108
Blog Entries: 4

Rep: Reputation: 46
[Lubuntu] (Theme Issue) Mismatched Icons


You see this?

http://pix.toile-libre.org/upload/or...1593655751.png

Yeah! That's BS! It irks me far more than it should!

As you see, the icon on the left is properly themed. It's the right icon! It's the right icon even in the start/application menu.

Then...

I start the app and it doesn't have the right icon!

If you look, the other apps have the right icon. They're all a nice blue color, just as they should be. Not Google Chrome! No! No, that one wants to be all multi-colored and special!

I've tried yelling at it. I've tried searching to see how to change that one specific section - but found nothing. I've looked at the shortcut properties. I got nothing...

The OS is Lubuntu 18.04.4 LTS. That means the DE is LXDE.

It's trivial, but I'd like to fix it if possible.
 
Old 07-01-2020, 09:14 PM   #2
KGIII
Member
 
Registered: Sep 2015
Location: North-Western, Maine - in the mountains.
Distribution: Lubuntu 18.04 LTS
Posts: 108

Original Poster
Blog Entries: 4

Rep: Reputation: 46
By the way, this is my desktop:

https://i.postimg.cc/hvVpjXcR/20200626-002-1.png

As you can see, it's way too sexy to be sullied by that Chrome icon!
 
Old 07-02-2020, 04:04 AM   #3
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,942
Blog Entries: 9

Rep: Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226
Quote:
Originally Posted by KGIII View Post
You see this?

http://pix.toile-libre.org/upload/or...1593655751.png

Yeah! That's BS! It irks me far more than it should!

(...)

The OS is Lubuntu 18.04.4 LTS. That means the DE is LXDE.
Are you using the default lxpanel?
Is that Chrome, not Chromium? Isn't it understandable that a closed-source application from outside the repositories doesn't play ball? Why don't you use Chromium instead?
Even so, some workarounds are possible:
  • Can you find the icons in the browser's list of installed files? You could try to replace them with sth more suitable - this would need to be repeated after every browser upgrade.
  • If Chrome searches for icons elsewhere, try to place suitably named icons in e.g. /usr/share/pixmaps or /usr/share/icons/hicolor...
  • use a script around xseticon to change the icon after Chrom* has started
But my favourite workaround is this:
https://forums.bunsenlabs.org/viewto...d=58090#p58090
...and following posts by ohnonot...
https://forums.bunsenlabs.org/viewto...d=58155#p58155
https://forums.bunsenlabs.org/viewto...d=58222#p58222
Been using that method for years.
 
1 members found this post helpful.
Old 07-02-2020, 04:33 AM   #4
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 1,135

Rep: Reputation: Disabled
Well, I don't use Google Chrome, but for Chromium I get:
Code:
$ apt-file list chromium-browser|grep desktop$
chromium-browser: /usr/share/applications/chromium-browser.desktop
Locate the .desktop file for Chrome and look inside for the icon it uses. E.g. here it's for firefox:
Code:
$ grep ^Icon= /usr/share/applications/firefox.desktop
Icon=firefox
If it's just the icon name like above then Chrome searches for it in standard places ondoho wrote about: /usr/share/icons/hicolor/..., /usr/share/pixmaps/.

If it's a path then it's the path to the icon file.
 
1 members found this post helpful.
Old 07-02-2020, 02:08 PM   #5
KGIII
Member
 
Registered: Sep 2015
Location: North-Western, Maine - in the mountains.
Distribution: Lubuntu 18.04 LTS
Posts: 108

Original Poster
Blog Entries: 4

Rep: Reputation: 46
Thanks! I resolved it.

For some reason, the theme was installed but not present in usr/share/themes. This means I have no idea where the theme was actually installed - but simply elevating my permissions with the file manager let me drag and drop it.

No specific info helped - but it all led me to the right place. So, thanks!
 
Old 07-03-2020, 02:40 AM   #6
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,942
Blog Entries: 9

Rep: Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226
^ screenshot to prove it!
 
Old 07-03-2020, 07:55 AM   #7
KGIII
Member
 
Registered: Sep 2015
Location: North-Western, Maine - in the mountains.
Distribution: Lubuntu 18.04 LTS
Posts: 108

Original Poster
Blog Entries: 4

Rep: Reputation: 46
LOL Remind me. It's early morning so I'm outside w/my laptop, sucking up the cooler temperatures.

*makes note to self*

It started to sprinkle, so here you go:
http://pix.toile-libre.org/upload/or...1593788308.png

It's still not quite right - but it's close enough I think that's because there's a "high-color" theme and a more matte color theme. When I go through the /usr/share/themes folder, it's a damned mess. I *think* I installed some of the themes by copy/pasting the folders and not through the importation process and that's where the troubles (probably) began.

Also, it may have to do with the tornado of attempts that I made prior. I did stuff like hard-code icon paths in .desktop files and the likes. I made a true mess. I should probably preserve /home and reinstall, but it's not yet broken enough to warrant that.

Last edited by KGIII; 07-03-2020 at 09:21 AM.
 
Old 07-04-2020, 03:30 AM   #8
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,942
Blog Entries: 9

Rep: Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226Reputation: 4226
Icon themes go into /usr/share/icons, not /usr/share/themes, so I don't see how that could've helped.

In any case, it would mean that Chrome finds your icon only when it's under /usr/share? I find that unlikely, but then, it being a closed source app that does not come from your distro's repositories, anything is possible.

Did you even apply that blue ACYL (that's what it is, right?) theme session-wide before?

I think it's more likely you "accidentally did the right thing" when editing those .desktop files.
 
Old 07-04-2020, 05:32 PM   #9
KGIII
Member
 
Registered: Sep 2015
Location: North-Western, Maine - in the mountains.
Distribution: Lubuntu 18.04 LTS
Posts: 108

Original Poster
Blog Entries: 4

Rep: Reputation: 46
I attribute it to dumb luck and trying everything - and I do mean everything.

And, yeah - I am pretty sure I installed it by the "customize look and feel" or directly with the OpenBox configuration app. Pretty sure...

Also, I drank last night and got bored. So, I now have a fresh install.

This amused me. It's amazing how quick I can put it back together again. I didn't even preserve home - but I did back my shit up and can just restore quite a bit of it by dragging and dropping.

I'll get to getting a good theme going and this time I'll take notes to make sure I can repeat getting the icon to work again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Lubuntu Is Finally Moving to LXQt by Default with the Lubuntu 18.10 Release LXer Syndicated Linux News 0 05-03-2018 12:18 AM
LXer: No Audio in Lubuntu? - Lubuntu Audio Configuration and Volume Control LXer Syndicated Linux News 0 05-22-2016 11:17 PM
LXer: Atolm GTK Theme + Clarity Icon Theme = Perfect for Dark Theme Fans LXer Syndicated Linux News 0 02-26-2011 11:50 PM
openoffice force default theme / no theme | dark theme fix H_TeXMeX_H LinuxQuestions.org Member Success Stories 1 03-08-2010 12:56 PM
kde / gtk cursor-theme / theme issue - gentoo imperfect Linux - Newbie 1 01-08-2006 05:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Desktop

All times are GMT -5. The time now is 09:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration