LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-31-2020, 12:22 PM   #1
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 246

Rep: Reputation: 24
How do I make my touchpad disabled when mouse plugged in, but able to turn it on by Fn+F6?


Hello all, I have a laptop Lenovo G580. My problem with it is Synaptics Touchpad. Every time when I power on my laptop I need to press Fn+F6 to disable touchpad. I can create udev rule that will disable touchpad if mouse is plugged, but if I do so, I can't enable touchpad by Fn+F6. How do I do this?
UPD. With synclient, I can change TouchPadOff setting, but it does nothing, using xinput --enable|disable I can enable or disable touchpad (but Synaptics Off property keeps unchanged, it also unchanged with Fn+F6).

Last edited by yars; 03-31-2020 at 12:58 PM.
 
Old 04-01-2020, 09:03 AM   #2
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,129

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
What desktop environment are you using?

In KDE (Plasma5) (ktown) this can be taken care of in System Settings, Input Devices, Touchpad, Enable/Disable Touchpad tab.
 
Old 04-01-2020, 10:22 AM   #3
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 246

Original Poster
Rep: Reputation: 24
I'm using Xfce. Yes, I know about mouse and touchpad settings dialog. I can comletely disable touchpad this way, but I tried to find a way to automate disabling (or ignoring) touchpad when external mouse is connected, and also should be possible to enable touchpad by Fn+F6. But some experiments and looking on the Web displays this is not so simple as seems. Main problem is the hardware (or it's firmware) does not interacts with the software (like xinput or synclient).
 
Old 04-01-2020, 12:30 PM   #4
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,943

Rep: Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141
doesn't xfce have a disable while typing? mine does, slack - current. xfce 4.12
 
Old 04-01-2020, 01:46 PM   #5
yars
Member
 
Registered: Apr 2012
Location: Russia
Distribution: Slackware64-current
Posts: 246

Original Poster
Rep: Reputation: 24
Quote:
Originally Posted by BW-userx View Post
doesn't xfce have a disable while typing?
Mine also does, but it's is only a great "workaround", not actually solution IMO. But I have no idea on how to fix this "problem".
UPD. I started this thread thinking that the solution is on the surface i.e. various scripts, etc, but later I realized that is not so simple as I was thiking. So I will continue using "disable touchpad while typing" option.
Thanks all.

Last edited by yars; 04-01-2020 at 02:03 PM.
 
Old 04-01-2020, 03:35 PM   #6
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,943

Rep: Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141Reputation: 2141
Quote:
Originally Posted by yars View Post
Mine also does, but it's is only a great "workaround", not actually solution IMO. But I have no idea on how to fix this "problem".
UPD. I started this thread thinking that the solution is on the surface i.e. various scripts, etc, but later I realized that is not so simple as I was thiking. So I will continue using "disable touchpad while typing" option.
Thanks all.
you might try creating some scripts, one that turns off your touchpad on startup/login. then another one that is in a loop looking for your F key input when it hits it turns your touchpad on and put them in your xfce4 startups, or some such thing like that.

I do not have a F key that turns it on and off.

just search the net to find the ole if on turn off, else turn on. then attach it to your shortcut to whatever F key you want.

Last edited by BW-userx; 04-01-2020 at 03:58 PM.
 
Old 04-01-2020, 03:53 PM   #7
slacker1337
Member
 
Registered: Jun 2012
Location: Connecticut, USA
Distribution: Slackware
Posts: 129

Rep: Reputation: 38
I would write a script that toggles between enabled and disabled, then map that script execution to the function key sequence you desire through xfce's Settings Manager:
https://forum.xfce.org/viewtopic.php?id=6528
 
Old 04-01-2020, 04:27 PM   #8
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,537

Rep: Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806
Quote:
Originally Posted by yars View Post
I'm using Xfce. Yes, I know about mouse and touchpad settings dialog. I can comletely disable touchpad this way, but I tried to find a way to automate disabling (or ignoring) touchpad when external mouse is connected, and also should be possible to enable touchpad by Fn+F6. But some experiments and looking on the Web displays this is not so simple as seems. Main problem is the hardware (or it's firmware) does not interacts with the software (like xinput or synclient).
FWIW, here's an old post of mine where I show how to implement a simple script to do this for any pointing device (no matter how it is being handled or the DE in question)...
https://www.linuxquestions.org/quest...5/#post5807829
 
Old 04-01-2020, 09:47 PM   #9
chrisretusn
Senior Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 1,129

Rep: Reputation: 465Reputation: 465Reputation: 465Reputation: 465Reputation: 465
I know you are using Xfce. Just to add, for the interest of others who might come across this thread. That you can disable the touchpad on plugin of a mouse in KDE (Plasma). I am using both a USB mouse and bluetooth mouse (two laptops). On plugin of the USB dongle the touchpad is disabled, removal enabled again. With the bluetooth mouse turning it on or off does it.
 
Old 04-01-2020, 10:53 PM   #10
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,537

Rep: Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806Reputation: 806
Quote:
Originally Posted by yars View Post
I'm using Xfce. Yes, I know about mouse and touchpad settings dialog. I can comletely disable touchpad this way, but I tried to find a way to automate disabling (or ignoring) touchpad when external mouse is connected, and also should be possible to enable touchpad by Fn+F6. But some experiments and looking on the Web displays this is not so simple as seems. Main problem is the hardware (or it's firmware) does not interacts with the software (like xinput or synclient).
Yes, the function key combo is used to enable/disable the touchpad by powering the hardware up or down. The DE function (or script approach) just does this by enabling/disabling the Xorg component.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Zenwalk 6.4 udev rules for disabling touchpad when usb mouse is plugged ?? hottdogg Zenwalk 0 11-21-2010 08:10 AM
LXer: How To Auto-Disable The Touchpad When The Mouse Is Plugged In (Fedora 13) LXer Syndicated Linux News 0 11-01-2010 11:40 AM
How to detect programatically if a USB device is is plugged-in / plugged out? franc Linux - Software 3 02-01-2007 04:01 AM
Un-plugged PS/2 mouse then plugged it into usb. mouse now dead deathman Mandriva 2 11-20-2006 07:35 AM
Plugged in mouse, dmesg said found, but don't know how to enable it. Gentoo Linux. RHLinuxGUY Linux - Hardware 0 07-21-2006 09:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:30 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration