LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 03-31-2020, 11:44 AM   #1
burning
Member
 
Registered: Jan 2020
Location: Canada
Distribution: Slackware
Posts: 66

Rep: Reputation: Disabled
trouble mounting CD drive. 'can't read superblock'


Following this tutorial here on how to mount my cd drive, I ran lsblk which listed my hard disk's partitions as well as
Code:
sr0  11:0  1  560M  0  rom
running dmesg | egrep -i --color 'cdrom|dvd|cd/rw|writer'
got me:
Code:
[    1.282433] ata2.00: ATAPI: MATSHITA DVD-RAM UJ-862, RB01, max UDMA/33
[    3.892214] scsi 3:0:0:0: CD-ROM    MATSHITA DVD-RAM UJ-862 
 RB01 PQ: 0 ANSI: 5
[    3.904345] sr 3:0:0:0: [sr0] scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.904508] cdrom: Uniform CD-ROM driver Revision: 3.20
upon attempting to mount the cd drive by doing mount -t iso9660 -o ro /dev/sr0 /mnt/cdrom , I got:
'mount: wrong fs type, bad option, bad superblock on dev/sr0, missing codepage or helper program or other error'

upon then trying mount -o ro /dev/sr0 /mnt/cdrom , instead it then gave me:
'mount: /dev/sr0: can't read superblock'

running dmesg | tail gives:
Code:
[1572.414852] sr 3:0:0:0: [sr0] tag#0 UNKNOWN(0x2003) Result: hostbyte=0x00 driverbyte=0x08
[1572.414866] sr 3:0:0:0: [sr0] tag#0 Sense key : 0x5 [current]
[1572.414874] sr 3:0:0:0: [sr0] tag#0 ASC=0x64  ASCQ=0x0
[1572.414882] sr 3:0:0:0: [sr0] tag#0 CDB: opcode=0x28 28 00 00 00 00 10 00 00 01 00
[1572.414889] blk_update_request: I/O error, dev sr0, sector 64
[1572.414930] isofs_fill_super: bread failed, dev=sr0, iso_blknum=16, block=16
For context, this is my first time trying to use the optical drive in this laptop. I put a music CD in the laptop's CD tray and upon trying the CD in my portable CD player, it plays perfectly fine, which implies the problem here is with the drive, not the disc.

Did I forget to do something?
for context, my cd drive is not in my /etc/fstab file

Last edited by burning; 03-31-2020 at 11:50 AM.
 
Old 03-31-2020, 12:33 PM   #2
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 543

Rep: Reputation: Disabled
You don't have to mount an audio CD in order to play it. Insert your CD, start your player of choice, & go.
Regards,
Bill
 
1 members found this post helpful.
Old 03-31-2020, 01:07 PM   #3
fatmac
Senior Member
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Posts: 3,548

Rep: Reputation: Disabled
A music CD has its own way of being created & does not have a regular file system.

If you just want to play it, use an audio program, if you want to put the tracks onto your computer, use a ripper, (cdparanoia is a good command line one).
 
1 members found this post helpful.
Old 04-01-2020, 02:29 PM   #4
TheRealGrogan
Member
 
Registered: Oct 2010
Location: Ontario, Canada
Distribution: Slackware, LFS, Manjaro (for gaming)
Posts: 376

Rep: Reputation: 247Reputation: 247Reputation: 247
Also, if you insert a blank DVD, you may see i/o errors in dmesg depending on your kernel version. Doesn't mean there's anything wrong, the kernel is just being silly.
 
1 members found this post helpful.
Old 04-01-2020, 02:50 PM   #5
uteck
Member
 
Registered: Oct 2003
Location: Elgin,IL,USA
Distribution: GalliumOS on Chrombook
Posts: 432

Rep: Reputation: 94
If the CD you are using is one you burnt yourself, or someone else did, it might have degraded and be unreadable. Writable drives use a layer of ink in the plastic that the laser etches, and that ink breaks down over time.
 
1 members found this post helpful.
Old 04-01-2020, 03:09 PM   #6
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,323

Rep: Reputation: Disabled
Hi,

Please insert the CD, then type in a terminal as root:
cd-info > info.txt
cd-drive > cddrive.txt
and attach both files info.txt and cddrive.txt to your next post.
 
1 members found this post helpful.
Old 04-01-2020, 03:58 PM   #7
slacker1337
Member
 
Registered: Jun 2012
Location: Connecticut, USA
Distribution: Slackware
Posts: 129

Rep: Reputation: 38
Are you sure it's an iso9660 format? Sounds like an issue I see at work on CDROM/DVD's that are burned from Windows as UDF.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting cdrom: can't read superblock thethinker Slackware 9 01-24-2008 09:53 PM
CDROM can't read/can't read superblock microomran Red Hat 1 07-05-2007 03:29 AM
"Can't Read Superblock" when mounting a second hard drive Maeltor Linux - Software 7 01-18-2007 01:13 PM
error mounting ext3 filesystem... mount: /dev/hdd1: can't read superblock versaulis Linux - Software 5 11-26-2006 08:34 PM
trouble mounting drive, bad superblock error mattuc Linux - Hardware 3 05-27-2004 10:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration