LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-15-2019, 10:49 PM   #1
shinanqu
LQ Newbie
 
Registered: Dec 2018
Posts: 16

Rep: Reputation: Disabled
How to install Gimp Heal Plugin?


Hello,

I would like to install the Heal tool (and all other tools coming with it) included in the Resynthesizer package:
https://github.com/bootchk/resynthesizer

As described, I installed gimp-plugin-registry from the repository. I can see now many new plugins in my Gimp 2.10.8, for example the resynthesizer module. I can use it without any issues.

But under Enhance are not new tools. No heal tool, no uncrop, no sharpen, no enlarge.

I tried to copy the plugin py files manually into the plugin folders (under home and under usr) and made them executable. It did not help, still no heal tool.

I tried search for a solution, but most threads about that topic are 5 years old.
 
Old 03-16-2019, 05:57 AM   #2
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,054
Blog Entries: 7

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
a heal tool is already part of gimp, no need to install. also sharpen (a filter).
 
Old 03-16-2019, 11:32 AM   #3
shinanqu
LQ Newbie
 
Registered: Dec 2018
Posts: 16

Original Poster
Rep: Reputation: Disabled
But as far as I know, the heal tool is a "tool", just like the Photoshop heal tool. It must be used manually. But what I want is something like the Photoshop "content aware fill". Filling large parts of the image with just one click. I think that's what the heal plugin is for.
 
Old 03-16-2019, 09:28 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,421

Rep: Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590Reputation: 2590
Heal is different then "Resysenthizer"

from your first post it looks good so far
it " should " work.

i am guessing there is an error in the source build

lets start from the top
step 1)
grab the master from github

step2)
there is a "aclocal.m4" in the source folder

needed for autotools to make a configure script
run
Code:
cd ( to the source folder) 
auroreconf -iv 
----- assuming that gimp is installed by the packagemanager ------
./configure --prefix=/usr 
make 
su
make install
i am guessing this IS what you did


PS.
i have been using resynthesizer for MANY MANY years .
since before it was on github -- aprox 2005 ish
http://www.logarithmic.net/pfh/resynthesizer


if the above is what you have done

i can uninstall and post a step by step install guide if needed
as i recall the scripts are NOT auto installed

Last edited by John VV; 03-16-2019 at 09:44 PM. Reason: added
 
Old 03-17-2019, 01:45 PM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 11,054
Blog Entries: 7

Rep: Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791Reputation: 2791
Quote:
Originally Posted by shinanqu View Post
As described, I installed gimp-plugin-registry from the repository. I can see now many new plugins in my Gimp 2.10.8, for example the resynthesizer module. I can use it without any issues.
so to me that sounds like everything is ok.
apparently you seem to be sure that there's something missing still.
please do not assume that evrybody knows about this package.

Quote:
But under Enhance are not new tools. No heal tool, no uncrop, no sharpen, no enlarge.
maybe you're looking in the wrong submenu?
 
Old 03-17-2019, 08:41 PM   #6
shinanqu
LQ Newbie
 
Registered: Dec 2018
Posts: 16

Original Poster
Rep: Reputation: Disabled
I found the solution! I didn't have Python support for Gimp installed. Perhaps that's the standard in the MX Linux repos? I don't know how it works... I just know, Python wasn't supported out of the box. I ran:
sudo apt install gimp-python
And now I have all I need! Thank you all for your answers!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SNAP my ssss this installed gimp and gimp no want to work right 2.10 gimp. BW-userx Linux - Software 1 12-07-2018 01:37 PM
LXer: GIMP Painter And GIMP Paint Studio Transform GIMP Into The Ultimate Painting Tool LXer Syndicated Linux News 0 02-08-2011 05:40 PM
LXer: Al Gore: Embedded Tech Can Help Heal the Earth LXer Syndicated Linux News 4 04-04-2007 12:18 PM
Samba heal thyself: connection problem disappears? LarryFrigginWachs Linux - Networking 1 12-29-2005 10:20 AM
gimp (1.3.21) and gimp-perl - need help installing gimp-perl keex Slackware 0 10-22-2003 03:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration