LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-03-2019, 07:49 PM   #1
danielsender1
LQ Newbie
 
Registered: Nov 2017
Distribution: Ubuntu 16.04, Centos 7
Posts: 12

Rep: Reputation: Disabled
Ubuntu 18.04 does not longer support the Nvidia-304 driver


I have an older 32b Dell M70. It was running 16.04 fine but I had the bad idea of upgrading to 18.04. Everything went fine except for the display resolution, the screen has 1920x1200 max but it is not getting more than 1280x1024, that is highly distorted. Under 16.04 it was using the proprietary driver Nvidia-304 that is not longer supported in 18.04. So I enabled the graphic-drivers PPA and that driver appears to be available. However when I attempted to install it I get the following:
Code:
luka@falu:~$ sudo apt install nvidia-304
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:


The following packages have unmet dependencies:
 nvidia-304 : Depends: xorg-video-abi-11 but it is not installable or
                       xorg-video-abi-12 but it is not installable or
                       xorg-video-abi-13 but it is not installable or
                       xorg-video-abi-14 but it is not installable or
                       xorg-video-abi-15 but it is not installable or
                       xorg-video-abi-18 but it is not installable or
                       xorg-video-abi-19 but it is not installable or
                       xorg-video-abi-20 but it is not installable or
                       xorg-video-abi-23
              Depends: xserver-xorg-core
E: Unable to correct problems, you have held broken packages.
So I attempted to fix it under Nouveau doing the following. I had an old xorg.conf set by Nvidia (under 16.04) and I copied what I thought were the relevant lines, please see the original:
Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (buildd@komainu)  Mon Feb  3 15:11:14 UTC 2014




Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection


Section "Files"
EndSection


Section "InputDevice"


    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection


Section "InputDevice"


    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection


Section "Monitor"


    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Seiko/Epson"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection


Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro FX Go1400"
EndSection


Section "Screen"


# Removed Option "metamodes" "nvidia-auto-select @3840x1200 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "Stereo" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
So I copied the lines into /etc/X11/xorg.conf.d/20-monitor.conf relevant to the screen:
Code:
Section "Monitor"
        Identifier      "Monitor0"
        VendorName      "Unknown"
        ModelName       "Seiko/Epson"
        HorizSync       30.0 - 75.0
        VertRefresh     60
        Option          "DPMS"
EndSection


Section "Screen"
        Identifier      "Screen0"
        Device          "Device0"
        Monitor         "Monitor0"
        DefaultDepth    24
        SubSection "Display"
                Depth    24
                Modes     "1920x1200" "1280x1024"
        EndSubSection
EndSection
This didn't solve the issue. I also added two lines to /etc/default/grub:
Code:
GRUB_GFXMODE=1920x1200x24
GRUB_GFXPAYLOAD_LINUX=1920x1200
The resolution is still stuck at 1280x1024 - My question is: is there anything else that I should be doing?
Many thanks in advance.

Last edited by danielsender1; 12-03-2019 at 07:50 PM.
 
Old 12-04-2019, 12:07 AM   #2
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,948

Rep: Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595
Please provide X terminal output from:
Code:
inxi -GxxS
hwinfo --monitor
egrep -A12 'el command li|reating def' /var/log/Xorg.0.log
If the latter reports file not found, then instead:
Code:
egrep -A12 'el command li|reating def' /home/`whoami`/.local/share/xorg/Xorg.0.log
What you do not want to see in inxi output is either of the following:
Code:
X.Org 1.19.6 driver: fbdev
X.Org 1.19.6 driver: vesa
What is possible is that nomodeset was required for installation and now blocks both competent FOSS DDX, resulting in use of either of the crude, fallback FBDEV or VESA drivers. If that is the case it needs to be removed from /etc/default/grub and /boot/grub/grub.cfg (via update-grub). Also, xorg.conf and the files you created in xorg.conf.d/ should be removed. If any of those are actually warranted they will be considerably more svelte.

A quick test would be to use the E key at the Grub menu and if you find nomodeset on the line that begins with linu to remove it before proceeding to boot.

Note that for most non-ancient NVidia GPUs and GPUs newer than the OS release that there are two FOSS DDX. The newer is modesetting, provided as an xserver-xorg component. The older is nouveau, not to be confused with the nouveau kernel driver, and provided by xserver-xorg-video-nouveau.
 
1 members found this post helpful.
Old 12-04-2019, 12:44 AM   #3
danielsender1
LQ Newbie
 
Registered: Nov 2017
Distribution: Ubuntu 16.04, Centos 7
Posts: 12

Original Poster
Rep: Reputation: Disabled
The first command:
Code:
luka@falu:~$ inxi -GxxS
System:    Host: falu Kernel: 4.15.0-72-generic i686 bits: 32 gcc: 7.4.0
           Desktop: N/A dm: gdm3 Distro: Ubuntu 18.04.3 LTS
Graphics:  Card: NVIDIA NV41GLM [Quadro FX Go1400]
           bus-ID: 01:00.0 chip-ID: 10de:00cc
           Display Server: X.Org 1.19.6
           drivers: vesa,nouveau (unloaded: modesetting,fbdev)
           Resolution: 1920x1080@60.00hz, 1920x1200@59.95hz
           OpenGL: renderer: N/A version: N/A Direct Render: N/A
second command:
Code:
luka@falu:~$ sudo hwinfo --monitor
25: None 00.2: 10002 LCD Monitor                                
  [Created at monitor.97]
  Unique ID: aHB6.if5DRIOIB17
  Hardware Class: monitor
  Model: "UD366 LCD Monitor"
  Vendor: SEC "UD366"
  Device: eisa 0x3155 
  Resolution: 1920x1200@60Hz
  Size: 331x207 mm
  Year of Manufacture: 2005
  Week of Manufacture: 0
  Detailed Timings #0:
     Resolution: 1920x1200
     Horizontal: 1920 1968 2000 2208 (+48 +80 +288) -hsync
       Vertical: 1200 1202 1208 1220 (+2 +8 +20) -vsync
    Frequencies: 161.63 MHz, 73.20 kHz, 60.00 Hz
  Config Status: cfg=new, avail=yes, need=no, active=unknown
third command:
Code:
luka@falu:~$ egrep -A12 'el command li|reating def' /var/log/Xorg.0.log
[    59.721] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.15.0-72-generic root=UUID=f0590156-463e-417e-adce-dd652460cb84 ro quiet splash nomodeset pnpbios=off acpi=force
[    59.721] Build Date: 03 June 2019  08:10:35AM
[    59.721] xorg-server 2:1.19.6-1ubuntu4.3 (For technical support please see http://www.ubuntu.com/support) 
[    59.721] Current version of pixman: 0.34.0
[    59.721] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    59.721] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    59.721] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  3 08:40:16 2019
[    60.020] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    60.020] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    60.083] (==) No Layout section.  Using the first Screen section.
in /etc/default/grub I don't see any mention to VESA nor FBDEV, please take a look at it:
Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset pnpbios=off acpi=force"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

GRUB_GFXMODE=1920x1200x24
GRUB_GFXPAYLOAD_LINUX=1920x1200
Thanks.
 
Old 12-04-2019, 01:02 AM   #4
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,948

Rep: Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595
Quote:
Originally Posted by mrmazda View Post
A quick test would be to use the E key at the Grub menu and if you find nomodeset on the line that begins with linu to remove it before proceeding to boot.
Please do this, in order to assure that doing so permanently will not create other trouble, such as a persisting black screen after leaving the Grub menu.
 
1 members found this post helpful.
Old 12-04-2019, 01:06 AM   #5
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,948

Rep: Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595
Quote:
Originally Posted by danielsender1 View Post
in /etc/default/grub I don't see any mention to VESA nor FBDEV, please take a look at it:
That's not a place where either would be found. Where you do not want to see extensive mention of either is in Xorg.0.log at either location mentioned in comment #2.
 
1 members found this post helpful.
Old 12-04-2019, 01:15 AM   #6
danielsender1
LQ Newbie
 
Registered: Nov 2017
Distribution: Ubuntu 16.04, Centos 7
Posts: 12

Original Poster
Rep: Reputation: Disabled
The grub menu at start is not appearing so pushing 'e' does not show the boot menu, is there anything that I have to change in /etc/default/grub to get that screen?
 
Old 12-04-2019, 01:28 AM   #7
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,948

Rep: Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595
Change GRUB_TIMEOUT=0 to some number larger than 0 and/or comment the GRUB_TIMEOUT_STYLE=hidden line if it exists. Pressing the Shift key prior to appearance of the Grub menu also may work.
 
1 members found this post helpful.
Old 12-04-2019, 01:55 AM   #8
danielsender1
LQ Newbie
 
Registered: Nov 2017
Distribution: Ubuntu 16.04, Centos 7
Posts: 12

Original Poster
Rep: Reputation: Disabled
Smile

It worked!!! After testing at the grub menu, with the shift key (the timeout was already != 0) I saw the menu, deleted nomodeset and the resolution went to 1920x1200 - after I made it permanent in /etc/default/grub.

Many, many thanks!
 
Old 12-04-2019, 02:12 AM   #9
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 1,948

Rep: Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595Reputation: 595
Quote:
Originally Posted by danielsender1 View Post
Many, many thanks!
You're welcome. You can thank better by clicking the Yes link in posts you found helpful.

Please also mark the thread solved.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: NVIDIA 304.64 Driver Fixes Performance, New GPUs LXer Syndicated Linux News 0 11-07-2012 01:01 AM
LXer: NVIDIA 304.51 Linux Graphics Driver Released LXer Syndicated Linux News 0 09-25-2012 04:11 PM
LXer: Download Nvidia GeForce 304.43 Driver for Linux LXer Syndicated Linux News 0 08-28-2012 07:00 PM
LXer: NVIDIA 304.37 Linux Driver Brings 41 Official Changes LXer Syndicated Linux News 0 08-13-2012 05:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 06:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration