LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices


Reply
  Search this Thread
Old 12-03-2019, 09:03 AM   #1
Xi0N
LQ Newbie
 
Registered: Apr 2008
Distribution: Arch LINUX
Posts: 5

Rep: Reputation: 0
Ubuntu 14 - Grub "The disk drive for /boot is not ready yet or not present"


This looks like a race condition in which the LVM volumes are still not present when fstab is parsed.

I wanted to ask if there is any way to either load LVM earlier or let the OS wait longer for the LVM volumes to "exist" before try and mount them

I attached the error message at boot time: Rebooting the VM ends up booting after some retries.
Attached Thumbnails
Click image for larger version

Name:	picturemessage_m4c41hms.wmc.png
Views:	197
Size:	88.2 KB
ID:	32032  
 
Old 12-04-2019, 01:30 PM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,707

Rep: Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188Reputation: 1188
If it's purely a race condition, surely pressing w for wait should sort it?

Presuming a PC, surely it will have grabbed the 1st disk (sda1) at least, before discovering this is all a mess of lvm. /boot is small. Can't you move it to sda1?
 
Old 12-04-2019, 10:22 PM   #3
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, arch, ubuntu, others
Posts: 3,677

Rep: Reputation: 607Reputation: 607Reputation: 607Reputation: 607Reputation: 607Reputation: 607
add rootdelay=20 to grub linux line might help. If it does see if you can change to 10 and still get same results.
 
Old 12-07-2019, 07:35 PM   #4
Xi0N
LQ Newbie
 
Registered: Apr 2008
Distribution: Arch LINUX
Posts: 5

Original Poster
Rep: Reputation: 0
I'll try the rootdelay but it seems to me that over 8 disks (sdh or more) ubuntu 14 craps itself: scan-scsi-bus stops working (manually triggering the rescans work, though) and reducing the number of disks seems to mitigate the issue... weird.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error on bootup "the disk drive for /dev/mapper/... Is not ready yet or not present cryptolo Linux - Newbie 11 07-24-2014 01:20 PM
Infinite Grub Loop: GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB... beeblequix MEPIS 2 11-02-2013 11:56 PM
disk drive for / is not ready yet or not present arunkumarev Linux - Newbie 3 10-09-2012 12:25 AM
The disk drive for /mnt/st is not yet ready or not present saeedsssss Linux - Newbie 1 09-24-2012 02:35 PM
grub/boot problem: the disk drive for /windows/c is not yet ready or is not present bth73 Linux Mint 5 07-05-2012 01:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu

All times are GMT -5. The time now is 01:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration