LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
  Search this Thread
Old 09-13-2020, 03:55 PM   #1
chainlynx
LQ Newbie
 
Registered: Sep 2020
Posts: 1

Rep: Reputation: Disabled
Unable to boot into ubuntu server 20.04


Hello everyone. This is my first post in this forum and if I posted this in the wrong spot, admins feel free to move. So my issue in a nutshell is that my Ubuntu Server Machine is not booting into the OS.

The machine is a Dell Precision T7600
-Dell PERC H710P HBA
-4 Hitachi 2TB HDDs
-32GB RAM ECC
-Intel Xeon E5-2609
-Ubuntu Server 20.04

This issue randomly started happening after an update. When I turn on the machine I am greeted to a grub prompt. Unfortunately I have tried some things that probably have made things worse. I have used Ubuntu desktop bootable media to access a terminal and used the boot-repair tool several times. the last time I used it and tried to boot the machine up, the grub prompt is gone and now its a grub rescue screen.

I dont know what to do

Currently im following the steps here: https://help.ubuntu.com/community/Grub2/Installing

trying to reinstall GRUB2

Im at the point when I am trying to run:
sudo grub-install --boot-directory=/boot /dev/sda2

The output is:

Installing for i386-pc platform
grub-install: error: failed to get canonical path of '/cow'

The last time I ran the boot-repair tool, I received this URL:

https://paste.ubuntu.com/p/b5DZxY49WW/

Any idea how I can proceed? I use this machine as a file server and it hosts my plex media server
 
Old 09-15-2020, 02:52 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 20,138

Rep: Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178Reputation: 3178
"randomly started happening after an update"

I'd assume some update may have caused it. Some timing I'd think. Try to boot to previous kernel and see if it still fails.

Doubt fixing grub or other deals will fix it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Buster - unable to boot, unable to recreate boot bits Mark Nagel Debian 10 05-07-2020 10:44 PM
[SOLVED] Unable to boot into ubuntu 12.04 after trying to connect to a 2nd HD DPNoyes Linux - Newbie 58 03-22-2014 01:40 PM
Unable to boot into Windows 8 from Fedora dual boot. Linux_Noob14 Linux - Newbie 2 03-18-2014 04:10 PM
Unable to boot into Ubuntu after installing fedora 15 Kamal Reddy Linux - Newbie 3 08-13-2011 01:59 AM
Can only connect to internet if 1st boot into XP then restart & boot into Suse 10.1 axarq Linux - Networking 6 08-03-2006 08:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Server

All times are GMT -5. The time now is 09:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration