LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-12-2019, 11:18 PM   #1
squall852
LQ Newbie
 
Registered: Jun 2018
Posts: 10

Rep: Reputation: Disabled
Angry How to install Oracle XE 18c to Ubuntu 18c


Hello,

I'm trying to install Oracle XE for 2 days.

Really, I couldnt it... fk xD.

any suggertions to install, i followed oracle documentation, nothing.

Error:

root@tony:~/Downloads# sudo rpm -i oracle-database-xe-18c-1.0-1.x86_64.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
warning: oracle-database-xe-18c-1.0-1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
error: Failed dependencies:
file is needed by oracle-database-xe-18c-1.0-1.x86_64
net-tools is needed by oracle-database-xe-18c-1.0-1.x86_64
oracle-database-preinstall-18c is needed by oracle-database-xe-18c-1.0-1.x86_64
/bin/sh is needed by oracle-database-xe-18c-1.0-1.x86_64

Really i need help....

Thank everybody.
 
Old 02-13-2019, 01:09 AM   #2
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,594

Rep: Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936
https://docs.oracle.com/en/database/...C-C7319ED934F0

I do not really understand why do you want to install it on ubuntu. Why do you want to install anything on ubuntu with rpm (you need to use apt or dpkg).
You need to install failed dependecies first.
https://www.linuxquestions.org/quest...ntu-4175648146
 
1 members found this post helpful.
Old 02-13-2019, 01:41 AM   #3
AnanthaP
Member
 
Registered: Jul 2004
Location: Chennai, India
Distribution: UBUNTU 5.10 since Jul-18,2006 on Intel 820 DC
Posts: 885

Rep: Reputation: 208Reputation: 208Reputation: 208
As others said, Oracle XE 18c doesn't seem to be supported on .deb type distros.

Not to say it won't work but installation is not documented by oracle. So you may have to look at other developer sites that are oracle specific.

Here's a link to install XE 18c on rpm distros.
https://docs.oracle.com/en/database/...tabase-xe.html

It's got a line on first installing the "Database Preinstallation RPM".

OK
 
Old 02-13-2019, 06:48 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,377

Rep: Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572
Quote:
Originally Posted by squall852 View Post
Hello,
I'm trying to install Oracle XE for 2 days. Really, I couldnt it... fk xD. any suggertions to install, i followed oracle documentation, nothing.

Error:

root@tony:~/Downloads# sudo rpm -i oracle-database-xe-18c-1.0-1.x86_64.rpm
rpm: RPM should not be used directly install RPM packages, use Alien instead!
rpm: However assuming you know what you are doing...
warning: oracle-database-xe-18c-1.0-1.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID ec551f03: NOKEY
error: Failed dependencies:
file is needed by oracle-database-xe-18c-1.0-1.x86_64
net-tools is needed by oracle-database-xe-18c-1.0-1.x86_64
oracle-database-preinstall-18c is needed by oracle-database-xe-18c-1.0-1.x86_64
/bin/sh is needed by oracle-database-xe-18c-1.0-1.x86_64

Really i need help....
Did you read what you posted?? It's very clearly telling you NOT to install an RPM package and to use Alien instead. Not a whole lot to be confused about with an error that plain. Past that, as others have said, did you read the instructions on Oracle's website? The parts where they tell you what OS'es are supported, and about Ubuntu *NOT* being on that list is also fairly plain.

Your error also included a list of packages that you don't have...again, nothing to be confused about. Either install them, or you can't install Oracle. Not sure how such plain errors can take days to understand.
 
Old 02-13-2019, 08:53 AM   #5
squall852
LQ Newbie
 
Registered: Jun 2018
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hello,

Thank to reply,

Well,

I know, I can't install RPM package and i need to use Alien to convert it to .DEB,

But when I tried, That give me a folder and not a .DEB package, on terminal give me a WARNING: Oracle-xe..... KEY. I read about that. ppl said, Its a space opt problem, but my disk have 1T of memory xD.

If Oracle XE 18c doesn't seem to be supported on .deb type distros, I've seem other version.

On the other hand, I've wanted to install Oracle since studies.

Maybe other way or I resign

Thank.
 
Old 02-13-2019, 09:03 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,377

Rep: Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572
Quote:
Originally Posted by squall852 View Post
Hello,
Thank to reply,
Well,

I know, I can't install RPM package and i need to use Alien to convert it to .DEB,
...so you tried to install the RPM anyway?
Quote:
But when I tried, That give me a folder and not a .DEB package, on terminal give me a WARNING: Oracle-xe..... KEY. I read about that. ppl said, Its a space opt problem, but my disk have 1T of memory xD.
And without knowing what the message was, what do you think we'll be able to tell you? You don't say what you typed in, what the error actually was, etc. And read the LQ Rules about text-speak, and not using it.
Quote:
If Oracle XE 18c doesn't seem to be supported on .deb type distros, I've seem other version. On the other hand, I've wanted to install Oracle since studies. Maybe other way or I resign
Again:
  • Post a CLEAR QUESTION with details
  • Do basic research first
  • Your installer gave you a list of packages to install first; so *INSTALL THEM*. Ignoring the requirements won't get you different results.
  • Oracle is **NOT SUPPORTED** on Ubuntu; again, you need to read the instructions and requirements that Oracle has on their own website, where you downloaded this software.
Either use CentOS or Fedora for this, or use MariaDB/MySQL instead.
 
Old 02-13-2019, 09:27 AM   #7
sevendogsbsd
Member
 
Registered: Sep 2017
Distribution: FreeBSD
Posts: 853

Rep: Reputation: Disabled
Oracle is not supported on any Debian distro, period. Read this: https://docs.oracle.com/en/database/...C-C7319ED934F0

Only Oracle Linux, Red at or SUSE. If you need this, I would suggest using CentOS as it is a Red Hat "clone" and is free.
 
1 members found this post helpful.
Old 02-13-2019, 11:04 PM   #8
squall852
LQ Newbie
 
Registered: Jun 2018
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hello,

wow relax TB0ne, I'll take your suggestions.

I've read a lot about this problem,

Thank sevendogsbsd, I saw to oracle 18c xe is not support by ubuntu.

so

I saw other alternative (Oracle 11g XE).

I could install this Oracle version.

Now, It is working with SqlDeveloper

Thank everybody.
 
Old 02-14-2019, 07:00 AM   #9
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,377

Rep: Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572
Quote:
Originally Posted by squall852 View Post
Hello,
wow relax TB0ne, I'll take your suggestions.
I was never not relaxed, thanks. Just didn't seem like you were paying attention or understanding what you were being told. You kept on about it.
Quote:
I've read a lot about this problem, Thank sevendogsbsd, I saw to oracle 18c xe is not support by ubuntu.
..which you should have looked up before downloading Oracle
Quote:
so
I saw other alternative (Oracle 11g XE). I could install this Oracle version. Now, It is working with SqlDeveloper
...and you're now numerous versions behind, won't have the latest features, and are running in a way that will make things harder for you. Rather than just loading CentOS and being done, or installing the missing packages.

Good luck.
 
Old 04-14-2019, 06:47 PM   #10
GhassanKhatib
LQ Newbie
 
Registered: Apr 2019
Posts: 2

Rep: Reputation: Disabled
I have the same problem. Broken dependencies, I installed the preinstall, and tried to install dependencies manually, still same result,
 
Old 04-15-2019, 01:21 AM   #11
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,594

Rep: Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936
and what is your problem exactly? What did you try?
 
Old 04-15-2019, 07:05 AM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,377

Rep: Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572
Quote:
Originally Posted by GhassanKhatib View Post
I have the same problem. Broken dependencies, I installed the preinstall, and tried to install dependencies manually, still same result,
Ok, so did you read what was told to the person who originally opened this thread?? Do basic research first, and provide details when asking a question. You have not, but more importantly, have you (as was told to the OP here), contacted Oracle for help with the product you are PAYING FOR??
 
Old 04-15-2019, 08:02 PM   #13
GhassanKhatib
LQ Newbie
 
Registered: Apr 2019
Posts: 2

Rep: Reputation: Disabled
TRIED TO INSTALL ORACLE

yum -y localinstall oracle-database-xe-18c-1.0-1.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-xe-18c-1.0-1.x86_64.rpm: oracle-database-xe-18c-1.0-1.x86_64
Marking oracle-database-xe-18c-1.0-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-xe-18c.x86_64 0:1.0-1 will be installed
--> Processing Dependency: file for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: net-tools for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: oracle-database-preinstall-18c for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: file
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: net-tools
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: oracle-database-preinstall-18c
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: /bin/sh
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

2. INSTALLED DEPENDENCY (THE RESULT IS FROM A SEDOND ATTEMPT, ALREADY INSTALLED BEFORE)

sudo apt-get install net-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
net-tools is already the newest version (1.60+git20161116.90da8a0-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

3. TRIED ORACLE INSTALLATION AGAIN - SAME ERROR

yum -y localinstall oracle-database-xe-18c-1.0-1.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-xe-18c-1.0-1.x86_64.rpm: oracle-database-xe-18c-1.0-1.x86_64
Marking oracle-database-xe-18c-1.0-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-xe-18c.x86_64 0:1.0-1 will be installed
--> Processing Dependency: file for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: net-tools for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: oracle-database-preinstall-18c for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: file
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: net-tools
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: oracle-database-preinstall-18c
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
Requires: /bin/sh
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest


4. TRIED TO INSTALL preinstall

yum -y localinstall oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm: oracle-database-preinstall-18c-1.0-1.el6.x86_64
Marking oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-preinstall-18c.x86_64 0:1.0-1.el6 will be installed
--> Processing Dependency: /bin/bash for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /etc/redhat-release for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: bc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: bind-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: binutils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: compat-libcap1 for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: compat-libstdc++-33 for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: ethtool for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: glibc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: glibc-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: initscripts for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: ksh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libaio for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libaio-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libgcc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libstdc++ for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libstdc++-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: make for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: module-init-tools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: net-tools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: nfs-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: openssh-clients for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: pam for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: procps for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: psmisc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: smartmontools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: sysstat for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: unzip for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: util-linux-ng for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: xorg-x11-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: xorg-x11-xauth for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /etc/redhat-release for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/bash for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: ethtool
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: glibc-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: libaio-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: procps
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: module-init-tools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: initscripts
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: openssh-clients
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: /etc/redhat-release
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: libstdc++-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: compat-libstdc++-33
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: psmisc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: glibc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: bc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: binutils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: nfs-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: make
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: xorg-x11-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: compat-libcap1
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: xorg-x11-xauth
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: /bin/bash
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: sysstat
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: smartmontools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: net-tools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: bind-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: unzip
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: pam
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: ksh
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: libaio
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: libstdc++
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: util-linux-ng
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: /bin/sh
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
Requires: libgcc
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

5. TIRED TO INSTALL DEPENDENCY

sudo apt-get install binutils


6. TRIED TO INSTALL preinstall AGAIN

same missing dependencies
 
Old 04-16-2019, 12:53 AM   #14
pan64
LQ Guru
 
Registered: Mar 2012
Location: Hungary
Distribution: debian/ubuntu/suse ...
Posts: 12,594

Rep: Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936Reputation: 3936
ok, now please try to read and understand post #2 and post #3. By the way, what kind of OS do you have (exactly)?
 
Old 04-16-2019, 07:05 AM   #15
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,377

Rep: Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572Reputation: 5572
Quote:
Originally Posted by GhassanKhatib View Post
TRIED TO INSTALL ORACLE
Code:
yum -y localinstall oracle-database-xe-18c-1.0-1.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-xe-18c-1.0-1.x86_64.rpm: oracle-database-xe-18c-1.0-1.x86_64
Marking oracle-database-xe-18c-1.0-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-xe-18c.x86_64 0:1.0-1 will be installed
--> Processing Dependency: file for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: net-tools for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: oracle-database-preinstall-18c for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: file
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: net-tools
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: oracle-database-preinstall-18c
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
2. INSTALLED DEPENDENCY (THE RESULT IS FROM A SEDOND ATTEMPT, ALREADY INSTALLED BEFORE)
Code:
sudo apt-get install net-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
net-tools is already the newest version (1.60+git20161116.90da8a0-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
3. TRIED ORACLE INSTALLATION AGAIN - SAME ERROR
Code:
yum -y localinstall oracle-database-xe-18c-1.0-1.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-xe-18c-1.0-1.x86_64.rpm: oracle-database-xe-18c-1.0-1.x86_64
Marking oracle-database-xe-18c-1.0-1.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-xe-18c.x86_64 0:1.0-1 will be installed
--> Processing Dependency: file for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: net-tools for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: oracle-database-preinstall-18c for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-xe-18c-1.0-1.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: file
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: net-tools
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: oracle-database-preinstall-18c
Error: Package: oracle-database-xe-18c-1.0-1.x86_64 (/oracle-database-xe-18c-1.0-1.x86_64)
           Requires: /bin/sh
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
4. TRIED TO INSTALL preinstall
Code:
 yum -y localinstall oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm
Setting up Local Package Process
Examining oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm: oracle-database-preinstall-18c-1.0-1.el6.x86_64
Marking oracle-database-preinstall-18c-1.0-1.el6.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package oracle-database-preinstall-18c.x86_64 0:1.0-1.el6 will be installed
--> Processing Dependency: /bin/bash for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /etc/redhat-release for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: bc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: bind-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: binutils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: compat-libcap1 for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: compat-libstdc++-33 for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: ethtool for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: glibc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: glibc-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: initscripts for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: ksh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libaio for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libaio-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libgcc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libstdc++ for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: libstdc++-devel for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: make for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: module-init-tools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: net-tools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: nfs-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: openssh-clients for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: pam for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: procps for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: psmisc for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: smartmontools for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: sysstat for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: unzip for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: util-linux-ng for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: xorg-x11-utils for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: xorg-x11-xauth for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /etc/redhat-release for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/bash for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Processing Dependency: /bin/sh for package: oracle-database-preinstall-18c-1.0-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: ethtool
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: glibc-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: libaio-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: procps
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: module-init-tools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: initscripts
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: openssh-clients
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: /etc/redhat-release
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: libstdc++-devel
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: compat-libstdc++-33
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: psmisc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: glibc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: bc
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: binutils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: nfs-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: make
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: xorg-x11-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: compat-libcap1
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: xorg-x11-xauth
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: /bin/bash
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: sysstat
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: smartmontools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: net-tools
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: bind-utils
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: unzip
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: pam
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: ksh
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: libaio
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: libstdc++
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: util-linux-ng
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: /bin/sh
Error: Package: oracle-database-preinstall-18c-1.0-1.el6.x86_64 (/oracle-database-preinstall-18c-1.0-1.el6.x86_64)
           Requires: libgcc
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
5. TIRED TO INSTALL DEPENDENCY
Code:
sudo apt-get install binutils
6. TRIED TO INSTALL preinstall AGAIN
same missing dependencies
AGAIN, since you ignored things the first time:
  • Have you contacted Oracle for assistance?? Oracle is **NOT FREE**, so since you're PAYING for it (RIGHT???), you can call them for help.
  • Have you done basic research?? The supported systems are clearly listed on Oracle's website; Ubuntu isn't on that list.
There were numerous suggestions in this very thread, which you apparently have just ignored. Also, when posting huge chunks of output, put it in CODE tags (again: see the LQ Rules and posting guidelines).

You **WILL NOT** get Oracle 18x to run on Ubuntu. Period. Load a supported OS and contact Oracle for assistance with the commercial product you have.
 
  


Reply

Tags
oracle


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Oracle 11g R1 install on Oracle Enterprise Linux martymedina Linux - Newbie 4 10-27-2013 01:24 PM
Cannot install DBD::Oracle perl module with Oracle 11.2.0.3 client Newbie_vin Linux - General 1 09-02-2012 01:00 PM
[SOLVED] oracle 11g install - oracle user passwd- Authentication Token Maniperror cdhar Linux - Newbie 3 08-21-2012 09:48 PM
Oracle redhat6.1 x86 install Oracle 11g r2 error. reconcil Linux - Newbie 3 11-03-2011 10:11 AM
xhost + as user oracle not working, need to see oracle install GUI enzo250gto Linux - Software 2 02-11-2007 11:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration