LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS
User Name
Password
CentOS This forum is for the discussion of CentOS Linux. Note: This forum does not have any official participation.

Notices


Reply
  Search this Thread
Old 02-13-2019, 10:59 AM   #1
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: MID-SOUTH USA
Distribution: Slackware 14.2 current / ArcoLinux / Void Linux
Posts: 8,515

Rep: Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775Reputation: 1775
automount setup not taking hold...


(much of nothing works in initial install?) don't answer that..

I did this to try and get auto mount to work for usb ports, as it is not even trying to mount anything i plug into the usb ports.

using system settings (KDE) I went into removable devices and turned on automount, that did not work so I did this


How to configure the autofs daemon on CentOS 7/Rhel 7


Code:
[userx@centoast ~]$  sudo yum install autofs
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.dc2.hackingand.coffee
 * epel: mirror.compevo.com
 * extras: repos-tx.psychz.net
 * nux-dextop: mirror.li.nux.ro
 * updates: repos-tx.psychz.net
Package 1:autofs-5.0.7-99.el7.x86_64 already installed and latest version
Nothing to do
[userx@centoast ~]$ sudo systemctl enable --now autofs
rebooted still nothing... the only off board thing working is my SD Card reader that has a card always plugged into it.

Last edited by BW-userx; 02-13-2019 at 11:00 AM.
 
Old 02-14-2019, 02:06 AM   #2
jsbjsb001
Senior Member
 
Registered: Mar 2009
Location: Earth? I would say I hope so but I'm not so sure about that... I could just be a figment of your imagination too.
Distribution: CentOS at the time of this writing, but some others over the years too...
Posts: 2,684

Rep: Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388Reputation: 1388
Hi BW,

While I'm not entirely sure if you mean "automount via the command-line" or "automount via KDE", since you mention KDE system settings; if you right click on the little USB icon for the "Device Notifier" applet in the main KDE panel (where the menu for your apps are, etc), then click on "Device Notifier Settings", you should see a dialog box come up (make sure you haven't locked widgets). Then in that dialog box, click on "Removable Devices", and if I'm understanding your question correctly, you should see the option you're after - just enable it. You might also need to have a look at the options below the main option there, to make sure it automount's your USB's the way you want, like for example "when attached", or "when it's been manually mounted before", etc.

But here's the essential bit that you may have missed; you MUST select your USB under "Device Overrides" below the same options I was talking about before! Or as I found out myself, it will NOT work. You'll see two options being "Automount at Login" and "Automount on Attach", so it depends on exactly what you want as to which one you choose. You only need to choose one of those options.

I've attached a screenshot of the settings I'm talking about for you below.

Also, the "autofs" package is installed by default in CentOS 7. But you will need to enable the "autofs" service though, as it is not enabled by default. I did not need to make any changes to the "autofs" service, or "autofs" itself though. But if you were talking about NFS shares or other networking shares, then you most likely would need to do some more config to get that working.

Note: I use KDE4 myself, so my advice above is for KDE4. I DID test this and it does work. I'm not sure what it is in KDE5 though.
Attached Thumbnails
Click image for larger version

Name:	kde-automounter.png
Views:	3
Size:	66.3 KB
ID:	29795  

Last edited by jsbjsb001; 02-14-2019 at 02:20 AM. Reason: added notes about autofs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup VMWare hard disks on a guets to hold certain Linux Directories JockVSJock Linux - Virtualization and Cloud 2 02-24-2015 09:17 PM
Unable to Automount ISO image unless automount is running in foreground! swests Linux - General 4 05-22-2009 12:47 AM
CentOS 5.2 Automount isos in fstab \other methods that work?automount iso Frankly3D Linux - General 6 07-13-2008 12:34 PM
LXer: Open source storage taking hold LXer Syndicated Linux News 0 07-30-2006 06:03 AM
Hold my hand while I setup my ADSL. cmack Linux - Networking 1 08-06-2003 03:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > CentOS

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration